Bug 829646 - askbot requires django-authenticator = 0.1.4
askbot requires django-authenticator = 0.1.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: askbot (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 04:20 EDT by Matthias Runge
Modified: 2012-06-24 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 14:54:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Runge 2012-06-07 04:20:05 EDT
Description of problem:
askbot has broken dependencies in the rawhide tree:
On x86_64:
	askbot-0.7.39-1.fc17.noarch requires django-authenticator = 0:0.1.4
On i386:
	askbot-0.7.39-1.fc17.noarch requires django-authenticator = 0:0.1.4
Please resolve this as soon as possible.

django-authenticator in rawhide has version 0.1.5

askbot requirements list:
akismet
django==1.3.1
Jinja2
Coffin>=0.3
South>=0.7.1
oauth2
Lamson
markdown2
html5lib==0.90
django-keyedcache
django-threaded-multihost
django-robots
unidecode
django-countries==1.0.5
django-celery==2.2.7
django-kombu==0.9.2
django-followit
django-recaptcha-works
python-openid
pystache==0.3.1
pytz

(no django-authenticator?) Can that requirement just get removed?
Comment 1 Matthias Runge 2012-06-07 04:26:48 EDT
asked at askbot.org, too
http://askbot.org/en/question/7805/askbot-requirements
Comment 2 Matthias Runge 2012-06-07 06:41:07 EDT
ok, it seems like django-authenticator-0.1.5 differs from 0.1.4 very slightly.

Imho, it just doesn't install some binary in /usr/bin, which 0.1.4 in fedora didn't do anyway.
Comment 3 Matthias Runge 2012-06-08 07:27:50 EDT
Answer from askbot upstream: 

We won't be using or supporting the django-authenticator app, at least in the foreseeable future. But support of django 1.4 will come of course, but we are not there yet.
Comment 4 Matthias Runge 2012-06-24 14:54:29 EDT
altered askbot to drop versioned requirement of django-authenticator.

Note You need to log in before you can comment on or make changes to this bug.