Bug 829650 - inconsistency in database, webUI X xmlrpc
inconsistency in database, webUI X xmlrpc
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Database (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: jianchen
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 04:30 EDT by Petr Sklenar
Modified: 2015-12-01 00:34 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 23:10:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-06-07 04:30:55 EDT
Description of problem:
There is issue with xmlrpc info about testcase.author and testcase.tester.
WebUI uses bugzilla login and xmlrpc uses full names.
The worst thing is that tester is None instead of some name many times 

Lets compare testcase number: 146417

Version-Release number of selected component (if applicable):
Nitrate 3.7.0 © 2011 Red Hat, Inc. All rights reserved.

How reproducible:
deterministic

Steps to Reproduce:
1, [psklenar@dhcp-25-114 tcmsinfo]$ python
Python 2.6.6 (r266:84292, Apr 11 2011, 15:50:32) 
[GCC 4.4.4 20100726 (Red Hat 4.4.4-13)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import Nitrate
>>> print Nitrate.TestCase(146417).author
Jan Scotka
>>> print Nitrate.TestCase(146417).tester
None
>>> 

Actual results:
author is Jan Scotka - not bugzilla login
tester is NONE
compare with: https://tcms.engineering.redhat.com/case/146417/


Expected results:
author is bugzilla login
    Author : jscotka@redhat.com

tester is  bugzilla login
   Default Tester : ebalintn@redhat.com

Additional info:
I can see it at many testcases. There are some inconsistency in database.
Comment 1 jianchen 2012-06-20 23:05:08 EDT
(In reply to comment #0)
> Description of problem:
> There is issue with xmlrpc info about testcase.author and testcase.tester.
> WebUI uses bugzilla login and xmlrpc uses full names.
> The worst thing is that tester is None instead of some name many times 
> 
> Lets compare testcase number: 146417
> 
> Version-Release number of selected component (if applicable):
> Nitrate 3.7.0 © 2011 Red Hat, Inc. All rights reserved.
> 
> How reproducible:
> deterministic
> 
> Steps to Reproduce:
> 1, [psklenar@dhcp-25-114 tcmsinfo]$ python
> Python 2.6.6 (r266:84292, Apr 11 2011, 15:50:32) 
> [GCC 4.4.4 20100726 (Red Hat 4.4.4-13)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import Nitrate
> >>> print Nitrate.TestCase(146417).author
> Jan Scotka
> >>> print Nitrate.TestCase(146417).tester
> None
> >>> 
> 
> Actual results:
> author is Jan Scotka - not bugzilla login
> tester is NONE
> compare with: https://tcms.engineering.redhat.com/case/146417/
> 
> 
> Expected results:
> author is bugzilla login
>     Author : jscotka@redhat.com
> 
> tester is  bugzilla login
>    Default Tester : ebalintn@redhat.com
> 
> Additional info:
> I can see it at many testcases. There are some inconsistency in database.

This inconsistency raise because the WebUI display author/tester email address but not the username of the user.
The XML-RPC's return user's username.
 
In [1]: s = nitrate.NitrateKerbXmlrpc('https://tcms.engineering.redhat.com/xmlrpc/').server
In [2]: s.TestCase.get(146417)['default_tester']
Out[2]: 'ebalintn'
In [3]: s.TestCase.get(146417)['author']
Out[3]: 'jscotka'

Check the https://tcms.engineering.redhat.com/accounts/ebalintn/profile/ this contains three field like "username", "name", "email".
Thanks.
Comment 2 jianchen 2012-06-25 23:10:41 EDT
This is not a bug, closed.
If you have any suggestions, re-open freely.

Note You need to log in before you can comment on or make changes to this bug.