Bug 829663 - after updating systemd from 44-8 to 44-12 : display error on startup
after updating systemd from 44-8 to 44-12 : display error on startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 04:57 EDT by jefnode
Modified: 2012-06-07 06:53 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 05:01:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jefnode 2012-06-07 04:57:58 EDT
Description of problem:


Version-Release number of selected component (if applicable):


systemd-44-8.fc17.x86_64
systemd-sysv-44-8.fc17.x86_64


How reproducible:

update systemd from 44-8 to 44-12

Steps to Reproduce:
1.install Fedora 17 from live kde iso
2.update all packages
3.reboot and notes the changes on system boot
(press <esc> to disable plymouth splash and see boot process)
  
Actual results:

width systemd v44-12
http://fpaste.org/iA1E/
(from cat /var/log/boot.log)

Expected results:

with systemd v44-8
http://fpaste.org/OLBj/
(from cat /var/log/boot.log)

Additional info:
Comment 1 Michal Schmidt 2012-06-07 05:01:55 EDT
In the future please add attachments directly to Bugzilla. Do not refer to external paste services.

I do not see any errors in the output.

If you're reporting that the "[ OK ]" marks are now on the left, this is a an intentional change. Having them on the right made it hard to see what messages they belong to on wide terminals.
Comment 2 jefnode 2012-06-07 05:14:12 EDT
why I submitted this "problem" as a bug

=========================================================
On 06/04/2012 02:35 PM I wrote :

hello,

I would like to know if it was possible to obtain a display option in
systemd to restore the "[ OK ]", on system boot, on the right of the
screen, like the good old SystemV. anyway great job!

Sincerely, jef

==> REPLY : (from Rahul Sundaram, systemd packages maintainer)

Hi jef,

Recent versions of systemd already do this

Rahul

==> REPLY

hello Rahul,

thank you for your response.
However, I think Ihave the latest stable release of systemd: systemd-44-12.fc17.x86_64.

and since the update from fedora 16 to fedora 17, systemd looks like this: http://fpaste.org/OLBj/

although in fact the "[ OK ]" were right before this update.

thank you in advance, jef

==> REPLY

You should use bugzilla to report issues.

https://fedoraproject.org/wiki/How_to_file_a_bug_report

Thanks

Rahul 
=========================================================

for me I don't think this "new stuff" is intentional, that is nonsense
Comment 3 Michal Schmidt 2012-06-07 05:28:55 EDT
(In reply to comment #2)
> ==> REPLY : (from Rahul Sundaram, systemd packages maintainer)

Rahul is listed as one of the co-maintainers of systemd, but he mostly works on other packages. The main maintaners of systemd in Fedora are Lennart, Kay and I. You can see this by looking at the rpm changelog.

> for me I don't think this "new stuff" is intentional, that is nonsense

I am the author of the change and I can say I made it intentionally. In the past we had complaints that the "[ OK ]" marks were too far from the text.

The only reason for keeping them on the right would be tradition. Which is a weak reason in my view.
Comment 4 Jóhann B. Guðmundsson 2012-06-07 05:43:24 EDT
Arguably we should only show [Failed] for services for example using the all famous car analogy you only get a light in your dashboard when something is wrong..

Or simply if doable color the text green for success and red for failure and be done altogether with [OK]/[Failed] since we no longer show [OK] or [Failed] when we start/restart/reload/stop services...
Comment 5 jefnode 2012-06-07 05:44:38 EDT
==
Rahul is listed as one of the co-maintainers of systemd, but he mostly works on other packages. The main maintaners of systemd in Fedora are Lennart, Kay and I. You can see this by looking at the rpm changelog.
==
I'm sorry for that mistake, I thought Rahul was one of the main maintainer (the only one I found while searching the Internet)

==
I am the author of the change and I can say I made it intentionally. In the past we had complaints that the "[ OK ]" marks were too far from the text.

The only reason for keeping them on the right would be tradition. Which is a weak reason in my view.
==
yes you probably right, Rahul didn't make it that way.

Now I better understand your perspective quite correct, is there a way to keep the old format for those who prefer the "tradition"?

Personally, this new layout is too "condensed", and if something goes wrong, there are effective ways that everyone already uses: systemd-analize, cat / var / log / boot.log etc. ...

most of the time, (and default) Fedora hide this stage by a splash screen.

PS : 
sorry if some turns of phrase have seemed rough, I'm still not quite comfortable with the nuances of the English language, systemd is a major step forward for Linux systems and its integration is very well done in Fedora
Comment 6 Michal Schmidt 2012-06-07 05:46:11 EDT
> Arguably we should only show [Failed] for services for example using the all
> famous car analogy you only get a light in your dashboard when something is
> wrong..

We used to have something like that in the beginning. People freaked out. Apparently watching the green OKs pass by has a soothing psychological effect.
Comment 7 Michal Schmidt 2012-06-07 05:48:44 EDT
(In reply to comment #5)
> is there a way to keep the old format for those who prefer the "tradition"?

No, the format is hardcoded in the source.
Comment 8 jefnode 2012-06-07 05:58:09 EDT
(In reply to comment #6)
> Apparently watching the green OKs pass by has a soothing psychological
> effect.

I confirm (and understand) but there is no real reason (at least in my case).

however, is not it better to let the opportunity for people to choose how the mistakes and successes are displayed beings?

maybe I say something stupid but why not remove plymouth and add options to GRUB_CMDLINE_LINUX (as quiet rhgb) to customize how the boot process is displayed?
Comment 9 Jóhann B. Guðmundsson 2012-06-07 06:04:04 EDT
(In reply to comment #6)
> > Arguably we should only show [Failed] for services for example using the all
> > famous car analogy you only get a light in your dashboard when something is
> > wrong..
> 
> We used to have something like that in the beginning. People freaked out.
> Apparently watching the green OKs pass by has a soothing psychological
> effect.

I would think passing the text in green or red would have the same soothing psychological effect while getting rid of the placement problem of the [OK]/[Failed]
Comment 10 Michal Schmidt 2012-06-07 06:07:57 EDT
(In reply to comment #8)
I am glad you took the effort to file this bugreport as you believed you were seeing a bug. And what you're saying is not stupid.
I just disagree with making everything configurable. It would also mean extra work for me.

(In reply to comment #9)
I don't think there's an actual problem at all. And I'm not touching that part of the code again in the near future.
Comment 11 Jóhann B. Guðmundsson 2012-06-07 06:12:16 EDT
(In reply to comment #8)
> (In reply to comment #6)
> > Apparently watching the green OKs pass by has a soothing psychological
> > effect.
> 
> I confirm (and understand) but there is no real reason (at least in my case).
> 
> however, is not it better to let the opportunity for people to choose how
> the mistakes and successes are displayed beings?
> 
> maybe I say something stupid but why not remove plymouth and add options to
> GRUB_CMDLINE_LINUX (as quiet rhgb) to customize how the boot process is
> displayed?

Having these customizable makes no sense and would just add unnecessary code to the code base. 

For desktop people want some graphical bootup and for embedded/servers you already monitor connectivity via snmp/munin/big brother aka hobbit/nagious/zenoss etc..
Comment 12 Jóhann B. Guðmundsson 2012-06-07 06:16:28 EDT
(In reply to comment #10)
> (In reply to comment #8)
> I am glad you took the effort to file this bugreport as you believed you
> were seeing a bug. And what you're saying is not stupid.
> I just disagree with making everything configurable. It would also mean
> extra work for me.
> 
> (In reply to comment #9)
> I don't think there's an actual problem at all. And I'm not touching that
> part of the code again in the near future.

We are a bit inconsistence in how we present this to the end user as on one hand we show [OK]/[Failed] at startup when service start and when they start and fail but not when you manually start the service via systemctl but yeah you are right this is so a first world problem ( non trivial )...
Comment 13 jefnode 2012-06-07 06:28:01 EDT
(In reply to comment #11)
> For desktop people want some graphical bootup and for embedded/servers you
> already monitor connectivity via snmp/munin/big brother aka
> hobbit/nagious/zenoss etc..

if anyone has more effective ways to scan the boot process to detect any error, why would optimize its use rather than keeping the traditional boot process and let people add the embellishments they want?

(In reply to comment #10)
> I just disagree with making everything configurable. It would also mean
> extra work for me.

this is not the very principle of Linux? (unlike Windows) everything is configurable via small text files, you just have to learn how!
Comment 14 Jóhann B. Guðmundsson 2012-06-07 06:43:30 EDT
(In reply to comment #13)
> (In reply to comment #11)
> > For desktop people want some graphical bootup and for embedded/servers you
> > already monitor connectivity via snmp/munin/big brother aka
> > hobbit/nagious/zenoss etc..
> 
> if anyone has more effective ways to scan the boot process to detect any
> error, why would optimize its use rather than keeping the traditional boot
> process and let people add the embellishments they want?
> 

With ever increasing boot speed you wont be able to "manually" inspect the boot process anymore for example if you have an ssd and you follow Harald's tuning recommendation [1] ( our distributions defaults are targeted at "everybody" which kinda sucks ) your boot process is ca 2 seconds essentially an blink of an eye and trying to spot [OK]/[Failed] is nearly impossible you will have to manually look at the log file once the machine has booted...

1. http://www.harald-hoyer.de/personal/blog/fedora-17-boot-optimization-from-15-to-3-seconds
Comment 15 jefnode 2012-06-07 06:53:12 EDT
(In reply to comment #14)

> trying to spot [OK]/[Failed] is nearly
> impossible you will have to manually look at the log file once the machine
> has booted...

I totally agree with that. so why want to change it. the "OK" on the right or left will change nothing. leave them all to the right ^ ^

> ( our distributions defaults are targeted at "everybody" which kinda sucks )

linux & co is not supposed to be an elitist system? I mean, that only those who take the time to look and learn can really appreciate all the capabilities of these technologies ?

Note You need to log in before you can comment on or make changes to this bug.