Bug 829688 - k3b is trying to use deprecated HAL
k3b is trying to use deprecated HAL
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: k3b (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: alpha
: 7.0
Assigned To: Radek Novacek
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 06:20 EDT by Martin
Modified: 2016-11-30 19:30 EST (History)
4 users (show)

See Also:
Fixed In Version: k3b-2.0.2-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 11:21:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-06-07 06:20:58 EDT
Description of problem:
k3b is trying to use deprecated HAL when probing optical drives.

Version-Release number of selected component (if applicable):
k3b-2.0.2-10.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Run k3b
  
Actual results:
k3b show error after start:

No optical drive found.
K3b did not find any optical device in your system.
Solution: Make sure HAL daemon is running, it is used by K3b for finding devices.

Expected results:
no error

Additional info:
Adding device "/org/freedesktop/UDisks2/Manager" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d0" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d1" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d2" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d3" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d4" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d5" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d6" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d7" 
Adding device "/org/freedesktop/UDisks2/block_devices/dm_2d8" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop0" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop1" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop2" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop3" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop4" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop5" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop6" 
Adding device "/org/freedesktop/UDisks2/block_devices/loop7" 
Adding device "/org/freedesktop/UDisks2/block_devices/sda" 
Adding device "/org/freedesktop/UDisks2/block_devices/sda1" 
Adding device "/org/freedesktop/UDisks2/block_devices/sda2" 
Adding device "/org/freedesktop/UDisks2/block_devices/sr0" 
Adding device "/org/freedesktop/UDisks2/drives/HITACHI_HTS723232A7A364_E3834563HJZB9N" 
Adding device "/org/freedesktop/UDisks2/drives/MATSHITADVD_RAM_UJ8A2_HK49_268806" 
k3b(2347)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory! 
k3b(2347)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory! 
k3b(2347)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory! 
k3b(2347)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory! 
k3b(2347) KSambaSharePrivate::findSmbConf: KSambaShare: Could not find smb.conf! 
"/org/freedesktop/UDisks2/block_devices/sr0" has new interfaces: ("org.freedesktop.UDisks2.Filesystem") 
"/org/freedesktop/UDisks2/block_devices/sr0" 's interface "org.freedesktop.UDisks2.Block" changed props: 
         modified: "IdLabel" : QVariant(QString, "Personal Data, Jul 04, 2011") 
         modified: "IdType" : QVariant(QString, "iso9660") 
         modified: "IdUsage" : QVariant(QString, "filesystem") 
         modified: "IdVersion" : QVariant(QString, "Joliet Extension") 
         modified: "Size" : QVariant(qulonglong, 2084864) 
         modified: "Symlinks" : QVariant(QDBusArgument, ) 
MEDIA CHANGED in "/org/freedesktop/UDisks2/block_devices/sr0" ; size is: 2084864
Comment 1 Bill Nottingham 2012-06-08 11:58:40 EDT
If that 'Additional info' is corect, it seems like it's at least trying to use udisks2 properly, and the error message about HAL is a bogus error message.
Comment 2 Radek Novacek 2012-06-12 04:13:35 EDT
k3b only uses HAL for locking the devices and it won't fail if there is no HAL in the system. It can be disabled but I don't see any harm to let it enabled.

However, this error message is wrong because HAL is not used for device discovery. I'll remove the line "Make sure HAL daemon is running, it is used by K3b for finding devices." from the dialog.
Comment 3 Martin 2012-06-12 04:25:36 EDT
Why bother user with error (in GUI):

"No optical drive found.
K3b did not find any optical device in your system."

Could you remove whole message from dialog? It makes no sense on RHEL7 and latest Fedora.
Comment 4 Radek Novacek 2012-06-12 04:38:44 EDT
I think that this error is quite important, IMHO user wants to know that k3b won't be much functional without optical drive. You can suggest this change to upstream, I've created bug in upstream bugzilla:

https://bugs.kde.org/show_bug.cgi?id=301711

For now, I've removed only that one line and committed it to rawhide (k3b-2.0.2-11.fc18). It will be dragged to RHEL-7 automatically, right?
Comment 6 Radek Novacek 2012-06-12 11:03:02 EDT
Another change, I've disabled HAL support completely. The HAL package is not even in Fedora, so it has been doing superfluous D-Bus call.

Note You need to log in before you can comment on or make changes to this bug.