Bug 829749 - Support for ppolicy external checker module
Support for ppolicy external checker module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 09:33 EDT by Guillaume Rousse
Modified: 2013-03-26 20:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: openldap-2.4.34-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 09:29:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openldap spec file patch (3.21 KB, patch)
2012-06-07 09:33 EDT, Guillaume Rousse
no flags Details | Diff

  None (edit)
Description Guillaume Rousse 2012-06-07 09:33:51 EDT
Created attachment 590204 [details]
openldap spec file patch

The attached patch adds an external checker module check_password.so to the openldap package, as it is quite difficult to build out of tree. See https://bugzilla.redhat.com/show_bug.cgi?id=812860 and http://www.openldap.org/its/index.cgi?findid=7283 for previous discussion.

This is actually a patch against latest rhel package, not against latest rawhide package, because I don't have such system available. I can eventually install one and rediff it again it that makes my demand more receivable.

Also, the patch is not self-sufficient, because it relies on original project tarball (from http://ltb-project.org/wiki/documentation/openldap-ppolicy-check-password) to be included also. I may eventually turn it into a self-sufficient patch, including its own makefile and source file, if considered better.
Comment 1 Fedora Admin XMLRPC Client 2013-01-30 06:10:52 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Jan Synacek 2013-03-01 03:19:54 EST
I will probably add this with the next openldap release.
Comment 3 Guillaume Rousse 2013-03-01 13:00:03 EST
For information, upstream inclusion has also been requested a second time, this time from original copyright owner:
http://www.openldap.org/its/index.cgi?findid=7412
Comment 5 Fedora Update System 2013-03-11 09:47:09 EDT
openldap-2.4.34-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openldap-2.4.34-1.fc18
Comment 6 Fedora Update System 2013-03-26 20:44:47 EDT
openldap-2.4.34-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.