Bug 829833 - Background error during gem install rhc with yard 0.7.5
Background error during gem install rhc with yard 0.7.5
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 12:03 EDT by Clayton Coleman
Modified: 2015-05-14 21:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhc-0.95.5-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2012-06-07 12:03:29 EDT
Running a gem install rhc on rhc .94+ from my local system

[error]: Unhandled exception in YARD::Handlers::Ruby::Legacy::ClassConditionHandler:
[error]:   in `lib/rhc/targz.rb`:7:

	 7: if File.executable?('/usr/bin/gnutar') then

[error]: ArgumentError: Invalid content for StatementList: nil:NilClass
[error]: Stack trace:
	/usr/lib/ruby/gems/1.8/gems/yard-0.7.5/lib/yard/parser/ruby/legacy/statement_list.rb:25:in `initialize'
	/usr/lib/ruby/gems/1.8/gems/yard-0.7.5/lib/yard/handlers/ruby/legacy/class_condition_handler.rb:77:in `new'
	/usr/lib/ruby/gems/1.8/gems/yard-0.7.5/lib/yard/handlers/ruby/legacy/class_condition_handler.rb:77:in `parse_else_block'

Doesn't seem to cause a failure.
Comment 1 Clayton Coleman 2012-06-15 13:34:13 EDT
Needs investigation - could be dropped to low severity if it's not serious.  Don't want to confuse users though.
Comment 2 Fabiano Franz 2012-06-19 12:25:01 EDT
Which Ruby version? Works for me with 1.9 under RVM.
Comment 3 Fabiano Franz 2012-06-19 12:58:18 EDT
Lowering severity since this is not blocker - rhc installs fine.
Comment 4 Clayton Coleman 2012-06-19 13:44:43 EDT
1.8.7 Fed 16 ruby - see stack trace.
Comment 5 Fabiano Franz 2012-06-28 17:37:11 EDT
Fixed.
Comment 6 Rony Gong 2012-07-01 23:27:30 EDT
retest on rhc-0.95.5.gem, fedora16, ruby-1.8.7

[root@localhost openshift]# gem install rhc
Successfully installed rhc-0.95.5
1 gem installed
Installing ri documentation for rhc-0.95.5...
Installing RDoc documentation for rhc-0.95.5...
[root@localhost openshift]#

Note You need to log in before you can comment on or make changes to this bug.