Bug 829869 - The system network services are not compatible with this version
The system network services are not compatible with this version
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 13:49 EDT by Nick Scavelli
Modified: 2014-10-05 06:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 03:06:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (1.09 MB, text/plain)
2012-08-09 00:23 EDT, anandshocking007
no flags Details

  None (edit)
Description Nick Scavelli 2012-06-07 13:49:28 EDT
Description of problem:
After restarting today I ran into my network icon not showing on top panel in gnome shell. When going into network settings I am graced with the wonderful message "The system network services are not compatible with this version".

Version-Release number of selected component (if applicable):
3.3.7-1.fc16.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in
2. Notice no network icon in top panel
3. System Settings->Network : Error message
  
Actual results:


Expected results:


Additional info:

NetworkManager seems to be running fine, I can actually connect to my wired connection, but can't access my network. Don't see any errors, "systemctl is-enabled NetworkManager.service && echo yes || echo no" produces enabled and yes.  Not sure what caused the issue but my guess is recent update to NetworkManager 0.9.4-6.git20120521.fc16 ?
Comment 1 Nick Scavelli 2012-06-07 17:17:03 EDT
Marking as notabug right now as it has seemed to fix itself somehow...
Comment 2 Nick Scavelli 2012-07-12 11:40:15 EDT
Reopening as I have found the cause of my issue. I get this error when my kvm switch (IOGear) is connected. Currently it's connected to my docking station, I have a thinkpad t510. I have yet to test connected directly to laptop.

Any help on where to look for issues would be appreciated.
Comment 3 Jirka Klimes 2012-07-24 10:14:58 EDT
It could be caused by dbus-glib, consider updating it (latest version is dbus-glib-0.98-2.fc16.x86_64).

If the problem still appears, please grab and attach /var/log/messages and ~/.xsession-errors so that we can see what's happening.
Comment 4 Nick Scavelli 2012-07-25 11:16:15 EDT
Looks like this is fixed now, thanks !
Comment 5 Jirka Klimes 2012-07-26 03:06:57 EDT
Great, closing then.
Comment 6 anandshocking007 2012-08-09 00:23:41 EDT
Created attachment 603163 [details]
/var/log/messages

Please find attached /var/log/messages file as suggested.
Comment 7 anandshocking007 2012-08-09 00:26:10 EDT
Sorry new here but my previous comment didn't get posted. I am facing same problem with same symptoms. My kernel version is 3.4.7-1 and dbus-glib version is same as mentioned above.
Output from ~/.xsession-errors


** (gnome-control-center:2332): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Method "GetAll" wi
th signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist


** (gnome-control-center:2332): WARNING **: fetch_connections_done: error fetching connections: (19) Method "ListConnections" with signature "" on interface "org.freedesktop.NetworkManager.Settings" doesn't exist
.

** (gnome-control-center:2332): WARNING **: _nm_remote_settings_ensure_inited: (NMRemoteSettings) error initializing: Method "GetAll" with signature "s" on interface "org.freedesktop.DBus.Properties" doesn't exist

Note You need to log in before you can comment on or make changes to this bug.