Bug 829884 - Use polkit .rules files instead of .pkla files
Use polkit .rules files instead of .pkla files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vdsm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Federico Simoncelli
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 14:16 EDT by David Zeuthen
Modified: 2013-02-21 03:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:54:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Zeuthen 2012-06-07 14:16:52 EDT
With polkit version 0.106, .rules files are used instead of .pkla files, see

 http://davidz25.blogspot.com/2012/06/authorization-rules-in-polkit.html

for more information. Therefore, please port the file

 /var/lib/polkit-1/localauthority/10-vendor.d/10-vdsm-libvirt-access.pkla

to use the new format. If you have any questions, I'm subscribed to this bug to help. Thanks.
Comment 1 Daniel Berrange 2012-06-08 12:04:46 EDT
Is there no backwards compatibility support for the existing .rules files in 0.106 ? I would have expected some overlap in support for both syntaxes for a couple of releases at least, to minimize the pain inflicted on both sysadmins & developers.
Comment 2 David Zeuthen 2012-06-08 12:16:22 EDT
(In reply to comment #1)
> Is there no backwards compatibility support for the existing .rules files in
> 0.106 ? I would have expected some overlap in support for both syntaxes for
> a couple of releases at least, to minimize the pain inflicted on both
> sysadmins & developers.

There is no backwards compatibility, no. The easiest is to just ship both a .pkla and a .rules file. I guess distributors can choose to include only the relevant file in their RPM (e.g. on F18 and newer you'd include the .rules file, on F17 and earlier you'd include the pkla file).
Comment 3 Federico Simoncelli 2012-09-26 09:43:10 EDT
A fix has been proposed upstream:

commit 3c5d4d23572b89bfed443d90163ae5ccddd87e38
Author: Federico Simoncelli <fsimonce@redhat.com>
Date:   Wed Sep 26 09:31:49 2012 -0400

    Support for the new polkit rules
    
    Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=829884
    Signed-off-by: Federico Simoncelli <fsimonce@redhat.com>
    Change-Id: I5de52881c60c54cd4874a8801d2705d0681f0824


http://gerrit.ovirt.org/#/c/8213/
Comment 4 Federico Simoncelli 2013-02-21 03:54:06 EST
The new polkit rules file is used since vdsm-4.10.1-1.fc18.

Note You need to log in before you can comment on or make changes to this bug.