Bug 8299 - kppp and userhelper breaks with X11 forwarding
Summary: kppp and userhelper breaks with X11 forwarding
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-08 22:41 UTC by Albert Strasheim
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 13:23:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Albert Strasheim 2000-01-08 22:41:08 UTC
When one fires up kppp on say, 192.168.1.1 from 192.168.1.3, using .3's
display, using openssh to manage X11 forwarding (although I imagine this
will be a common problem), the userhelper GTK password dialog pops up, asks
for the root password and then quits, leaving kppp unstarted.

Is this a problem with userhelper, X11 forwarding or kppp?

My second box will be returning to its owner soon, so I won't be able to
duplicate this bug much longer.

Comment 1 Nalin Dahyabhai 2000-01-13 23:01:59 UTC
Which version of openssh are you running?  Are there any error messages being
printed to the console by kppp?

Comment 2 Albert Strasheim 2000-01-14 17:21:59 UTC
I'm running openssh-1.2.1pre25-1 (with openssl-0.9.4-3), both built from SRPMS
found on http://www.firedrake.org/openssh/files/

There weren't any error messages, kppp just died silently.

Ditto with rp3-config. And this is with a connect to myself (ie.
ssh 192.168.1.1).

I hope I'm not barking up the wrong tree here, but most other apps I tried,
including GIMP and netscape worked fine.

Comment 3 Nalin Dahyabhai 2000-01-24 14:04:59 UTC
This is the first I've heard of this, but it sounds like it might be an obscure
usermode bug of some kind, so I can't be completely sure.  Are there any
error messages in /var/log/messages or /var/log/secure?  Is there any indication
of usermode crashing somehow (core dump, error messages, etc)?  When you ssh in
as root, does running /usr/sbin/kppp directly work?

Comment 4 Albert Strasheim 2000-01-25 17:44:59 UTC
When ssh'ing from a normal user under X to the root user, and executing kppp (as
root), I get the following error:

-- error start --

X11 connection rejected because of wrong authentication.

kppp: Fatal IO error: client killed

-- error end --

I assume running as root bypasses userhelper?

Ditto for ssh'ing from root to root. Also, for some strange reason, when I log
out, the ssh session refuses to die on the client side. Nothing of interest in
any of the logfiles.

Comment 5 Nalin Dahyabhai 2000-02-02 13:23:59 UTC
Programs gated by userhelper have a symlink in /usr/bin/<appname> that points
to userhelper, and userhelper's configuration file under
/etc/security/console.apps lists the "real" binary's location, which is almost
always in /usr/sbin.  Running this program from /usr/sbin bypasses userhelper
entirely if you're root, and should not work (or at least, not completely) as a
non-root user.

Comment 6 Nalin Dahyabhai 2000-08-29 14:32:56 UTC
Ah, this was a *very* specific usermode/pam_xauth interaction problem, which
should be solved by today's errata.


Note You need to log in before you can comment on or make changes to this bug.