This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 829901 - Wrong icon in taskbar and gnome dock
Wrong icon in taskbar and gnome dock
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tvtime (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 15:03 EDT by Alexei Panov
Modified: 2012-08-21 05:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-21 05:52:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wrong icon in taskbar (11.60 KB, image/png)
2012-06-07 15:03 EDT, Alexei Panov
no flags Details
Wrong icon in dock (87.73 KB, image/png)
2012-06-07 15:04 EDT, Alexei Panov
no flags Details
Correct icon in taskbar (37.10 KB, image/png)
2012-06-07 15:05 EDT, Alexei Panov
no flags Details
Correct icon in dock (41.32 KB, image/png)
2012-06-07 15:05 EDT, Alexei Panov
no flags Details
Wrong icon in dock (62.13 KB, image/png)
2012-08-13 07:35 EDT, Romka
no flags Details

  None (edit)
Description Alexei Panov 2012-06-07 15:03:37 EDT
Created attachment 590263 [details]
Wrong icon in taskbar

Description of problem:
Wrong icon in taskbar and gnome dock while the application is runned. See screenshots in attachments.

Version-Release number of selected component (if applicable):
tvtime-1.0.2-20.fc17

How reproducible:
all time

Steps to Reproduce:
1. install tvtime
2. run tvtime in Gnome 3
3.
  
Actual results:
Wrong icon

Expected results:
Correct icon

Additional info:
Comment 1 Alexei Panov 2012-06-07 15:04:38 EDT
Created attachment 590264 [details]
Wrong icon in dock
Comment 2 Alexei Panov 2012-06-07 15:05:08 EDT
Created attachment 590265 [details]
Correct icon in taskbar
Comment 3 Alexei Panov 2012-06-07 15:05:32 EDT
Created attachment 590266 [details]
Correct icon in dock
Comment 4 Romka 2012-06-27 06:11:52 EDT
What is not interesting to anyone?
It's a long time, with 15 version is a bug!
Comment 5 Tomas Smetana 2012-06-29 12:02:54 EDT
Hello,
  I confess: I'm not a Gnome 3 user and just to test this problem I would have to install Gnome 3 on a physical hardware...

I will gladly include a patch.  Feel free to suggest one.

Thanks and regards.
Comment 6 Alexei Panov 2012-07-03 17:30:35 EDT
Thank you, Thomas. 
We are very sorry that you do not use Gnome 3.
May be you paste patch here or URL to src.rpm?
Comment 7 Tomas Smetana 2012-08-06 04:12:34 EDT
All right. I found somebody to run tvtime on Gnome 3 to discover that this is indeed a tvtime problem: even though it sets the _NET_WM_ICON XWindow proerty it somewhat doesn't seem to work correctly.

Good news is that I don't need Gnome 3 to debug this issue so let me please tinker for a while.

Regards.
Comment 8 Fedora Update System 2012-08-06 07:00:25 EDT
tvtime-1.0.2-22.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tvtime-1.0.2-22.fc17
Comment 9 Alexei Panov 2012-08-07 07:43:53 EDT
Thank you Thomas. 1.0.2-22 has fixed this bug.
Comment 10 Fedora Update System 2012-08-09 19:22:43 EDT
Package tvtime-1.0.2-22.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tvtime-1.0.2-22.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11650/tvtime-1.0.2-22.fc17
then log in and leave karma (feedback).
Comment 11 Romka 2012-08-13 07:35:05 EDT
Created attachment 603967 [details]
Wrong icon in dock

That now looks like a dock with running tvtime.
The problem, unfortunately, is partially resolved, and is not correct. 
The second icon in the dock should not appear at all, but has highlighted the presence in there already as a favorite.
Thank you and good luck.
Comment 12 Tomas Smetana 2012-08-17 09:18:07 EDT
(In reply to comment #11)

> That now looks like a dock with running tvtime.

This did not happen before? I mean -- it looks rather odd that the changes I made to tvtime could cause this...

Do the others see the same problem?

I will have to find out how does Gnome-shell "group" the activities and then decide what might be wrong...
Comment 13 Tomas Smetana 2012-08-20 04:51:28 EDT
I will push my patch to stable repositories now and will try to find out how does Gnome-shell track the activities and what might be wrong with tvtime...  I suspect this has nothing to do with the WM_ICON.
Comment 14 Fedora Update System 2012-08-21 05:52:14 EDT
tvtime-1.0.2-22.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.