Bug 829991 - QE Feedback - Getting Started Guide - Tomas' General QE Feedback
QE Feedback - Getting Started Guide - Tomas' General QE Feedback
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 6.0.1
Assigned To: gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 19:10 EDT by Misha H. Ali
Modified: 2012-09-19 23:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 23:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-06-07 19:10:09 EDT
1) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/jboss-feedback.html
The following link will take you to a pre-filled bug report for this product: https://bugzilla.redhat.com/.
 
ad 1) It's link to bugzilla. I suppose to change link to: https://bugzilla.redhat.com/enter_bug.cgi?product=JBoss%20Data%20Grid%206
or provide "click-path" for users like: open bugzilla service homepage - NEW - JBOSS - Jboss Data Grid 6 - and fill info.
Now I can see that it works for "report a bug" - perfectly. Maybe you don't want to direct link on the first page, I see.
 
 
 
2) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Run_the_Clustered_Cache_with_Distribution_Mode.html
Result
JGroups and JBoss Data Grid initialized on the three nodes. After approximately fifteen seconds, the ten entries added by the third node can be seen as they are distributed to the first and second nodes.*
 
ad 2) asterisk after dot.*
 
 
 
3) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Register_the_Named_Cache_Using_XML.html
To configure the named cache declaratively (using XML) rather than programmatically, add the following code to the infinispan.xml file:
 
ad 3) And where EXACTLY user should add infinispan.xml file to his project. Maybe it could be better to provide this information too for immediate understanding.
 
 
 
 
4) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Customize_the_Default_Cluster_Configuration.html
 
Replace jgroups.xml with the desired file name.
 
AND THEN:
 
Declarative Configuration:
Use the following XML snippet to configure the JGroups properties to use JBoss Data Grid's XML configuration:
 
ad 4) Where we can find jgroups.xml? This file is not mentioned before - or I didn't notice. Probably user should create new config file - on which location? User maybe don't know whether this file is in his project or inside configuration of JDG server distribution.
  Where exactly to use this snippet? In which xml file?
 
 
Maybe I am silly but on the first read and only read I can't exactly recognize where all these configuration files should be, whether I should create them in project or there are created somewhere already.
I am sure that you know what I mean - I am trying to build the program and all config in my head while reading andI have found some misunderstanding.
Just discuss it with Martin or Tristan, or I will.
 
For example this is good enough, clear 100 %:
Edit the standalone.xml file (located at $JDG_HOME/standalone/configuration/) to add definitions for the datasource and infinispan subsystems.
 
 
 
5) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/The_Grouping_API.html
 
Each submodule (specifically hotrod-endpoint, rest-endpoint and memcached-endpoint contain a configuration file (located at $JDG_HOME/src/main/resources/jdg.properties). Edit the configuration to add default values for memcached and REST endpoints.
 
ad 5) Which default values? Where can user find them? I am first time user and I can't see ANY config/default values before. Or can I manage this? How? What is default value?
Comment 1 gsheldon 2012-06-08 01:45:26 EDT
2)  Removed asterix (*) from the end of the sentence:

"JGroups and JBoss Data Grid initialized on the three nodes. After approximately fifteen seconds, the ten entries added by the third node can be seen as they are distributed to the first and second nodes."

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Run_the_Clustered_Cache_with_Distribution_Mode.html

3) Moved section "Register the Named Cache Using XML".

This section now appears immediatly after " Load the Configuration File" to provide greater clarity, as per mgencur's feedback.
Section now appears as:

  6.5.4. Register the Named Cache Using XML 

and will appear on the stage after brew.

4) http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Customize_the_Default_Cluster_Configuration.html

 - added sentence including the directory for jgroups.xml:
 "The jgroups.xml file is located in $JDG_Quickstart/clustered-cache/src/main/resources/jgroups.xml."

  - added location of where to include declarative configuration. Documentation now reads: Use the following XML snippet in the infinispan.xml file to configure the JGroups properties to use JBoss Data Grid's XML configuration:

5)  http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/The_Grouping_API.html

 Removed reference to "default values" in Step 2: Edit the Submodule Configuration File.
 Now reads:
"Each submodule (specifically hotrod-endpoint, rest-endpoint and memcached-endpoint contain a configuration file (located at $JDG_HOME/src/main/resources/jdg.properties). Edit the configuration to specify the values required for your JBoss Data Grid installation."
Comment 2 gsheldon 2012-06-08 02:48:21 EDT
(In reply to comment #1)

> 3) Moved section "Register the Named Cache Using XML".
> 
> This section now appears immediatly after " Load the Configuration File" to
> provide greater clarity, as per mgencur's feedback.
> Section now appears as:
> 
>   6.5.4. Register the Named Cache Using XML 
>
Available http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Register_the_Named_Cache_Using_XML.html
> 

> 
> 5) 
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Getting_Started_Guide/The_Grouping_API.html

Corrected name on docstage:

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html-single/Getting_Started_Guide/index.html#Build_and_Deploy_an_Application_to_JBoss_Application_Server
> 
>  Removed reference to "default values" in Step 2: Edit the Submodule
> Configuration File.
>  Now reads:
> "Each submodule (specifically hotrod-endpoint, rest-endpoint and
> memcached-endpoint contain a configuration file (located at
> $JDG_HOME/src/main/resources/jdg.properties). Edit the configuration to
> specify the values required for your JBoss Data Grid installation."
Comment 3 Tomas Sykora 2012-06-08 03:39:57 EDT
Hi Gemma :-)

Thank you very much for your DOC updates. I am satisfied with it pretty much! I think these aspects are more clear for everyone since now.

Setting as verified because all my mentioned issues were fixed.

Note You need to log in before you can comment on or make changes to this bug.