Bug 829994 - QE Feedback - Getting Started Guide - Chapter 9
QE Feedback - Getting Started Guide - Chapter 9
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 19:15 EDT by Misha H. Ali
Modified: 2012-08-15 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 23:08:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-06-07 19:15:19 EDT
Chapter 9
---------

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-The_CartMart_Quickstart_Using_JBoss_Application_Server.html

The first step of the installation is now different as we ship our own maven repo in a zip file. So now we do not install libraries
with "mvn initialize -Pinit-repo" but rather install the repo. Contact Tristan for more information, he did these changes recently.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-The_CartMart_Quickstart_Using_Tomcat.html

The same as above.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-The_CartMart_Quickstart_in_Remote_Client-Server_Mode.html

Section 4. -> Edit the datagrid.properties file ....the file's name is jdg.properties now. It is actually there a few lines below.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/The_Grouping_API.html
(also related to Tomas' point 5)

Grouping API? ....This topic points to the football manager application. I wonder where is located the topic for Grouping API :)
The code snippets' formatting is awful. Could we make it better?

The sentence: "Each submodule (specifically hotrod-endpoint, rest-endpoint and memcached-endpoint contain...." is missing the right
parenthesis and "contain" should be "contains", IMO.

Regargin Tomas' comment on the following sentence: "Edit the configuration to add default values for memcached and REST endpoints. "

... the source distribution of quickstarts contains something a little different and IMO more understandable:
"Modify it to point to your JDG installation (default values should be fine for most cases)."

Section 2 should contain different description of additional steps for running HotRod endpoint example. Clarify with Tristan,
this is again related to the new maven repo in a zip file.
Comment 1 Misha H. Ali 2012-06-08 01:28:52 EDT
1. Need to get Tristan's input on this series of topics.

2. Fixed filename, it should now be jdg.properties.

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-The_CartMart_Quickstart_in_Remote_Client-Server_Mode.html

3. URLs for book fixed, some old topics names changed and the old fixed URLs remained.

New URL to follow brew.

4. Code snippet fixed, looks better now. 

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/sect-The_CartMart_Quickstart_in_Remote_Client-Server_Mode.html

Section 9.2. requires an update to the additional steps for Hot Rod. Will check with Tristan.
Comment 2 Misha H. Ali 2012-06-08 07:01:53 EDT
Last bit unresolved, setting back to modified.
Comment 3 Misha H. Ali 2012-06-11 04:52:40 EDT
(In reply to comment #1)
> 1. Need to get Tristan's input on this series of topics.
> 
> 2. Fixed filename, it should now be jdg.properties.
> 
> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Getting_Started_Guide/sect-The_CartMart_Quickstart_in_Remote_Client-
> Server_Mode.html
> 
> 3. URLs for book fixed, some old topics names changed and the old fixed URLs
> remained.
> 
> New URL to follow brew.
> 
> 4. Code snippet fixed, looks better now. 
> 
> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Getting_Started_Guide/sect-The_CartMart_Quickstart_in_Remote_Client-
> Server_Mode.html
> 
> Section 9.2. requires an update to the additional steps for Hot Rod. Will
> check with Tristan.

Checked, the new information is listed at the following link:

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Build_the_Football_Application.html

Steps 2b and 3 are modified.
Comment 4 Martin Gencur 2012-06-11 06:47:10 EDT
I still see some issues in this article: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Build_the_Football_Application.html

1) Code formatting looks ugly
2) point 2a should be removed because we do not need JBoss Data Grid with productized libraries when we have the JDG maven repo
3) step 3 is not correct, the specified maven call is for the carmart application, not for endpoint examples; endpoint examples can be built simply by "mvn package"
Comment 5 Misha H. Ali 2012-06-11 08:08:16 EDT
(In reply to comment #4)
> I still see some issues in this article:
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Getting_Started_Guide/Build_the_Football_Application.html
> 
> 1) Code formatting looks ugly

Broken up now and should look better.

> 2) point 2a should be removed because we do not need JBoss Data Grid with
> productized libraries when we have the JDG maven repo

Step 2a "Download JBoss Data Grid" is removed.

> 3) step 3 is not correct, the specified maven call is for the carmart
> application, not for endpoint examples; endpoint examples can be built
> simply by "mvn package"

Command altered to just "mvn package".

Fixes can be viewed here: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Getting_Started_Guide/Build_the_Football_Application.html
Comment 6 Martin Gencur 2012-06-11 08:22:57 EDT
Nice. Everything looks good to me now.

Note You need to log in before you can comment on or make changes to this bug.