Bug 830009 - Source language required by Maven client and upload document (pot) are different
Source language required by Maven client and upload document (pot) are different
Status: CLOSED NEXTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6-SNAPSHOT
Unspecified Unspecified
unspecified Severity medium
: ---
: 1.6.2
Assigned To: Carlos Munoz
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 21:48 EDT by Ding-Yi Chen
Modified: 2012-11-25 23:50 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.8.0-SNAPSHOT (20120810-0025)
Doc Type: Bug Fix
Doc Text:
Cause Users trying to upload a source document from the Zanata UI on an instance that did not have locale 'en' enabled. Consequence Zanata would reject the upload because it defaults to locale 'en' for source documents. This conflicts the maven client's default (en-US), and means that two different documents would have different outcomes when pushing from the maven client and uploading from the UI. Furthermore, users were not able to pick a source language when uploading documents. Fix Enabled source locale selection when uploading a document via the UI. By default, en-US is selected if this locale is enabled on the Zanata server (to keep in line with the maven client defaults). Result Users are now able to select a source locale when uploading a document, and get en-US as default when said locale is enabled.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-25 23:36:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-06-07 21:48:44 EDT
Description of problem:
Source language required by maven client and upload document (pot) is inconsistant.

maven client expects that 'en-US' enabled, while 'upload document' expects 'en'.


Version-Release number of selected component (if applicable):
1.6.1-SNAPSHOT (20120608-0019)

How reproducible:
Always

Steps to Reproduce:
1. Use Admin -> manage langues to activate 'en-US', and deactivate 'en'
2. Use maven client to push any document
3. Use Web UI to upload pot document
  
Actual results:
Error message: Locale en is not enabled on this server. Please contact admin. 

Expected results:
Documents are uploaded successfully.

Additional info:
Comment 1 Carlos Munoz 2012-07-03 02:12:43 EDT
I think it should default to en-US like the maven client, but also let the user choose the source locale when uploading a document.
Comment 2 Carlos Munoz 2012-07-03 23:28:47 EDT
Added a selectable source language when uploading a document through the UI. Like the maven client, the default language is en-US if it is enabled on the server.

See:
https://github.com/zanata/zanata/commit/ccfd88441ab53b12c27acc642b37f86e4a6b7dbf
Comment 3 Carlos Munoz 2012-07-03 23:28:47 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
Users trying to upload a source document from the Zanata UI on an instance that did not have locale 'en' enabled.

Consequence
Zanata would reject the upload because it defaults to locale 'en' for source documents. This conflicts the maven client's default (en-US), and means that two different documents would have different outcomes when pushing from the maven client and uploading from the UI.

Furthermore, users were not able to pick a source language when uploading documents.

Fix
Enabled source locale selection when uploading a document via the UI. By default, en-US is selected if this locale is enabled on the Zanata server (to keep in line with the maven client defaults).

Result
Users are now able to select a source locale when uploading a document, and get en-US as default when said locale is enabled.
Comment 4 Ding-Yi Chen 2012-08-09 22:25:48 EDT
VERIFIED with Zanata version 1.8.0-SNAPSHOT (20120810-0025)

Note You need to log in before you can comment on or make changes to this bug.