Bug 830184 - conversion to 'size_t {aka long unsigned int}' from 'long int'
conversion to 'size_t {aka long unsigned int}' from 'long int'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibmm24 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 09:21 EDT by Serge Pavlovsky
Modified: 2012-06-11 11:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 09:27:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Serge Pavlovsky 2012-06-08 09:21:56 EDT
Description of problem:

/usr/include/glibmm-2.4/glibmm/arrayhandle.h:43:23: warning: conversion to 'size_t {aka long unsigned int}' from 'long int' may change the sign of the result [-Wsign-conversion]
Comment 1 Kalev Lember 2012-06-08 09:27:26 EDT
Please file this upstream at https://bugzilla.gnome.org/enter_bug.cgi?product=glibmm

Thanks!
Comment 2 Serge Pavlovsky 2012-06-11 11:04:49 EDT
i have no account there and no intention to register
also i don't understand what makes it 'not a bug'
Comment 3 Kalev Lember 2012-06-11 11:09:58 EDT
I don't disagree that it's a bug, but it's not a bug in the Fedora packaging. It's an issue with upstream glibmm, and as such should be reported there.

You are doing great work reporting these warnings, it's just that they should go to upstream gnome bugzilla instead.

Note You need to log in before you can comment on or make changes to this bug.