Bug 830203 - Dep resolve error with ruby-irb
Dep resolve error with ruby-irb
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 847528 849402 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 10:26 EDT by Josef Bacik
Modified: 2014-01-21 18:22 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 16:45:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2012-06-08 10:26:48 EDT
Tried to run a yum update on my box this morning, got this


Running Transaction Check
ERROR with transaction check vs depsolve:
ruby-irb = 1.8.7.358-1.fc16 is needed by (installed) ruby-rdoc-1.8.7.358-1.fc16.noarch
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
ruby-rdoc-1.8.7.358-1.fc16.noarch has missing requires of ruby-irb = ('0', '1.8.7.358', '1.fc16')
Comment 1 Aidan Talerico 2012-06-08 11:46:53 EDT
I'm experiencing the same problem.
rpm -Va --nofiles --nodigest gives this output:
Unsatisfied dependencies for ruby-rdoc-1.8.7.358-1.fc16.noarch:
	ruby-irb = 1.8.7.358-1.fc16 is needed by (installed) ruby-rdoc-1.8.7.358-1.fc16.noarch
Comment 2 Harika 2012-06-14 13:33:29 EDT
I have the same problem. 
ERROR with transaction check vs depsolve:
ruby-irb = 1.8.7.358-1.fc16 is needed by (installed) ruby-rdoc-1.8.7.358-1.fc16.noarch
rubygem-gettext = 2.1.0-4.fc16 is needed by (installed) ruby-gettext-package-2.1.0-4.fc16.noarch
Comment 3 Harika 2012-06-14 13:47:28 EDT
I solved it in two steps as follows;
sudo yum remove ruby-rdoc-1.8.7.358-1.fc16.noarch
sudo yum remove ruby-rdoc-1.8.7.358-1.fc16.noarch

Then I could update the system! (sudo yum update)
Hope it works for you as well. Harika
Comment 4 Jim 2012-07-05 21:53:00 EDT
I've also been expierenceing this problem.

With the suggestion above I've solved the problem with: `sudo yum remove ruby-rdoc.noarch`

Thanks and I hope it works for others as well.

Jim
Comment 5 James Antill 2013-05-28 16:37:45 EDT
*** Bug 847528 has been marked as a duplicate of this bug. ***
Comment 6 James Antill 2013-05-28 16:39:35 EDT
*** Bug 849402 has been marked as a duplicate of this bug. ***
Comment 7 James Antill 2013-05-28 16:45:54 EDT
Pre-existing rpmdb problem, "yum check" should find them all and "yum remove" (or "yum install") can fix them.

Note You need to log in before you can comment on or make changes to this bug.