This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 830216 - Seam: TAG-16 Restbay example
Seam: TAG-16 Restbay example
Status: CLOSED WORKSFORME
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Examples, Seam (Show other bugs)
2.0.0.ER7
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marek Novotny
Karel Piwko
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 10:48 EDT by Karel Piwko
Modified: 2012-06-15 10:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 10:06:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-06-08 10:48:42 EDT
Following errors happen in restbay example when imported to JBDS (ignoring missing Maven artifacts):

Description	Resource	Path	Location	Type
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:application'.	components.xml	/restbay-web/src/main/webapp/WEB-INF	line 42	XML Problem
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:application'.	components.xml	/restbay-web/target/m2e-wtp/web-resources/WEB-INF	line 42	XML Problem
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:resource-home'.	components.xml	/restbay-web/src/main/webapp/WEB-INF	line 50	XML Problem
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:resource-home'.	components.xml	/restbay-web/target/m2e-wtp/web-resources/WEB-INF	line 50	XML Problem
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:resource-query'.	components.xml	/restbay-web/src/main/webapp/WEB-INF	line 54	XML Problem
cvc-complex-type.2.4.c: The matching wildcard is strict, but no declaration can be found for element 'resteasy:resource-query'.	components.xml	/restbay-web/target/m2e-wtp/web-resources/WEB-INF	line 54	XML Problem
Comment 1 Marek Novotny 2012-06-15 06:44:08 EDT
I can't reproduce these errors. Karel, could you check it again?
Comment 2 Karel Piwko 2012-06-15 10:06:07 EDT
I can't reproduce it neither. Seems to be fixed by updating JBDS to from Beta3 to CR1. Closing as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.