This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 830290 - sudo yum update fail
sudo yum update fail
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 14:29 EDT by guizmaii59
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 11:09:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guizmaii59 2012-06-08 14:29:42 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Test de la transaction en cours
ERREUR lors de la vérification de la transaction avec les dépendances :
ruby-irb = 1.8.7.358-1.fc16 is needed by (installed) ruby-rdoc-1.8.7.358-1.fc16.noarch
ruby(abi) = 1.8 is needed by (installed) rubygem-fastercsv-1.5.4-1.fc16.noarch
ruby(abi) = 1.8 is needed by (installed) rubygem-imagefactory-console-0.4.0-6.fc16.noarch
ruby(abi) = 1.8 is needed by (installed) rubygem-ParseTree-3.0.5-1.fc14.noarch
ruby(abi) = 1.8 is needed by (installed) rubygem-idn-0.0.2-7.fc16.x86_64
ruby(abi) = 1.8 is needed by (installed) rubygem-addressable-2.2.6-4.fc16.noarch
Veuillez reporter cette erreur dans https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** 18 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
antlr3-gunit-3.2-14.fc15.noarch a des dépendances manquantes de antlr3-java = ('0', '3.2', '14.fc15')
gcr-3.4.1-2.fc17.x86_64 des conflits sont installés gnome-keyring < ('0', '3.3.0', None): gnome-keyring-3.2.1-3.fc16.i686
gnome-keyring-3.4.1-2.fc17.x86_64 est un doublon de gnome-keyring-3.2.1-3.fc16.i686
netbeans-6.9-5.fc16.noarch a des dépendances manquantes de netbeans-platform12 >= ('0', '6.9', None)
netbeans-apisupport-6.9-5.fc16.noarch a des dépendances manquantes de netbeans-platform12 >= ('0', '6.9', None)
netbeans-ide-6.9-5.fc16.noarch a des dépendances manquantes de netbeans-platform12 >= ('0', '6.9', None)
netbeans-java-6.9-5.fc16.noarch a des dépendances manquantes de netbeans-platform12 >= ('0', '6.9', None)
ruby-rdoc-1.8.7.358-1.fc16.noarch a des dépendances manquantes de ruby-irb = ('0', '1.8.7.358', '1.fc16')
rubygem-ParseTree-3.0.5-1.fc14.noarch a des dépendances manquantes de ruby(abi) = ('0', '1.8', None)
rubygem-addressable-2.2.6-4.fc16.noarch a des dépendances manquantes de ruby(abi) = ('0', '1.8', None)
rubygem-fastercsv-1.5.4-1.fc16.noarch a des dépendances manquantes de ruby(abi) = ('0', '1.8', None)
rubygem-idn-0.0.2-7.fc16.x86_64 a des dépendances manquantes de libruby.so.1.8()(64bit)
rubygem-idn-0.0.2-7.fc16.x86_64 a des dépendances manquantes de ruby(abi) = ('0', '1.8', None)
rubygem-imagefactory-console-0.4.0-6.fc16.noarch a des dépendances manquantes de ruby(abi) = ('0', '1.8', None)
2:samba4-4.0.0-47alpha18.fc17.x86_64 des conflits sont installés samba < ('2', '4.0.0', '47alpha18.fc17'): 2:samba-3.6.5-86.fc17.1.x86_64
2:samba4-client-4.0.0-47alpha18.fc17.x86_64 des conflits sont installés samba-client < ('2', '3.9.9', None): 2:samba-client-3.6.5-86.fc17.1.x86_64
2:samba4-common-4.0.0-47alpha18.fc17.x86_64 des conflits sont installés samba-common < ('2', '3.9.9', None): 2:samba-common-3.6.5-86.fc17.1.x86_64
2:samba4-winbind-4.0.0-47alpha18.fc17.x86_64 des conflits sont installés samba-winbind < ('2', '3.9.9', None): 2:samba-winbind-3.6.5-86.fc17.1.x86_64
Votre transaction a été enregistrée, relancez-la avec :
 yum load-transaction /tmp/yum_save_tx.2012-06-08.20-26.IIoBTs.yumtx



Expected results:


Additional info:
Comment 1 Darryl L. Pierce 2012-06-11 10:24:30 EDT
+1 on this. I can't upgrade ruby-irb since it depends on Ruby 1.8.7 rather than Ruby 1.9.
Comment 2 James Antill 2012-06-11 11:09:33 EDT
As it says:

> ** 18 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :

...yum isn't going to be happy until these are fixed. You can use
install/remove/reinstall/etc. to fix them.

 Darryl, assuming you don't have any pre-existing problems ... you can try "yum downgrade ruby" (and then versionlock), or get a ruby-irb that's built for the newer version.

Note You need to log in before you can comment on or make changes to this bug.