Bug 830303 - Calibbre fails to mount device
Calibbre fails to mount device
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 15:30 EDT by Wolfgang Denk
Modified: 2012-06-15 15:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 17:00:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Calibre debug output (5.12 KB, text/plain)
2012-06-08 15:30 EDT, Wolfgang Denk
no flags Details

  None (edit)
Description Wolfgang Denk 2012-06-08 15:30:14 EDT
Created attachment 590496 [details]
Calibre debug output

Description of problem:

After upgrading to Fedora 17 "calibre" cannot connecct to the e-boot reader device any more (a Sony reader in my case).

Version-Release number of selected component (if applicable):

calibre-0.8.50-1.fc17.x86_64


How reproducible:

Always

Steps to Reproduce:
1. Connect reader to USB port, verify it's recognized (using for example lsusb):
   ...
   Bus 002 Device 005: ID 054c:05c2 Sony Corp. 
2. Start "calibre".
  
Actual results:

"Send to device" button s missing, device is not recognized as connected.
No communication with device possible.

Expected results:

"Send to device" should be there, communication with device should work.


Additional info:

wild guess: can this have anything to do with moving the mount point for such devices from /media to /run/media/... ?

When I run the connect attempt in debug mode I can see that the mount fails,
see attachment.
Comment 1 Kevin Fenzi 2012-06-08 16:21:05 EDT
You are getting a: 

DBusException: org.freedesktop.UDisks.Error.PermissionDenied: Not Authorized

from udisks. 

What desktop are you in? How did you login?
Comment 2 Wolfgang Denk 2012-06-08 16:38:10 EDT
(In reply to comment #1)
> You are getting a: 
> 
> DBusException: org.freedesktop.UDisks.Error.PermissionDenied: Not Authorized
> 
> from udisks. 

Yes.  But I was not getting this before, with Fedora 16.
I can even reproduce that (as long as I still have F16 systems, that is...)

> What desktop are you in? How did you login?

I'm running FVWM2.
Comment 3 Kevin Fenzi 2012-06-08 17:47:46 EDT
And how are you logging in? gdm?
Comment 4 Wolfgang Denk 2012-06-08 18:24:43 EDT
(In reply to comment #3)
> And how are you logging in? gdm?

Yes, gdm, no changes here; I'm just starting a FVWM session instead of GNOME ot anything else (well, after fixing Bug 714482, that is).
Comment 5 Kevin Fenzi 2012-06-09 13:58:00 EDT
Is ConsoleKit installed?

What does 'ck-list-sessions' show?
Comment 6 Wolfgang Denk 2012-06-09 17:20:58 EDT
(In reply to comment #5)
> Is ConsoleKit installed?

Yes:

-> rpm -q ConsoleKit
ConsoleKit-0.4.5-2.fc17.x86_64

> What does 'ck-list-sessions' show?

-> ck-list-sessions
Session2:
        unix-user = '0'
        realname = 'root'
        seat = 'Seat1'
        session-type = ''
        active = FALSE
        x11-display = ''
        x11-display-device = ''
        display-device = '/dev/ttyS0'
        remote-host-name = ''
        is-local = TRUE
        on-since = '2012-06-08T22:16:04.518496Z'
        login-session-id = '3'
        idle-since-hint = '2012-06-09T15:23:40.922120Z'
Session3:
        unix-user = '500'
        realname = 'Wolfgang Denk'
        seat = 'Seat3'
        session-type = ''
        active = FALSE
        x11-display = ':0'
        x11-display-device = ''
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2012-06-09T15:16:10.621790Z'
        login-session-id = '235'
->
Comment 7 Kevin Fenzi 2012-06-09 20:23:36 EDT
ok, if you edit: 

/usr/share/xsessions/fvwm.desktop

and change: 

Exec=fvwm

to

Exec=ck-launch-session fvwm

and logout and back on and see if anything changes?
Comment 8 Wolfgang Denk 2012-06-10 08:57:24 EDT
(In reply to comment #7)
> ok, if you edit: 
> /usr/share/xsessions/fvwm.desktop
> and change: 
> Exec=fvwm
> to
> Exec=ck-launch-session fvwm
> 
> and logout and back on and see if anything changes?

This changes something - it makes things worse.

Fvwm still gets started, but it does not start any of my Xlients -
similar as if my patch for Bug 714482 had not been aplied.

When I start calibre in this environment, it still fails to detect the
connected reader device, similar to what we had before.

So I reverted this change (or should I keep it?  If yes, then how do I
get the actions in my $HOME/.Xclients-default file run?).


BTW:  thanks for your quick help.  I really appreciate it!
Comment 9 Kevin Fenzi 2012-06-11 10:47:17 EDT
ok, what happens if you use one of the fuller desktops? (Xfce, Gnome)? 

Does it work as expected there? or still fails?

(This will hopefully tell us if it's a issue with your hardware/setup somewhere or something particular to fvwm2). 

Also, can you (in fvwm2 without ck-launch-session), mount manually the device and see if calibre sees it then?
Comment 10 Wolfgang Denk 2012-06-11 14:00:09 EDT
(In reply to comment #9)
> ok, what happens if you use one of the fuller desktops? (Xfce, Gnome)? 
> 
> Does it work as expected there? or still fails?

Hm... this is funny (actually not so).

So I did the following:

- I checked again running in fwvm - it didn't work.
- Logged out, log into gnome session.
- It works.
- Logged out, log into xfce session.
- It works.
- Logged out, log into KDE Plasma session.
- It works.
- Logged out, log into fwvm session.
- It works!!!
- Reboot, log into fwvm session.
- It works!!!

I cannot reproduce the problem any more.  It appears as if one of the
gnome, xfce, or KDE logins magically "fixed" something in a persistent
way, so that it even works after a reboot.

> (This will hopefully tell us if it's a issue with your hardware/setup
> somewhere or something particular to fvwm2). 

I don't think it is hardware rleated as it has always worked before
(i. e. in Fedora 15 and Fedora 16).  It stopped working after
upgrading to Fedora 17.

Note that up until now I had never loged in on Fedore 17 with either
of gnome, xfce, or KDE, so it may well be that one of these logins has
created any files, links, directories or whatever that now make it
work.

Although the problem appears fixed for me now I don;t feel happy as it
means the cause of the problem is still unknown.

> Also, can you (in fvwm2 without ck-launch-session), mount manually the
> device and see if calibre sees it then?

Where would I mount it?  I guess it needs some specific mount point?

Best regards,

Wolfgang Denk
Comment 11 Kevin Fenzi 2012-06-11 16:18:31 EDT
Wow. I don't understand that. 

If you make a new user and only login to fvwm does it fail for them?

The mount can be anywhere... calibre just looks for the usb device strings, so it can figure out where you mounted it.
Comment 12 Wolfgang Denk 2012-06-14 16:07:03 EDT
I tested with a newly created login, and it worked, too.
I also tested on another host, where I never tried this before,
and it worked as well.

I'm at the end of my wits - I cannot reproduce the problem any more.
I can only speculate that some configuration data must have been left
from earlier runs under Fedora 16 that blocked the access somehow,
and that got cleaned up when logging into Gnome.

Please feel free to close this bug - I can't reproduce it any more.
Comment 13 Kevin Fenzi 2012-06-14 17:00:59 EDT
Yeah, bugs like these are always frustrating. ;( 

Do reopen or file a new one if you can see it happening again...
Comment 14 Wolfgang Denk 2012-06-15 15:57:04 EDT
(In reply to comment #13)
> Yeah, bugs like these are always frustrating. ;( 

Indeed :-(

> Do reopen or file a new one if you can see it happening again...

Will do.  Thanks a lot for all your help!

Note You need to log in before you can comment on or make changes to this bug.