Bug 830321 - yum error: libudev-devel < 183 is obsoleted
yum error: libudev-devel < 183 is obsoleted
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 16:34 EDT by Tom
Modified: 2015-02-17 09:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 09:16:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
today's yum output (180.13 KB, text/plain)
2012-06-09 09:21 EDT, Tom
no flags Details
grep -C3 -E "yum|udev|systemd" /var/log/yum.log >yum-log.txt (6.51 KB, text/plain)
2012-08-10 19:55 EDT, David Timms
no flags Details

  None (edit)
Description Tom 2012-06-08 16:34:36 EDT
Description of problem:
ERROR with transaction check vs depsolve:
libudev-devel < 183 is obsoleted by (installed) systemd-devel-185-2.fc18.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Try to do yum update --skip-broken on Rawhide
2.yum tries to: 
Installing for dependencies:
libudev-devel                   x86_64 182-3.fc18               rawhide     69 k
3.yum transaction error.
  
Actual results:


Expected results:


Additional info:
Comment 1 James Antill 2012-06-08 16:43:15 EDT
Can you add the full output?
Comment 2 Tom 2012-06-09 09:21:23 EDT
Created attachment 590607 [details]
today's yum output
Comment 3 James Antill 2012-06-11 16:27:11 EDT
 There are two problems here:

1. new systemd-devel can't be installed due to dep. problems. So skip-broken removes it.

2. Old-ish problem of installed obsoletes not being checked by yum.

...we should really fix #2.
Comment 4 David Timms 2012-08-10 19:55:22 EDT
Created attachment 603649 [details]
grep -C3 -E "yum|udev|systemd" /var/log/yum.log >yum-log.txt
Comment 5 David Timms 2012-08-10 19:56:59 EDT
Hi, getting this issue on rawhide today, not seen previously. Machine was installed GUI F17, added fedora-release-rawhide a few days ago, upgraded to rawhide. Updates since hadn't noted this issue.

Seems update got systemd installed, but not udev uninstalled. Might be a problem for all rawhide users ?
---
$ rpm -qa \*udev\* systemd\* kern\* rpm\* yum\*|sort
kernel-3.3.4-5.fc17.x86_64
kernel-3.6.0-0.rc1.git1.2.fc18.x86_64
kernel-3.6.0-0.rc1.git2.1.fc18.x86_64
kernel-headers-3.6.0-0.rc1.git2.1.fc18.x86_64
libgudev1-187-3.fc18.x86_64
libudev-182-1.fc17.x86_64
rpm-4.10.0-6.fc18.x86_64
rpm-build-4.10.0-6.fc18.x86_64
rpm-build-libs-4.10.0-6.fc18.x86_64
rpmdevtools-8.2-3.fc18.noarch
rpmfusion-free-release-18-0.2.noarch
rpmfusion-nonfree-release-18-0.2.noarch
rpmfusion-packager-0.4-1.fc12.noarch
rpm-libs-4.10.0-6.fc18.x86_64
rpmlint-1.4-7.fc18.noarch
rpm-python-4.10.0-6.fc18.x86_64
system-config-printer-udev-1.3.11-1.fc18.x86_64
systemd-187-3.fc18.x86_64
systemd-libs-187-3.fc18.x86_64
systemd-sysv-187-3.fc18.x86_64
udev-182-1.fc17.x86_64
yum-3.4.3-30.fc18.noarch
yum-langpacks-0.2.5-2.fc18.noarch
yum-metadata-parser-1.1.4-7.fc18.x86_64
yum-plugin-downloadonly-1.1.31-6.fc18.noarch
yum-presto-0.8.1-2.fc18.noarch
yum-utils-1.1.31-6.fc18.noarch

$ uname -a
Linux f18 3.6.0-0.rc1.git2.1.fc18.x86_64 #1 SMP Mon Aug 6 14:21:25 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 6 Fedora End Of Life 2013-04-03 12:49:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 7 Fedora End Of Life 2015-01-09 12:11:00 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-02-17 09:16:53 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.