Bug 830403 - Cheese doesn't work because vp8enc is missing
Cheese doesn't work because vp8enc is missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 04:19 EDT by Mike Manilone
Modified: 2012-06-11 17:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 17:13:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Manilone 2012-06-09 04:19:05 EDT
Description of problem:
Run Cheese, but it shows 'One or more needed GStreamer elements are missing: vp8enc'

Version-Release number of selected component (if applicable):
cheese-3.4.2-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1.Just open Cheese
2.
3.
  
Actual results:
The same as 'Description of problem'

Expected results:
Show the photo captured by the camera.

Additional info:
Here are the versions of all the gstreamer-related packages:
gstreamer-0.10.36-1.fc17.x86_64
gstreamer-plugins-good-0.10.31-1.fc17.x86_64
gstreamer-plugins-bad-0.10.22-4.fc17.x86_64
gstreamer-ffmpeg-0.10.13-2.fc17.x86_64
gstreamer-devel-0.10.36-1.fc17.x86_64
gstreamer-python-0.10.19-3.fc17.x86_64
gstreamer-plugins-bad-free-0.10.23-2.fc17.x86_64
gstreamer-plugins-base-devel-0.10.36-1.fc17.x86_64
gstreamer-tools-0.10.36-1.fc17.x86_64
gstreamer-plugins-ugly-0.10.19-1.fc17.x86_64
gstreamer-plugins-base-0.10.36-1.fc17.x86_64
gstreamer-plugins-bad-nonfree-0.10.22-3.fc17.x86_64
gstreamer-rtsp-0.10.8-2.fc17.x86_64
Comment 1 Mike Manilone 2012-06-09 04:21:49 EDT
libvpx has been installed, too:
libvpx-1.0.0-1.fc17.x86_64
Comment 2 Hans de Goede 2012-06-09 17:00:00 EDT
[hans@shalem ~]$ rpm -qf /usr/lib64/gstreamer-0.10/libgstvp8.so 
gstreamer-plugins-bad-free-0.10.23-6.fc17.x86_64
[hans@shalem ~]$ rpm -q --requires cheese
cheese-3.4.2-2.fc17.x86_64
/bin/sh  
/bin/sh  
/bin/sh  
gnome-video-effects  
gstreamer-plugins-bad-free  
gstreamer-plugins-good >= 0.10.6-2
libX11.so.6()(64bit)  
<snip>

So somehow gstreamer-plugins-bad-free ism missing from your system even though cheese requires it. rpm --verify cheese should also give an error about it being missing.

A simple "yum install gstreamer-plugins-bad-free" should fix this. As to how this got missing, that is something which we will likely never find out.

Closing this as nota(cheese)bug.
Comment 3 Adam Young 2012-06-11 11:20:55 EDT
I have the same problem.  In addition, I have gstreamer-plugins-bad-free  installed.

[ayoung@ayoung fedora]$ rpmquery gstreamer-plugins-bad-free
gstreamer-plugins-bad-free-0.10.23-2.fc17.x86_64
Comment 4 Adam Young 2012-06-11 11:35:26 EDT
vp8 seems to be installed:

[ayoung@ayoung fedora]$ rpmquery -f /usr/lib64/gstreamer-0.10/libgstvp8.so 
gstreamer-plugins-bad-free-0.10.23-2.fc17.x86_64


I see the following errors:


** (cheese:1116): CRITICAL **: cheese_camera_create_effects_preview_bin: assertion `error == NULL || *error == NULL' failed

** (cheese:1116): WARNING **: cheese-window.vala:1624: Error: One or more needed GStreamer elements are missing: One or more needed GStreamer elements are missing: vp8enc.


running gstreamer-properties brings up test video input and output just fine.
Comment 5 Adam Young 2012-06-11 11:51:48 EDT
Downloaded the srpm and build the code inplace.  Gives the same response.

run ./configure in BUILD/cheese-3.4.2

gives this snippet:

checking for vp8enc GStreamer plugin... not found
configure: WARNING: vp8enc was not found. It needs to be installed before Cheese is run


The config script in turn runs /usr/bin/gst-inspect-0.10

[ayoung@ayoung cheese-3.4.2]$ /usr/bin/gst-inspect-0.10 | grep 8
rtpvp8:  rtpvp8pay: RTP VP8 payloader
rtpvp8:  rtpvp8depay: RTP VP8 depayloader
typefindfunctions: application/x-hls: m3u8


Either cheese needs to switch away from vp8,  or gstreamer vp8 support needs to be fixed
Comment 6 Hans de Goede 2012-06-11 14:19:38 EDT
(In reply to comment #4)
> vp8 seems to be installed:
> 
> [ayoung@ayoung fedora]$ rpmquery -f /usr/lib64/gstreamer-0.10/libgstvp8.so 
> gstreamer-plugins-bad-free-0.10.23-2.fc17.x86_64

That is rather old, we are at gstreamer-plugins-bad-free-0.10.23-6.fc17.x86_64 atm, which is in stable
updates now, and the changelog for -4 has:

* Tue May 29 2012 Adel Gadllah <adel.gadllah@gmail.com> 0.10.23-4
- Backport upstream patch to fix vp8enc (GNOME #676653, #676245) 

If gstreamer-plugins-bad-free-0.10.23-6.fc17 fixes this issue, please close this bug.
Comment 7 Hans de Goede 2012-06-11 14:20:16 EDT
Ok, I see the changelog says May 29, so I guess rather old is a bit over the top :)
Comment 8 Adam Young 2012-06-11 17:13:49 EDT
I now have gstreamer-plugins-bad-free-0.10.23-6.fc17.x86_64  and cheese works.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.