Bug 830435 - Joystick not working anymore and others
Joystick not working anymore and others
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: torcs (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 10:54 EDT by Piergiorgio Sartor
Modified: 2013-03-04 15:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-04 15:01:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piergiorgio Sartor 2012-06-09 10:54:22 EDT
Description of problem:
I'm not sure if this belongs here, but anyway...
After upgrading from F16 to F17 it is not possible anymore to play torcs with a joystick, only keyboard works (and probably mouse).
The joystick is an USB Logitech Logitech Dual Action.
After hot-plug "dmesg" shows:

[21708.139404] usb 1-3.1: new low-speed USB device number 12 using ehci_hcd
[21708.244037] usb 1-3.1: New USB device found, idVendor=046d, idProduct=c216
[21708.244047] usb 1-3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[21708.244054] usb 1-3.1: Product: Logitech Dual Action
[21708.244060] usb 1-3.1: Manufacturer: Logitech

After starting torcs:

[21718.251354] generic-usb 0003:046D:C216.0005: usb_submit_urb(ctrl) failed: -1
[21718.251380] generic-usb 0003:046D:C216.0005: timeout initializing reports
[21718.251565] input: Logitech Logitech Dual Action as /devices/pci0000:00/0000:00:0b.1/usb1/1-3/1-3.1/1-3.1:1.0/input/input10
[21718.251940] generic-usb 0003:046D:C216.0005: input,hidraw2: USB HID v1.10 Joystick [Logitech Logitech Dual Action] on usb-0000:00:0b.1-3.1/input0

Which may or may not be OK.

Version-Release number of selected component (if applicable):
torcs-1.3.3-1.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1.
Start torcs from command line (torcs-wrapper)
2.
Go to the player configuration menu and try to change the controls, assigning the joystick buttons, for example. Alternatively, if already configured (like my case), try to start a race.
  
Actual results:
It is not possible to steer the car using the joystick.

Expected results:
The joystick should work as it did before.

Additional info:
A couple of comments.
I was positively surprised to find new tracks, this is really nice.
I was a bit less positively surprise to *not* find the Formula One cars anymore... Are they missing or it is another problem?

Thanks,

bye,

pg
Comment 1 Piergiorgio Sartor 2012-06-09 10:59:36 EDT
Just tested something...

I tried GL-117, this works with the joystick.

bye,

pg
Comment 2 Piergiorgio Sartor 2012-07-07 09:44:16 EDT
Hi again,

it seems something changed, not GL-117 is not working too.

I installed the joystick tool and this has problems as well.

I guess there are two possibilities, either a (sudden) hardware failure or a kernel problem.

I guess you can close this bug report (apart from the question about the F1 cars), I'll open a new one for the kernel component.

Thanks,

bye,

pg
Comment 3 Piergiorgio Sartor 2012-08-17 16:10:28 EDT
Hi,

it seems I solved both issues.

The joystick seems to depend on "kernel-modules-extra" package, once installed, everything was working fine.

The F1 car I found under different name...

I guess you can close this bug.

Thanks,

bye,

pg
Comment 4 Piergiorgio Sartor 2013-03-04 15:01:52 EST
Hi all,

since the issue is solved, I close this one.

Thanks,

bye,

pg

Note You need to log in before you can comment on or make changes to this bug.