Bug 830458 - The afraid-dyndns package is competely broekn
Summary: The afraid-dyndns package is competely broekn
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: afraid-dyndns
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Erick Calder
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-09 20:46 UTC by Nadav Har'El
Modified: 2013-02-26 02:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-26 02:06:34 UTC


Attachments (Terms of Use)

Description Nadav Har'El 2012-06-09 20:46:16 UTC
The afraid-dyndns package does not work at all, and in fact HASN'T WORKED SINCE AT LEAST FEDORA 14 (see bug 610999). Please either fix this package soon, or (more likely...) simply give up on it ever being fixed, and remove it from Fedora altogether.

The main program in this package, /usr/bin/afraid-dyndns, doesn't work for at least two separate reasons:

1. It has code which looks like:
     split /\s*=\s*/;
     $ARGV{$_[0]} = $_[1];
   This is *wrong*, as split only uses $_, and doesn't modify it! It
   perhaps was supposed to be @_ = split /\s*=\s*/;
   Without fixing this, you always get the error message: "No AccountHash in configuration file - please see README for instructions." even if you do set AccountHash.


2. Even if you fix problem #1, you run into the problem of bug 610999 which was never fixed. Now /usr/bin/afraid-dyndns dies because it tries to reach some external site which hasn't existed for a few years...

Comment 1 Erick Calder 2012-06-09 20:50:53 UTC
I fixed the two issues above along with a number of other fixes rather some time ago but I no longer have a proper facility for packaging this stuff for Fedora... if you can package it, the latest code is at:

https://github.com/ekkis/afraid-dyndns

Comment 2 Nadav Har'El 2012-08-21 17:51:08 UTC
In the hope that something is done, I'm changing the package on this bug to "Package Review" (I hope it means what I think it means).

Comment 3 Paul Flo Williams 2012-09-28 09:22:16 UTC
(In reply to comment #1)
> I fixed the two issues above along with a number of other fixes rather some
> time ago but I no longer have a proper facility for packaging this stuff for
> Fedora... if you can package it, the latest code is at:
> 
> https://github.com/ekkis/afraid-dyndns

You will need to orphan the package, following this procedure:

https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers

(In reply to comment #2)
> In the hope that something is done, I'm changing the package on this bug to
> "Package Review" (I hope it means what I think it means).

I've changed the component back to afraid-dyndys, as the package is officially still in Fedora, even in its non-working state. If Erick drops ownership, it can be re-built by someone else.

Comment 4 Jacobo Cabaleiro 2012-10-13 18:02:24 UTC
Adding myself here for news, as I tried to use this package today in F17 and found it broken.

Also found the split problem, but this is my first perl contact so I'm of no help here, and Erick probably has already corrected everything.

Comment 5 Joao M. S. Silva 2013-02-26 00:25:43 UTC
I just lost a few hours thinking that I hadn't configured /etc/afraid-dyndns.conf correctly.

I think this should be corrected or removed from the repos.

Can someone advance which one will be?

Thanks.

Comment 6 Erick Calder 2013-02-26 02:06:34 UTC
Jacobo/Joao,

there have been many fixes made since the package went to the repos.  the latest good copy is at the link I posted before on github.  I need somebody to repackage it for me because I no longer know how to.  it shouldn't be so difficult to do for someone who knows how to do it because it's a very vanilla solution.

- erick

Comment 7 Erick Calder 2013-02-26 02:16:32 UTC
ok, I've followed the instructions Paul was kind to provide and released ownership of all the branches for this package.  if anyone could maintain this package by following the source on github I'd be grateful.  the source is here:

https://github.com/ekkis/afraid-dyndns


Note You need to log in before you can comment on or make changes to this bug.