Bug 830494 - missing libQtWebKit.so.4 dependency
missing libQtWebKit.so.4 dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PyQt4 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 04:14 EDT by Adrin Jalali
Modified: 2012-06-10 23:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 23:53:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log (7.13 KB, text/plain)
2012-06-10 20:28 EDT, Adrin Jalali
no flags Details

  None (edit)
Description Adrin Jalali 2012-06-10 04:14:01 EDT
Hey,

eric-4.4.19-2.fc17.x86_64 has missing dependency to libQtWebKit.so.4.

Thanks,
Adrin.
Comment 1 Rex Dieter 2012-06-10 09:08:15 EDT
It already has:

* Wed Dec 14 2011 Rex Dieter <rdieter@fedoraproject.org> 4.4.19-1
- 4.4.19
- Requires: PyQt4 PyQt4-webkit

Can you perphaps describe the problem(s) you're experiencing to try to diagnose why the PyQt4-webkit is not sufficient?
Comment 2 Adrin Jalali 2012-06-10 16:52:42 EDT
I'm not a Python coder yet and I can't tell you what exactly happened.

I just installed eric4 and tried to run it, then I got this message:

$ eric4
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/eric4/eric4.py", line 60, in <module>
    from KdeQt.KQApplication import KQApplication
  File "/usr/lib/python2.7/site-packages/eric4/KdeQt/__init__.py", line 20, in <module>
    import Preferences
  File "/usr/lib/python2.7/site-packages/eric4/Preferences/__init__.py", line 26, in <module>
    from PyQt4.QtWebKit import QWebSettings
ImportError: libQtWebKit.so.4: cannot open shared object file: No such file or directory


then I ran yum whatprovides "*/libQtWebKit.so.4" and installed whatever the result was.
Comment 3 Rex Dieter 2012-06-10 17:14:14 EDT
ok, seems to be a problem with PyQt4 then, re-assigning.  I'll take a look there.

quick-n-dirty short-term solution is:

yum install qtwebkit
Comment 4 Rex Dieter 2012-06-10 17:22:36 EDT
hrm, strange, on my box:

$ rpm -qR PyQt4 | grep -i qt
libQtCore.so.4()(64bit)  
libQtDBus.so.4()(64bit)  
libQtDeclarative.so.4()(64bit)  
libQtDesigner.so.4()(64bit)  
libQtGui.so.4()(64bit)  
libQtHelp.so.4()(64bit)  
libQtMultimedia.so.4()(64bit)  
libQtNetwork.so.4()(64bit)  
libQtOpenGL.so.4()(64bit)  
libQtScript.so.4()(64bit)  
libQtScriptTools.so.4()(64bit)  
libQtSql.so.4()(64bit)  
libQtSvg.so.4()(64bit)  
libQtTest.so.4()(64bit)  
libQtWebKit.so.4()(64bit)  
libQtXml.so.4()(64bit)  
libQtXmlPatterns.so.4()(64bit)  
qt4(x86-64) >= 4.8.1

See the libQtWebKit.so.4 dep there?

What does the output of:

rpm -qR PyQt4 | grep -i qt

say on your box?
Comment 5 Adrin Jalali 2012-06-10 20:08:57 EDT
This is mine:


# rpm -qR PyQt4 | grep -i qt
libQtCore.so.4()(64bit)  
libQtDBus.so.4()(64bit)  
libQtDeclarative.so.4()(64bit)  
libQtDesigner.so.4()(64bit)  
libQtGui.so.4()(64bit)  
libQtHelp.so.4()(64bit)  
libQtMultimedia.so.4()(64bit)  
libQtNetwork.so.4()(64bit)  
libQtOpenGL.so.4()(64bit)  
libQtScript.so.4()(64bit)  
libQtScriptTools.so.4()(64bit)  
libQtSql.so.4()(64bit)  
libQtSvg.so.4()(64bit)  
libQtTest.so.4()(64bit)  
libQtWebKit.so.4()(64bit)  
libQtXml.so.4()(64bit)  
libQtXmlPatterns.so.4()(64bit)  
qt4(x86-64) >= 4.8.1
Comment 6 Rex Dieter 2012-06-10 20:11:16 EDT
ok, the dependency is there.

So, one more try:

rpm -q eric sip PyQt4 qt qtwebkit

please.
Comment 7 Adrin Jalali 2012-06-10 20:13:41 EDT
# rpm -q eric sip PyQt4 qt qtwebkit
eric-4.4.19-2.fc17.x86_64
sip-4.13.2-1.fc17.x86_64
PyQt4-4.9.1-2.fc17.x86_64
qt-4.8.2-2.fc17.x86_64
qt-4.8.2-2.fc17.i686
qtwebkit-2.2.1-6.fc17.x86_64


remember that I've already installed that dependency. So my box is running eric4, I can remove that package if you need.
Comment 8 Rex Dieter 2012-06-10 20:16:39 EDT
OK, as far as I can tell, the package dependencies should all 'just work', we confirmed that your installed PyQt4 includes a dependency on libQtWebKit yet, somehow your box didn't have qtwebkit. ??

I guess you could try to uninstall

yum remove PyQt4 qtwebkit

and try re-installing eric:

yum install eric

and if that fails, we've got problems elsewhere methinks.
Comment 9 Adrin Jalali 2012-06-10 20:28:25 EDT
Created attachment 590804 [details]
yum log

so there is a problem there. see the log, dependency is not there.
Comment 10 Rex Dieter 2012-06-10 20:52:18 EDT
ok, how about:

rpm -q --whatprovides 'libQtWebKit.so.4()(64bit)'

something is tricking yum into thinking installing qtwebkit is not necessary.


as a last resort, try running (as root):
package-cleanup --problems
Comment 11 Adrin Jalali 2012-06-10 20:56:06 EDT
haha, that was funny. look at it:


# rpm -q --whatprovides 'libQtWebKit.so.4()(64bit)'
rstudio-0.96.231-1.x86_64
qtwebkit-2.2.1-6.fc17.x86_64


stupid rstudio, OK, what do we do now?
Comment 12 Rex Dieter 2012-06-10 23:53:48 EDT
Bug whoever you got rstudio from, it shouldn't provide stuff that it really doesn't.

Note You need to log in before you can comment on or make changes to this bug.