Bug 830499 - Gluster - Backend: Can't remove server, even when it doesn't have bricks on it
Gluster - Backend: Can't remove server, even when it doesn't have bricks on it
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dhandapani
Sudhir D
gluster, storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 04:34 EDT by Daniel Paikov
Modified: 2013-02-28 23:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 05:37:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-06-10 04:34:34 EDT
When trying to remove a server that doesn't have bricks on it but does belong to a cluster that has volumes on it, the remove action fails. According to shireesh, this action should run with "gluster peer detach" and succeed.

2012-06-10 11:25:27,255 WARN  [org.ovirt.engine.core.bll.RemoveVdsCommand] (ajp--0.0.0.0-8009-11) CanDoAction of action RemoveVds failed. Reasons:VDS_CANNOT_REMOVE_HOST_HAVING_GLUSTER_VOLUME,VAR__ACTION__REMOVE,VAR__TYPE__HOST
Comment 2 Shireesh 2012-06-11 02:39:40 EDT
Please provide access details of the cluster (peers) and engine, and the webadmin URL, userid and password so that this can be analyzed.
Comment 3 Dhandapani 2012-06-15 02:13:26 EDT
Not able to simulate in our environment. Please confirm with the latest QA Drop. Moving the bug status to ON_QA.
Comment 4 Sudhir D 2012-06-15 05:37:58 EDT
Looks like this is not reporducible. Since there is no actual fix that was done for this issue, closing this bug. Please reopen if issue persists.

Note You need to log in before you can comment on or make changes to this bug.