Bug 830505 - Boot from live cd doesn't work - kernel panic
Boot from live cd doesn't work - kernel panic
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 05:31 EDT by Bernard Ladenthin
Modified: 2012-07-10 10:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 10:55:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v (9.10 KB, text/plain)
2012-06-10 05:31 EDT, Bernard Ladenthin
no flags Details

  None (edit)
Description Bernard Ladenthin 2012-06-10 05:31:39 EDT
Created attachment 590713 [details]
lspci -v

Description of problem:
I got that kernel panic error from live cd:

[   20.716405] Kernel panic - not syncing: Attempted to kill init!
[   20.716533] Pid: 1, comm: switch_root Not tainted 3.3.4-5.fc17.x86_64 #1
[   20.716662] Call Trace:
[   20.716723] [<ffffffff815e21eb>] panic+0xba/0x1c6
[   20.716823] [<ffffffff8105aff1>] do_exit+0x8b1/0x8c0
[   20.716924] [<ffffffff8105b34f>] do_group_exit+0x3f/0xa0
[   20.717044] [<ffffffff8105b3c7>] sys_exit_group+0x17/0x20
[   20.717155] [<ffffffff815f38e9>] system_call_fastpath+0x16/0x1h
[   20.717274] panic occurred, switching back to text console

Boot from usb sticks works to loading page, but instead gnome only a black screen appears. Fedora 16 works fine a half year.
_

Version-Release number of selected component (if applicable):
kernel-3.3.4-5.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. start system with live cd
2. press enter (default setting)
  
Actual results:
boot hangs

Expected results:
boot does not hangs
Comment 1 Josh Boyer 2012-07-10 10:55:30 EDT
That seems to be userspace exiting as the init process (or segfaulting, etc) and the kernel will not run without at least PID 1 being alive.

There's not much to go on here and we aren't going to be able to fix the live images at this point as they are not remastered after release.  If this continues to fail after reimaging the USB key, or using a different USB key, you might try the nightly live images of rawhide to see if the issue persists.

Note You need to log in before you can comment on or make changes to this bug.