Bug 830510 - xine-ui-0.99.7 is available
xine-ui-0.99.7 is available
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xine-ui (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael J Gruber
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 05:48 EDT by Upstream Release Monitoring
Modified: 2012-10-05 05:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-30 16:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-06-10 05:48:11 EDT
Latest upstream release: 0.99.7
Current version in Fedora Rawhide: 0.99.6
URL: http://sourceforge.net/api/file/index/project-name/xine/mtime/desc/limit/100/rss

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Account closed by user 2012-08-29 10:08:19 EDT
xine-ui has quite a few changes: better M3U playlist handling, various
UI fixes (including a deadlock fix and a crash fix), use of XScreenSaver,
and two overflow bug fixes (which you'll probably want).

xine-ui (0.99.7) unstable; urgency=low:

  * Support for comments in .m3u playlists
  * Avoid possible overflows when handling media marks & M3U files.
  * Fixes for libpng 1.5 and header checking.
  * xine-bugreport uses $TMPDIR.
  * Spanish translation update from Carlos E. Robinson M.
  * Czech translation update.
  * Use only ASCII for "picture" texts in skin.
  * Fix of the help texts encoding.
  * Avoid a deadlock in the tooltips code.
  * Set combo box menu windows' override-redirect flags.
  * MRL browser recognises a few more extensions.
  * Fix LIRC library detection (build time).
  * Fix a segfault which prevented the display of the help window.
  * Make building of fbxine optional (--with-fb; enabled by default).
  * "ToggleFullscreen" command takes an optional numeric parameter,
    controlling whether full-screen mode is switched on or off.
  * New command "Close".
  * Rename default.avi to default.mpv since it's actually an MPEG.
  * Replace the splash .mpv with a PNG (from xine-lib).
  * Support use of JPEG images for splash etc.
  * Make use of XScreenSaver.
  * Set dialogue windows' maximum sizes.
  * Fix LIRC check so that it doesn't fail if liblircclient0.pc (which is
    Debian-specific) is missing.
  * Recognise "authentication needed" messages from xine-lib 1.2.
  * Handle "file is empty" messages from xine-lib.
  * Add support for XINE_EVENT_MRL_REFERENCE_EXT.
  * Use re-entrant XML parser functions (if available).
  * Distribute xine_splash.xcf (source for xine_splash.png).
  * Tidy up building of common function libraries; ensure all replacement
    function sources are distributed.
  * xine.desktop now says that xine can accept files or URLs.
Comment 2 Michael J Gruber 2012-08-30 16:56:43 EDT
0.99.7-2 package builds are available in rawhide now, and soon in testing for f18 etc.

http://koji.fedoraproject.org/koji/buildinfo?buildID=351400

[Forgot to specify the bug # in "fedpkg update", sorry. There's too much redundant stuff in the template :| ]
Comment 3 Andrew Schultz 2012-09-06 22:39:25 EDT
The build for this in updates-testing (0.99.7-2.fc17) seems rather broken.  When bringing up xine, I get:

The stream 'There is no MRL.' uses an upsupported codec:
Video Codec: Image (0x0)
(null)
Start playback anyway?

no-> same dialog again
yes-> dialog goes away, the window is black (no xine logo).
xine seems unable to load images and some videos (DVD fails).  audio seems fine.

reverting to 0.99.6-30.fc17 makes xine happy again.
Comment 4 Michael J Gruber 2012-09-07 03:26:13 EDT
(In reply to comment #3)
> The build for this in updates-testing (0.99.7-2.fc17) seems rather broken. 
> When bringing up xine, I get:
> 
> The stream 'There is no MRL.' uses an upsupported codec:
> Video Codec: Image (0x0)
> (null)
> Start playback anyway?
> 
> no-> same dialog again
> yes-> dialog goes away, the window is black (no xine logo).

What do you mean by "bring up"? Start without arguments from the command line, start from a DE's menu? All of this works for me.

> xine seems unable to load images and some videos (DVD fails).  audio seems
> fine.
> 
> reverting to 0.99.6-30.fc17 makes xine happy again.

Is xine supposed to display images? You mean jpg's? Please provide a link to something that xine is supposed to display, that 0.99.6-30 displays and that 0.99.7-2 does not, so that I can reproduce the issue. Thanks!
Comment 5 Andrew Schultz 2012-09-07 08:34:14 EDT
> What do you mean by "bring up"? Start without arguments from the command line, > start from a DE's menu? All of this works for me.

I'm just running "xine" from a terminal.

> Is xine supposed to display images?

Sadly, I can't seem to find an image format it can handle.  I was operating under the assumption that the logo it normally shows is just an image that it was displaying like any other image, but 0.99.6 doesn't handle other images I give it.

So, beyond the dialog at startup, the only brokenness is DVDs.  When I try to play a DVD, I get the same dialog, but 'There is no MRL.' is replaced by 'dvd:/'; it's still complaining about an Image codec.  If I dismiss the dialog, the DVD does not play.  Before getting the dialog, I get messages from libdvdnav and libdvdread in my terminal that it is (successfully) parsing the DVD.
Comment 6 Andrew Schultz 2012-09-07 09:03:41 EDT
With "xine --verbose=100" I get:

xine-0.99.7:
gui_xine_open_and_play():
        mrl: '/usr/share/xine/skins/xine-ui_logo.png',
        sub 'NONE',
        start_pos 0, start_time 0, av_offset 0, spu_offset 0.
xine: found input plugin  : file input plugin
load_plugins: probing demux 'anx'
load_plugins: probing demux 'image'
xine: found demuxer plugin: image demux plugin
...
video_decoder: no plugin available to handle 'Image'


xine-0.99.6:
gui_xine_open_and_play():
        mrl: 'file:/usr/share/xine/skins/xine-ui_logo.mpv',
        sub 'NONE',
        start_pos 0, start_time 0, av_offset 0, spu_offset 0.
xine: found input plugin  : file input plugin
load_plugins: probing demux 'anx'
load_plugins: probing demux 'image'
load_plugins: probing demux 'aud'
load_plugins: probing demux 'aiff'
...
load_plugins: probing demux 'elem'
xine: found demuxer plugin: Elementary MPEG stream demux plugin

The new xine-ui includes a png instead of an mpv.  If I make my own copy of the mpv, I can open it with xine 0.99.7.

when trying to play a DVD,
xine 0.99.7:
load_plugins: probing demux 'mpeg_block'
xine: found demuxer plugin: DVD/VOB demux plugin
...
av_offset=0 pts
spu_offset=0 pts
gui_xine_open_and_play():
        mrl: '/usr/share/xine/skins/xine-ui_logo.png',
        sub 'NONE',
        start_pos 0, start_time 0, av_offset 0, spu_offset 0.

xine 0.99.6:
load_plugins: probing demux 'mpeg_block'
xine: found demuxer plugin: DVD/VOB demux plugin
...
av_offset=0 pts
spu_offset=0 pts
xine_play
play_internal ...done
(keeps going with more messages)
Comment 7 Andrew Schultz 2012-10-04 23:05:28 EDT
I was finally able to track this down...

> Is xine supposed to display images? You mean jpg's?

Yes.  The xine-lib includes an image demuxer that claims to handle gif, png and jpg.  For reasons that won't make sense to me, xine-lib does /not/ include an image decoder.  That is in xine-lib-extras.  So, without xine-lib-extras installed, I get a the-sky-is-falling dialog because (as indicated in the previous comment), the logo changed from an mpv to a png in 0.99.7 (the logo is "played").
Comment 8 Michael J Gruber 2012-10-05 04:01:17 EDT
(In reply to comment #7)
> I was finally able to track this down...
> 
> > Is xine supposed to display images? You mean jpg's?
> 
> Yes.  The xine-lib includes an image demuxer that claims to handle gif, png
> and jpg.  For reasons that won't make sense to me, xine-lib does /not/
> include an image decoder.  That is in xine-lib-extras.  So, without
> xine-lib-extras installed, I get a the-sky-is-falling dialog because (as
> indicated in the previous comment), the logo changed from an mpv to a png in
> 0.99.7 (the logo is "played").

Thanks for hanging in there. I had pushed the update just the other day because I couldn't reproduce, but I have xine-lib-extras, of course.

So I'll add xine-lib-extras as requires unless there is a good reason not to. There is still a pending plan to move xine-* to rpmfusion, and if/when it's carried out there will be a new package structure anyway.
Comment 9 Michael J Gruber 2012-10-05 05:51:23 EDT
For the image decoder/xine-lib-extras issue I have opened bug 863365 so that we have an open bug independent of this update request. Please follow-up there with anything pertaining to that issue.

Note You need to log in before you can comment on or make changes to this bug.