Bug 830515 - Ovirt SDK - Can't update storage domain name
Ovirt SDK - Can't update storage domain name
Status: CLOSED DUPLICATE of bug 815736
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Pasternak
Oded Ramraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 06:07 EDT by Elena
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 06:21:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elena 2012-06-10 06:07:14 EDT
storage_domain.set_name(new_name)
storage_domain.update()

status: 400  
reason: Bad Request  
detail: [Cannot edit Storage. Only Storage Domain name is updateable.]
Comment 1 Michael Pasternak 2012-06-10 06:21:46 EDT
this is api bug, see https://bugzilla.redhat.com/show_bug.cgi?id=815736
Comment 2 Michael Pasternak 2012-06-10 06:22:12 EDT

*** This bug has been marked as a duplicate of bug 815736 ***
Comment 3 Elena 2012-06-10 06:28:17 EDT
I'm not sure it's the same. When I do it in rest (changing only name) it works.
I think Attila also specified it as:
'If I remove the type tag, operation succeeds, but I think this is not how it's supposed to work.'

Bottom line - when there is a work-around in rest, there is no in sdk
Comment 4 Michael Pasternak 2012-06-10 06:34:45 EDT
of course as in sdk you cannot remove individual elements
from the xml objects,

(i.e it get converted to xml including <type> element which cause #815736)

Note You need to log in before you can comment on or make changes to this bug.