Bug 830518 - Cannot fetch mail from account configured in gnome-online-accounts
Cannot fetch mail from account configured in gnome-online-accounts
Status: CLOSED DUPLICATE of bug 830519
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 06:20 EDT by Yajo
Modified: 2012-06-14 02:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 02:46:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yajo 2012-06-10 06:20:53 EDT
Version-Release number of selected component (if applicable):
evolution-3.4.1-2.fc17.x86_64


Steps to Reproduce:
1. Add a Gmail account in gnome-online-accounts.
2. Activate its e-mail.
3. Open Evolution to see the e-mail.
4. Select for exaple the Inbox folder into that account.


Actual results:
Red alert saying "No existe la carpeta: <folder name>" in every folder. But those *do* exist. From terminal it says:

(evolution:9422): evolution-mail-WARNING **: Failed to refresh folders: No existe la carpeta: INBOX


Expected results:
Read the e-mail.


Additional info:
Gmail's IMAP is correctly configured. I can know it because I can choose to which folders subscribe and the folders are correct.
Comment 1 Milan Crha 2012-06-11 05:58:13 EDT
Thanks for a bug report. I tried to reproduce this with evolution 3.4.2 on a clean machine, by adding a new GMail account and then starting evolution and evolution was able to read the account information, with no error like the one you cited above. I see similar warning in my Yahoo mail account, though.
Comment 2 Milan Crha 2012-06-11 06:04:55 EDT
Oops, I'm sorry, I do not see similar warning from my Yahoo account, it only throws a runtime warning on console:
   camel-WARNING **: camel_store_summary_connect_folder_summary: Store
   summary 0x2281090 doesn't hold path 'INBOX'
but nothing in the UI.

By any chance, can this be related to this upstream bug?
https://bugzilla.gnome.org/show_bug.cgi?id=668247
Comment 3 Yajo 2012-06-11 07:54:22 EDT
(In reply to comment #2)
> By any chance, can this be related to this upstream bug?
> https://bugzilla.gnome.org/show_bug.cgi?id=668247

Hmm I don't think so, because 'INBOX' has not special characters, nor any other of the folders that I cannot fetch.

However, if you are right in bug #830519 comment #1, maybe solving that will solve this?
Comment 4 Milan Crha 2012-06-12 02:57:20 EDT
OK, let's try with the bug #830519 first, and then here.
Comment 5 Milan Crha 2012-06-14 02:46:49 EDT
According to bug #830519 comment #4 there had been issues with permissions set on the data folders/files. I'm marking this as a duplicate of that bug.

*** This bug has been marked as a duplicate of bug 830519 ***

Note You need to log in before you can comment on or make changes to this bug.