Bug 830519 - Cannot add account
Cannot add account
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 830518 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 06:22 EDT by Yajo
Modified: 2012-06-14 02:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 02:45:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yajo 2012-06-10 06:22:43 EDT
Version-Release number of selected component (if applicable):
evolution-3.4.1-2.fc17.x86_64


How reproducible:
Follow every step of the assistant to add an e-mail account.

  
Actual results:
Nothing is added. If you close it and launch it by terminal, you get these 2 messages for each previous attempt you did:

** (evolution:9669): WARNING **: Failed to add service: <account name>: unable to open database file

(evolution:9669): evolution-mail-CRITICAL **: auto_timeout: assertion `CAMEL_IS_SERVICE (service)' failed


Expected results:
New account should appear with the other ones.


Additional info:
I actually managed to add a Gmail account by activating it through gnome-online-accounts, but then it cannot fetch any of the folders. However I submitted that into a different bug (bug #830518).

Seems like it tries to add those accounts, because every time I open it, I get those 2 messages, each one indicating the name of one of those attempts (actually 5, including IMAP, IMAP+ and POP3 accounts).

I renamed ~/.config/evolution and ~/.local/share/evolution and restarted Evolution, but then it cannot open. It fails with this message:

(evolution:10010): e-utils-WARNING **: Lock file creation failed: Permiso denegado

** (evolution:10010): CRITICAL **: mail_session_add_local_store: Permiso denegado
Violación de segmento (`core' generado)
Comment 1 Milan Crha 2012-06-11 04:31:33 EDT
Thanks for a bug report. There seem to be something broken in your setup, because I can add IMAP account into my evolution. Was this a clean install, or you updated from any older Fedora version to Fedora 17?
Comment 2 Yajo 2012-06-11 07:45:54 EDT
I updated from F16, but from CD installation, not from preupgrade.

How can I reset the setup? I ask because you see that deleting ~/.config/evolution and ~/.local/share/evolution does not work.
Comment 3 Milan Crha 2012-06-12 02:53:25 EDT
Updating with CD is OK, there only seem to be some issue with your home, with right in your current home folder (due to that "Permission deny" error).

Can you create
   ~/.local/share/evolution/mail/local
from a terminal? Like with 'mkdir -p ...' command.

To "reset the setup" you also want to delete account information, which is stored under GConf key /apps/evolution. I would use gconf-editor for that, but, if this is about user rights, then the "reset" will not help, especially because the On This Computer mail folder is not part of this setup.
Comment 4 Yajo 2012-06-13 04:40:26 EDT
(In reply to comment #3)
> Updating with CD is OK, there only seem to be some issue with your home,
> with right in your current home folder (due to that "Permission deny" error).
> 
> Can you create
>    ~/.local/share/evolution/mail/local
> from a terminal? Like with 'mkdir -p ...' command.

OK, now you moved me in the right direction. There was a problem with my umask, and from there the permissions error.

It's solved (this and bug #830518), thanks and sorry for the inconveniences.
Comment 5 Milan Crha 2012-06-14 02:45:24 EDT
Good, thanks for the update. I'm closing this accordingly.
Comment 6 Milan Crha 2012-06-14 02:46:49 EDT
*** Bug 830518 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.