Bug 830543 - ABRT not submitting bug reports when it finds existing bugs
ABRT not submitting bug reports when it finds existing bugs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 10:08 EDT by Ryan
Modified: 2012-08-09 17:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 17:30:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report that was supposed to have been submitted to bugzilla (89.86 KB, image/png)
2012-06-10 10:08 EDT, Ryan
no flags Details

  None (edit)
Description Ryan 2012-06-10 10:08:07 EDT
Created attachment 590749 [details]
bug report that was supposed to have been submitted to bugzilla

Description of problem:

When bug reports are submitted to bugzilla, if it determines the bug is a duplicate of an existing bug, it doesn't append to the existing bug.

Version-Release number of selected component (if applicable):

ABRT 2.0.10

How reproducible:

not sure, happens whenever I submit a bug that is determined to be an existing bug

Steps to Reproduce:
1. Submit bug report
2. Go back to submitted bug report and determine if your submission was submitted to the bug listed in "reported to"
3. Discover the bug that was supposedly reported has not been
  
Actual results:

Bugs not submitted to bugzilla to append to an existing report, when a previous bug report for the bug is already determined to exist

Expected results:

details of crash to be appended to previous bug report and info updated (if necessary, e.g. architecture, build version, etc)

Additional info:

a bug report that was supposedly submitted for me was: 767353, if you check that bug report you will note that no bug report was appended there even though my instance of ABRT indicates that it reported my crash to that location.
Comment 1 Jiri Moskovcak 2012-08-09 17:29:48 EDT
If ABRT finds a duplicate, it automatically adds only a comment (if provided) and adds reporting user to CC list (which appears like it did). The arch and package version is added only if it differs from the original report. The new backtrace is added only of it's evaluated as better than what already there (the bt scale is 1-4, so if there is 4 already no other bt will be attached).

Note You need to log in before you can comment on or make changes to this bug.