Bug 830573 - Fedora 17 Live CD / netinst CD / USB installation does not boot on Lenovo IdeaCentre Q180
Fedora 17 Live CD / netinst CD / USB installation does not boot on Lenovo Ide...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 13:43 EDT by Milos Jakubicek
Modified: 2013-01-10 02:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 12:25:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Jakubicek 2012-06-10 13:43:30 EDT
Description of problem:

Fedora 17 installation (KDE live CD, netinst, possibly on USB, always x86_64) cannot boot on Lenovo IdeaCentre Q180, probably due to some EFI issue.

How reproducible:

Boot using one of the above named methods.

Actual results:

System hangs after grub with the following output:

Trying to allocate 1135 pages for VMLINUZ
Got pages at 0x0282f000
[Linux-EFI, setup=0x1068, size=0x46e190]
    [Initrd, addr=0x7e972000, size=0xc6b72a]

(Numbers may vary, of course. Except for the second I get similar output also with Live CD of F15 and F16).

Unfortunately there is no way how to disable EFI boot in BIOS -- is this somehow achievable using a grub / kernel command line option? Currently I can't see a way how to install Fedora.
Comment 1 Milos Jakubicek 2012-06-10 13:47:55 EDT
Just for the completeness: a quite ancient System Rescue CD version 1.2.0 with kernel 2.6.29 boots just fine.
Comment 2 Josh Boyer 2012-06-11 08:14:01 EDT
Matthew?
Comment 3 sara.alderweireldt@gmail.com 2012-06-21 13:34:15 EDT
I'm having this same issue on my Asus UX31, trying to get dual boot Win7 / Fedora 17 running. I booted the install dvd in EFI mode, pointed Fedora to the existing EFI partition, and continued the install as usual. 

My BIOS now has two boot options in the list: Win7 bootmanager & Fedora bootmanager (Grub2 isn't mentioned anywhere). If I select the Win7 as first option, the thing boots properly. If I select the Fedora as first option, I get the error we're discussing here: "Trying to allocate ...". 

I'm assuming I somehow added Fedora EFI boot stuff onto the existing EFI boot partition, instead of getting a clean install (since the Win7 is still booting).

Also for me the issue is appearing if I try to boot the live versions, I tried the USB 17 just as a test.

Any tips on how to fix this boot / install Fedora 17 (next to Win7) cleanly?
Comment 4 sara.alderweireldt@gmail.com 2012-06-21 15:35:55 EDT
(In reply to comment #3)
> I'm having this same issue on my Asus UX31, trying to get dual boot Win7 /
> Fedora 17 running. I booted the install dvd in EFI mode, pointed Fedora to
> the existing EFI partition, and continued the install as usual. 
> 
> My BIOS now has two boot options in the list: Win7 bootmanager & Fedora
> bootmanager (Grub2 isn't mentioned anywhere). If I select the Win7 as first
> option, the thing boots properly. If I select the Fedora as first option, I
> get the error we're discussing here: "Trying to allocate ...". 
> 
> I'm assuming I somehow added Fedora EFI boot stuff onto the existing EFI
> boot partition, instead of getting a clean install (since the Win7 is still
> booting).
> 
> Also for me the issue is appearing if I try to boot the live versions, I
> tried the USB 17 just as a test.
> 
> Any tips on how to fix this boot / install Fedora 17 (next to Win7) cleanly?

Additional info:

I can boot into F17 using rescatux bootusb (latest, 0,30b6), I'm posting this from inside :). Anyway, this is not a solution, but at least it takes the urgency away - somewhat. 

And yes, the rescatux boot menu showed only the F17 entry, no entry for Win7.

Feel free to ask for logs etc., I'd happily provide, but I can't guess what you need to be able to help me.
Comment 5 Milos Jakubicek 2012-06-22 11:13:14 EDT
Matthew, Josh: if you had any tip for a workaround that would enable me to boot and install F17 on that machines, it would help a lot (a kernel option, maybe? I tried "noefi" with no success).

Sara: I'm not sure if this the same bug. I was unable to boot the installation media.
Comment 6 sara.alderweireldt@gmail.com 2012-06-23 10:13:34 EDT
Milos, for installing, I used the dvd. I also had trouble getting the install/live media to boot. On top of that you need to boot them in UEFI mode for the install to succeed (if you boot them in BIOS mode, you'll get an error at partitioning about the lack of a bios-boot partition).

I can boot the F17 install dvd from an external dvd-drive, that I know. Did you try booting from the install dvd? 
I also just tried F17 live image from a USB key again, I can boot it, but not in EFI mode. I don't know about live image on cd, I don't have one lying around.


For booting the installed distro, now that is really proving difficult. I finally managed to get some serious live in it (as in booting without external attached drives/usb keys/...) by, horror, using a ubuntu live distribution from usb. That way I could chroot into my install F17 distro, and install grub2-efi. In fact the entire package was missing from the install, I had to add it. I have no clue how it could happen that this was not installed from the beginning. I did choose to install it, and I did see the install finish cleanly up until the 'Congratulations' screen. 

In any case, I now have a working grub2 on my efi partition, and I can boot everything manually. As in:

set root=(hd0,gpt5)
linux /boot/vmlinuz-... (tab autocompletes)
initrd /boot/init... (tab autocompletes)
boot

All that I have left to do is figure out where to put my config file, or how to tell grub2 where it is. Clearly the thing is not finding it now. Any tips?
Comment 7 sara.alderweireldt@gmail.com 2012-06-23 10:33:24 EDT
It was too easy; the config files had to be in /boot/grub2, and they ended up in /boot/grub.

I'm booting F17 cleanly now. The Windows entry in grub2 is still reporting 'invalid efi path', but that's a problem for another day.
Comment 8 Milos Jakubicek 2012-06-26 10:28:42 EDT
Sara, I'm really not sure whether this is the same issue. I was unable to boot even from the F17 DVD. I tried back with no luck until F13. Hence I installed F13 and preupgraded to F15 and then to F17. Quite a cumbersome way, but now everything works and boots just fine (I didn't have to touch any configuration after the upgrades).
Comment 9 Justin M. Forbes 2012-09-12 12:25:46 EDT
Unfortunately there is no way for us to respin the F17 media, so there is nothing that can be done against this bug. If you could possibly test the F18 alpha and beta spins, that would be a tremendous help. If the issue still occurs please open a new bug against F18
Comment 10 Milos Jakubicek 2012-11-11 13:13:39 EST
Justin: this is just to confirm that I have tried Fedora 18 Alpha KDE x86_64 Live CD, and it boots fine.

Note You need to log in before you can comment on or make changes to this bug.