This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 830621 - Unable to install the mesa update due to missing dependency
Unable to install the mesa update due to missing dependency
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 22:36 EDT by John Mellor
Modified: 2013-01-20 12:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-20 12:40:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mellor 2012-06-10 22:36:56 EDT
Description of problem:
Unable to install the mesa update due to missing dependency

Version-Release number of selected component (if applicable):


How reproducible:
every time

Steps to Reproduce:
1. Freshly-installed F17 system.
2. yum update

  
Actual results:
$ sudo yum update --skip-broken
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package eclipse-eclemma.noarch 0:1.5.3-1.fc16 will be updated
---> Package eclipse-eclemma.noarch 0:2.1.1-2.fc17 will be an update
--> Processing Dependency: jacoco for package: eclipse-eclemma-2.1.1-2.fc17.noarch
---> Package llvm-libs.i686 0:2.9-10.fc16 will be updated
---> Package llvm-libs.x86_64 0:3.0-12.fc17 will be updated
---> Package llvm-libs.i686 0:3.0-13.fc17 will be an update
---> Package llvm-libs.x86_64 0:3.0-13.fc17 will be an update
---> Package mesa-dri-drivers.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-dri-drivers.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-drivers.i686 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-drivers.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-filesystem.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-filesystem.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGL.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-libGL.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGL.i686 0:8.0.3-1.fc17 will be an update
--> Processing Dependency: libglapi.so.0 for package: mesa-libGL-8.0.3-1.fc17.i686
---> Package mesa-libGL.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGL-devel.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGL-devel.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGLU.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGLU.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGLU-devel.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGLU-devel.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libglapi.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libglapi.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libxatracker.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libxatracker.x86_64 0:8.0.3-1.fc17 will be an update
--> Running transaction check
---> Package eclipse-eclemma.noarch 0:2.1.1-2.fc17 will be an update
--> Processing Dependency: jacoco for package: eclipse-eclemma-2.1.1-2.fc17.noarch
---> Package mesa-libglapi.i686 0:8.0.3-1.fc17 will be installed
--> Running transaction check
---> Package eclipse-eclemma.noarch 0:1.5.3-1.fc16 will be updated
---> Package eclipse-eclemma.noarch 0:2.1.1-2.fc17 will be an update
--> Running transaction check
---> Package llvm-libs.i686 0:2.9-10.fc16 will be updated
---> Package llvm-libs.x86_64 0:3.0-12.fc17 will be updated
---> Package llvm-libs.i686 0:3.0-13.fc17 will be an update
---> Package llvm-libs.x86_64 0:3.0-13.fc17 will be an update
---> Package mesa-dri-drivers.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-dri-drivers.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-drivers.i686 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-drivers.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-dri-filesystem.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-dri-filesystem.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGL.i686 0:7.11.2-3.fc16 will be updated
---> Package mesa-libGL.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGL.i686 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGL.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGL-devel.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGL-devel.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGLU.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGLU.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libGLU-devel.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libGLU-devel.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libglapi.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libglapi.i686 0:8.0.3-1.fc17 will be installed
---> Package mesa-libglapi.x86_64 0:8.0.3-1.fc17 will be an update
---> Package mesa-libxatracker.x86_64 0:8.0.2-8.fc17 will be updated
---> Package mesa-libxatracker.x86_64 0:8.0.3-1.fc17 will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    eclipse-eclemma-2.1.1-2.fc17.noarch from updates

Dependencies Resolved

================================================================================
 Package                   Arch         Version             Repository     Size
================================================================================
Updating:
 llvm-libs                 i686         3.0-13.fc17         updates       6.1 M
 llvm-libs                 x86_64       3.0-13.fc17         updates       5.9 M
 mesa-dri-drivers          i686         8.0.3-1.fc17        updates        12 M
 mesa-dri-drivers          x86_64       8.0.3-1.fc17        updates        11 M
 mesa-dri-filesystem       x86_64       8.0.3-1.fc17        updates        24 k
 mesa-libGL                i686         8.0.3-1.fc17        updates       148 k
 mesa-libGL                x86_64       8.0.3-1.fc17        updates       148 k
 mesa-libGL-devel          x86_64       8.0.3-1.fc17        updates       473 k
 mesa-libGLU               x86_64       8.0.3-1.fc17        updates       179 k
 mesa-libGLU-devel         x86_64       8.0.3-1.fc17        updates        91 k
 mesa-libglapi             x86_64       8.0.3-1.fc17        updates        50 k
 mesa-libxatracker         x86_64       8.0.3-1.fc17        updates       386 k
Installing for dependencies:
 mesa-libglapi             i686         8.0.3-1.fc17        updates        48 k
Skipped (dependency problems):
 eclipse-eclemma           noarch       2.1.1-2.fc17        updates       503 k

Transaction Summary
================================================================================
Install                                    ( 1 Dependent package)
Upgrade                        12 Packages
Skipped (dependency problems)   1 Package

Total size: 37 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
mesa-dri-filesystem(x86-32) is needed by mesa-dri-drivers-8.0.3-1.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
llvm-libs-3.0-12.fc17.x86_64 is a duplicate with llvm-libs-2.9-10.fc16.i686
mesa-dri-drivers-7.11.2-3.fc16.i686 has missing requires of mesa-dri-filesystem(x86-32)
mesa-dri-drivers-8.0.2-8.fc17.x86_64 is a duplicate with mesa-dri-drivers-7.11.2-3.fc16.i686
mesa-libGL-8.0.2-8.fc17.x86_64 is a duplicate with mesa-libGL-7.11.2-3.fc16.i686
2:vim-enhanced-7.3.515-2.fc16.x86_64 has missing requires of libruby.so.1.8()(64bit)
xorg-x11-drv-intel-2.19.0-3.fc16.x86_64 has missing requires of libxcb-aux.so.0()(64bit)
xorg-x11-drv-intel-2.19.0-3.fc16.x86_64 has missing requires of xserver-abi(videodrv-11) >= ('0', '0', None)
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2012-06-10.22-28.P9yvsF.yumtx
$ 


Expected results:
Clean install without missing packages dependency.

Additional info:
Comment 1 John Mellor 2012-06-11 21:31:00 EDT
Problem traced to a defective upgrade process as released on the F17 DVD, that does not upgrade the fully up-to-date F16 version of mesa, and simply installs the F17 version as well.

Request that this problem be transferred to the installer product, as that is the root cause of this bug.
Comment 2 Jesse Keating 2012-08-20 14:19:44 EDT
This is actually a mulit-arch problem, because what it's comparing is the x86_64 F17 version with the i686 f16 version.

Multilib screws us again.
Comment 3 Chris Lumens 2013-01-20 12:40:33 EST
With F18, we've moved to a simpler upgrade process that does not involve anaconda in the least.  We're using a tool called fedup now that takes the place of preupgrade, and then uses regular system tools to do the upgrade itself.  With anaconda no longer involved, this bug report should no longer be relevant.

Note You need to log in before you can comment on or make changes to this bug.