This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 830623 - the change in behaviour for asymmetrical routing is not properly described
the change in behaviour for asymmetrical routing is not properly described
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Technical_Notes (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Prpič
ecs-bugs
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 22:50 EDT by manuel wolfshant
Modified: 2015-09-27 22:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 06:07:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description manuel wolfshant 2012-06-10 22:50:15 EDT
Description of problem:
http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6-Beta/html/6.3_Technical_Notes/networking_issues.html states "Red Hat Enterprise Linux 6.3 drops packets when the route for outbound traffic differs from the route of incoming traffic." when in fact the change relies only in the default value of the filtering.

Version-Release number of selected component (if applicable):

Revision 1-0	Tue April 24 2012	Martin Prpič
Initial release of the Red Hat Enterprise Linux 6.3 Beta Technical Notes.

How reproducible:
always


Steps to Reproduce:
1. read the URL mentioned above


Actual results:
"Red Hat Enterprise Linux 6.3 drops packets when the route for outbound traffic differs from the route of incoming traffic."

Expected results:

"Due to the new default settings, Red Hat Enterprise Linux 6.3 drops packets when the route for outbound traffic differs from the route of incoming traffic."


Additional info:
IMHO this change in behaviour is very important and the details on how to change the default settings should be publicly available.
Comment 2 Martin Prpič 2012-06-11 07:02:57 EDT
Manuel, I've updated the description so that it now reads:

<snip>
Because RHEL6.3 defaults to using Strict Reverse Path filtering, packets are dropped by default when the route for outbound traffic differs from the route of incoming traffic. This is in line with current recommended practice in RFC3704. For more information about this issue please refer to /usr/share/doc/kernel-doc-<version>/Documentation/networking/ip-sysctl.txt and https://access.redhat.com/knowledge/solutions/53031. 
</snip>

I believe all the information is available from the resources linked to from the description.

Let me know if this is a viable solution for you. Thanks!
Comment 3 manuel wolfshant 2012-06-11 07:05:27 EDT
Wonderful solution. Thank you.
Comment 4 Martin Prpič 2012-06-11 07:29:45 EDT
Great, thank you! This change will be present in the GA version of the document.
Comment 6 Martin Prpič 2012-06-25 06:07:04 EDT
Fix available on docs.redhat.com. Closing!

Note You need to log in before you can comment on or make changes to this bug.