Bug 830641 - Users can successfully register with mismatching captcha.
Users can successfully register with mismatching captcha.
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 01:10 EDT by mcao
Modified: 2015-05-14 21:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 15:23:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the register shown as the picture can be registered successfully. (41.17 KB, image/png)
2012-06-11 01:10 EDT, mcao
no flags Details

  None (edit)
Description mcao 2012-06-11 01:10:10 EDT
Created attachment 590817 [details]
the register shown as the picture can be registered successfully.

Description of problem:

When I register in the register page, I input correct email,password. but a wrong captcha which is a little diffrence with the given one (the captcha given is "and rnchgo" ,and I inputed "ann..rnchgg"). It turns out to be a successful page and I can receive the email to confirm.

Version-Release number of selected component (if applicable):

devenv_1827

How reproducible:randomly


Steps to Reproduce:

1.Go to openshift register page.
2.Input a valid email and valid password
3.Input a captcha which is a little dismatched with the given  captcha. (For example,if the given captcha is "freedom homendsh" ,you could input "freedo..homendsa");
4.Click "Sign up".
  
Actual results:

It will register successfully, and I can receive a letter to confirm.

Expected results:

It should be left on the register page with error message like
"Captcha text was Incorrect, please try again".

Additional info:

This issue exists on devenv_1827, stg.openshift.redhat.com, and openshift.redhat.com
Comment 1 Clayton Coleman 2012-06-11 15:23:45 EDT
Google is fairly flexible about what the user enters if the whitespace appears to be correct.  Since the implementation of the captcha is completely google defined, our tests merely need to validate that incorrect captchas force the user to refresh the page.

Note You need to log in before you can comment on or make changes to this bug.