Bug 830654 - [abrt] java-1.7.0-openjdk-1.7.0.3-2.1.fc17.6: Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.3-2.1.fc17.6: Process /usr/lib/jvm/java-1.7.0...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:4f4369b538a04f20dab04642657...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 02:07 EDT by Mihkel Vain
Modified: 2012-07-06 11:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-06 11:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (13.37 KB, text/plain)
2012-06-11 02:07 EDT, Mihkel Vain
no flags Details
File: maps (68.75 KB, text/plain)
2012-06-11 02:07 EDT, Mihkel Vain
no flags Details
File: backtrace (69.27 KB, text/plain)
2012-06-11 02:07 EDT, Mihkel Vain
no flags Details

  None (edit)
Description Mihkel Vain 2012-06-11 02:07:03 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        java -Xmx128m -cp ./Azureus2.jar:./swt.jar -Djava.library.path=/home/mihkel/vuze -Dazureus.install.path=/home/mihkel/vuze -Dazureus.script=/home/mihkel/vuze/vuze -Dazureus.script.version=2 org.gudy.azureus2.ui.swt.Main
comment:        I tried to launch vuze
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java
kernel:         3.4.0-1.fc17.x86_64
pid:            1723
pwd:            /home/mihkel/vuze
time:           E 11 juuni 2012 08:47:10 EEST
uid:            1000
username:       mihkel
var_log_messages: Jun 11 08:47:13 gigabyte abrt[1781]: Saved core dump of pid 1723 (/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java) to /var/spool/abrt/ccpp-2012-06-11-08:47:10-1723 (233693184 bytes)

backtrace:      Text file, 70933 bytes
dso_list:       Text file, 13691 bytes
maps:           Text file, 70404 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mihkel/2

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:cd78e2295ac5f856c2727dd99f28f02526e6a2b5 0x6ce779 - libjvm.so -
:cd78e2295ac5f856c2727dd99f28f02526e6a2b5 0x82556f - libjvm.so -
:cd78e2295ac5f856c2727dd99f28f02526e6a2b5 0x6d5b5f JVM_handle_linux_signal libjvm.so -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=gigabyte.lan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/run/user/mihkel/keyring-P6FrKM/gpg:0:1
:TERM=dumb
:SHELL=/bin/bash
:XDG_SESSION_COOKIE=5116faf45411aa5ccce25fd20000000b-1339393003.364459-1532762843
:HISTSIZE=1000
:OLDPWD=/home/mihkel/vuze
:GNOME_KEYRING_CONTROL=/run/user/mihkel/keyring-P6FrKM
:MOZILLA_FIVE_HOME=/usr/lib64/xulrunner-2
:'IMSETTINGS_MODULE=User Specific'
:QT_GRAPHICSSYSTEM_CHECKED=1
:USER=mihkel
:LD_LIBRARY_PATH=/usr/lib64/xulrunner-2
:SSH_AUTH_SOCK=/run/user/mihkel/keyring-P6FrKM/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1096,unix/unix:/tmp/.ICE-unix/1096
:USERNAME=mihkel
:DESKTOP_SESSION=gnome
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mihkel/bin
:MAIL=/var/spool/mail/mihkel
:QT_IM_MODULE=xim
:PWD=/home/mihkel/vuze
:XMODIFIERS=@im=ibus
:EDITOR=emc
:LANG=et_EE.UTF-8
:GNOME_KEYRING_PID=1092
:CLUTTER_PAINT=disable-clipped-redraws:disable-culling
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/mihkel
:XDG_SEAT=seat0
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=mihkel
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-E5KE9l0Ag4,guid=546f93c68227b9d1a9f5b42c0000003b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:DISPLAY=:0.0
:XDG_RUNTIME_DIR=/run/user/mihkel
:XAUTHORITY=/var/run/gdm/auth-for-mihkel-2HVhK7/database
:CCACHE_HASHDIR=
:_=/usr/bin/java

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 31462                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       31462                31462                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/mihkel/.xsession-errors
:2:/home/mihkel/.xsession-errors
:3:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/rt.jar
:4:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/ext/pulse-java.jar
:5:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/ext/gnome-java-bridge.jar
:6:/home/mihkel/vuze/Azureus2.jar
:7:socket:[22722]
:8:socket:[22724]
:9:/home/mihkel/.azureus/.lock
:10:/home/mihkel/.azureus/.lock
:11:/home/mihkel/.azureus/.lock
:12:/home/mihkel/.azureus/.lock
:13:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/jsse.jar
:14:/dev/random
:15:/dev/urandom
:16:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/ext/sunjce_provider.jar
:17:/home/mihkel/vuze/swt.jar
:18:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/jce.jar
:19:/home/mihkel/.azureus/logs/debug_1.log
:20:pipe:[23623]
:21:pipe:[23623]
:22:anon_inode:[eventpoll]
:23:pipe:[22725]
:24:pipe:[22725]
:25:anon_inode:[eventpoll]
:26:pipe:[22726]
:27:pipe:[22726]
:28:anon_inode:[eventpoll]
:29:socket:[23624]
Comment 1 Mihkel Vain 2012-06-11 02:07:07 EDT
Created attachment 590827 [details]
File: dso_list
Comment 2 Mihkel Vain 2012-06-11 02:07:10 EDT
Created attachment 590828 [details]
File: maps
Comment 3 Mihkel Vain 2012-06-11 02:07:13 EDT
Created attachment 590829 [details]
File: backtrace
Comment 4 Deepak Bhole 2012-06-21 16:33:33 EDT
Is this reproducible?
Comment 5 Mihkel Vain 2012-06-22 01:36:14 EDT
Yes. Just tried it. After clicking on ~/vuze/vuze script, vuze launches, I click on some menu item, vuze dissapears and ABRT pops up.
Comment 6 Deepak Bhole 2012-06-22 13:54:24 EDT
The problem is that the trace below Mozilla code does not have any source associated with it, so it is hard to tell what is going on.

If it is reproducible, do you mind first running: 'debuginfo-install java-1.7.0-openjdk' as root and then trying it and sending the GDB trace you see after that?
Comment 7 Mihkel Vain 2012-06-22 14:29:55 EDT
I ran 'debuginfo-install java-1.7.0-openjdk' as root, set ulimit -c unlimited, then I executed ./vuze

$ ./vuze 
Starting Azureus...
Suitable java version found [java = 1.7.0_03-icedtea]
Configuring environment...
Java exec found in PATH. Verifying...
Gtk-Message: Failed to load module "pk-gtk-module"
Browser check failed with: InvocationTargetException, No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]
Auto-scanning for GRE/XULRunner.  You can skip this by appending the GRE path to LD_LIBRARY_PATH and setting MOZILLA_FIVE_HOME.
  checking /usr/lib64/firefox for GRE
	Can not use GRE from /usr/lib64/firefox because it's missing libxpcom.so.
  checking /usr/lib64/xulrunner-2 for GRE
GRE found at /usr/lib64/xulrunner-2.
Browser check failed with: InvocationTargetException, XPCOM error -2147467261
Can't create browser.  Will try to set LD_LIBRARY_PATH and hope Vuze has better luck.
setting LD_LIBRARY_PATH to: /usr/lib64/xulrunner-2
setting MOZILLA_FIVE_HOME to: /usr/lib64/xulrunner-2
Loading Azureus:
java -Xmx128m -cp "./Azureus2.jar:./swt.jar" -Djava.library.path="/home/mihkel/vuze" -Dazureus.install.path="/home/mihkel/vuze" -Dazureus.script="./vuze" -Dazureus.script.version=2 org.gudy.azureus2.ui.swt.Main 
file:/home/mihkel/vuze/Azureus2.jar ; file:/home/mihkel/vuze/swt.jar ; file:/home/mihkel/vuze/
changeLocale: *Default Language* != Estonian (Estonia). Searching without country..
changeLocale: Searching for language Estonian in *any* country..
changeLocale: no message properties for Locale 'Estonian (Estonia)' (et_EE), using 'English (default)'
Gtk-Message: Failed to load module "pk-gtk-module"
UIFunctions/ImageLoad took 25ms
new shell took 206ms
new shell setup took 86ms
skin init took 80ms
MainMenu init took 50ms
pre skin widgets init took 25ms
WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@42eded9
skin widgets (1/2) init took 76ms
skin widgets (2/2) init took 100ms
pre SWTInstance init took 0ms
Init Core Columns took 50ms
SWTInstance init took 0ms
shell.layout took 50ms
---------SHOWN AT 1340389484490;1662ms
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x0000000000000000, pid=9808, tid=140544217949952
#
# JRE version: 7.0_03
# Java VM: OpenJDK 64-Bit Server VM (23.0-b21 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  0x0000000000000000
#
# Core dump written. Default location: /home/mihkel/vuze/core or core.9808
#
# An error report file with more information is saved as:
# /home/mihkel/vuze/hs_err_pid9808.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
./vuze: line 188:  9808 Aborted                 (core dumped) ${JAVA_PROGRAM_DIR}java "${JAVA_ARGS}" -cp "${CLASSPATH}" -Djava.library.path="${PROGRAM_DIR}" -Dazureus.install.path="${PROGRAM_DIR}" -Dazureus.script="$0" $JAVA_PROPS $START_CLASS "$@"
Exit from Azureus complete
No shutdown tasks to do
Azureus TERMINATED.
[mihkel@gigabyte vuze]$ 


Can't see any GDB trace. Also ABRT popped up, but I can't send the report, because it says "Reporting diabled because the backtrace is unusable."

I don't know what to do?
Comment 8 Deepak Bhole 2012-06-22 14:35:55 EDT
Hi Mihkel, looks like vuze is just a shell script.

You should be able to peek into the core dump file now:

gdb -c core.9808 /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java

core.9808 should be in /home/mihkel/vuze/ .. if not core.9808, it might just be 'core'.

Once in, you should be able to do 'thread apply all bt' , and if you can please send that log that'd be great.
Comment 9 Mihkel Vain 2012-06-22 16:23:31 EDT
Is this the right thing?

(gdb) thread apply all bt

Thread 33 (Thread 0x7fd2fb3c9700 (LWP 9828)):
#0  0x0000003191af1f83 in epoll_wait () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd2fbbe1909 in iepoll (timeout=<optimized out>, numfds=4096, events=0x7fd2cc1af000, epfd=20)
    at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:61
#2  Java_sun_nio_ch_EPollArrayWrapper_epollWait (env=0x7fd2cc1f89d8, this=<optimized out>, address=140543344177152, 
    numfds=4096, timeout=<optimized out>, epfd=20) at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:162
#3  0x00007fd301011f70 in ?? ()
#4  0x0000000000000000 in ?? ()

Thread 32 (Thread 0x7fd2fbbd7700 (LWP 9822)):
#0  0x0000003191af1f83 in epoll_wait () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd2fbbe1909 in iepoll (timeout=<optimized out>, numfds=4096, events=0x7fd2cc1cd000, epfd=26)
    at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:61
#2  Java_sun_nio_ch_EPollArrayWrapper_epollWait (env=0x7fd2cc13e1d8, this=<optimized out>, address=140543344300032, 
    numfds=4096, timeout=<optimized out>, epfd=26) at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:162
#3  0x00007fd301011f70 in ?? ()
#4  0x0000000000000000 in ?? ()

Thread 31 (Thread 0x7fd3004d3700 (LWP 9819)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd3004d2d10, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=this@entry=0x7fd304114000, millis=millis@entry=120000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a77f3a3 in park (millis=120000, this=0x7fd304114000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5096
#4  os::sleep (thread=<optimized out>, millis=120000, interruptible=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:3363
#5  0x00007fd30a88da20 in WatcherThread::run (this=0x7fd304113000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1198
#6  0x00007fd30a77a602 in java_start (thread=0x7fd304113000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#7  0x0000003191e07d14 in start_thread (arg=0x7fd3004d3700) at pthread_create.c:309
#8  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 30 (Thread 0x7fd3005d4700 (LWP 9818)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304109c00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
---Type <return> to continue, or q <return> to quit---
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304109c00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304004f10, Self=Self@entry=0x7fd304108800, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748bf7 in Monitor::wait (this=0x7fd304004f10, no_safepoint_check=true, timeout=0, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1111
#5  0x00007fd30a800868 in ServiceThread::service_thread_entry (jt=0x7fd304108800, __the_thread__=0x7fd304108800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/serviceThread.cpp:104
#6  0x00007fd30a895fd6 in JavaThread::thread_main_inner (this=0x7fd304108800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1548
#7  0x00007fd30a77a602 in java_start (thread=0x7fd304108800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#8  0x0000003191e07d14 in start_thread (arg=0x7fd3005d4700) at pthread_create.c:309
#9  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 29 (Thread 0x7fd3006d5700 (LWP 9817)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304107300)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304107300)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304006410, Self=Self@entry=0x7fd304106000, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748995 in Monitor::wait (this=0x7fd304006410, no_safepoint_check=<optimized out>, timeout=0, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1126
#5  0x00007fd30a42123f in CompileQueue::get (this=this@entry=0x7fd304102c50)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/compiler/compileBroker.cpp:637
#6  0x00007fd30a425400 in CompileBroker::compiler_thread_loop ()
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/compiler/compileBroker.cpp:1558
#7  0x00007fd30a895fd6 in JavaThread::thread_main_inner (this=0x7fd304106000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1548
#8  0x00007fd30a77a602 in java_start (thread=0x7fd304106000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#9  0x0000003191e07d14 in start_thread (arg=0x7fd3006d5700) at pthread_create.c:309
#10 0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 28 (Thread 0x7fd3007d6700 (LWP 9816)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
---Type <return> to continue, or q <return> to quit---
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304104900)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304104900)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304006410, Self=Self@entry=0x7fd304103000, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748995 in Monitor::wait (this=0x7fd304006410, no_safepoint_check=<optimized out>, timeout=0, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1126
#5  0x00007fd30a42123f in CompileQueue::get (this=this@entry=0x7fd304102c50)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/compiler/compileBroker.cpp:637
#6  0x00007fd30a425400 in CompileBroker::compiler_thread_loop ()
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/compiler/compileBroker.cpp:1558
#7  0x00007fd30a895fd6 in JavaThread::thread_main_inner (this=0x7fd304103000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1548
#8  0x00007fd30a77a602 in java_start (thread=0x7fd304103000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#9  0x0000003191e07d14 in start_thread (arg=0x7fd3007d6700) at pthread_create.c:309
#10 0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 27 (Thread 0x7fd3008d7700 (LWP 9815)):
#0  sem_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/sem_wait.S:86
#1  0x00007fd30a77cdf1 in check_pending_signals (wait=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:2447
#2  os::signal_wait () at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:2471
#3  0x00007fd30a7766ad in signal_thread_entry (thread=<optimized out>, __the_thread__=0x7fd304101000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/os.cpp:235
#4  0x00007fd30a895fd6 in JavaThread::thread_main_inner (this=0x7fd304101000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:1548
#5  0x00007fd30a77a602 in java_start (thread=0x7fd304101000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#6  0x0000003191e07d14 in start_thread (arg=0x7fd3008d7700) at pthread_create.c:309
#7  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 26 (Thread 0x7fd3009d8700 (LWP 9814)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd3040aaf00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2f0003578, millis=0, interruptible=true, 
    __the_thread__=0x7fd3040aa000)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd3040aa000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00000000ff73b5a8 in ?? ()
#7  0x00007fd3040aa000 in ?? ()
#8  0x00007fd3009d7930 in ?? ()
#9  0x00007fd3040aa000 in ?? ()
#10 0x00007fd3009d7910 in ?? ()
#11 0x0000000000000000 in ?? ()

Thread 25 (Thread 0x7fd300ad9700 (LWP 9813)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd3040a8a00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2f0002078, millis=0, interruptible=true, 
    __the_thread__=0x7fd3040a7800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd3040a7800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00007fd300ad8980 in ?? ()
#7  0x00007fd3040a7800 in ?? ()
#8  0x00007fd3040a7250 in ?? ()
#9  0x00007fd300ad8978 in ?? ()
#10 0x0000000000000000 in ?? ()

Thread 24 (Thread 0x7fd300bda700 (LWP 9812)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd300bd9c00, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd3040a2300, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a7480d1 in ParkCommon (timo=<optimized out>, ev=0x7fd3040a2300)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:426
#4  Monitor::IWait (this=this@entry=0x7fd304005990, Self=Self@entry=0x7fd3040a1000, timo=timo@entry=1000)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#5  0x00007fd30a748bf7 in Monitor::wait (this=0x7fd304005990, no_safepoint_check=true, timeout=1000, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1111
#6  0x00007fd30a8db029 in VMThread::loop (this=this@entry=0x7fd3040a1000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vmThread.cpp:433
#7  0x00007fd30a8db322 in VMThread::run (this=0x7fd3040a1000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/vmThread.cpp:284
#8  0x00007fd30a77a602 in java_start (thread=0x7fd3040a1000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#9  0x0000003191e07d14 in start_thread (arg=0x7fd300bda700) at pthread_create.c:309
#10 0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 23 (Thread 0x7fd309440700 (LWP 9811)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304018e00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304018e00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304015610, Self=Self@entry=0x7fd304017800, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748bf7 in Monitor::wait (this=0x7fd304015610, no_safepoint_check=true, timeout=0, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1111
#5  0x00007fd30a50b8aa in GCTaskManager::get_task (this=0x7fd304015590, which=1)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/gc_implementation/parallelScavenge/gcTaskManager.cpp:652
#6  0x00007fd30a50cbae in GCTaskThread::run (this=0x7fd304017800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/gc_implementation/parallelScavenge/gcTaskThread.cpp:131
#7  0x00007fd30a77a602 in java_start (thread=0x7fd304017800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#8  0x0000003191e07d14 in start_thread (arg=0x7fd309440700) at pthread_create.c:309
#9  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 22 (Thread 0x7fd309541700 (LWP 9810)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304017000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304017000)
---Type <return> to continue, or q <return> to quit---
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304015610, Self=Self@entry=0x7fd304016000, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748bf7 in Monitor::wait (this=0x7fd304015610, no_safepoint_check=true, timeout=0, 
    as_suspend_equivalent=false)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1111
#5  0x00007fd30a50b8aa in GCTaskManager::get_task (this=0x7fd304015590, which=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/gc_implementation/parallelScavenge/gcTaskManager.cpp:652
#6  0x00007fd30a50cbae in GCTaskThread::run (this=0x7fd304016000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/gc_implementation/parallelScavenge/gcTaskThread.cpp:131
#7  0x00007fd30a77a602 in java_start (thread=0x7fd304016000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:886
#8  0x0000003191e07d14 in start_thread (arg=0x7fd309541700) at pthread_create.c:309
#9  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 21 (Thread 0x7fd30a07d700 (LWP 9809)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd304008f00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a747e47 in ParkCommon (timo=0, ev=0x7fd304008f00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:424
#3  Monitor::IWait (this=this@entry=0x7fd304005910, Self=Self@entry=0x7fd304008000, timo=timo@entry=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:802
#4  0x00007fd30a748a2a in Monitor::wait (this=0x7fd304005910, no_safepoint_check=<optimized out>, timeout=0, 
    as_suspend_equivalent=true)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/mutex.cpp:1126
#5  0x00007fd30a895ce1 in Threads::destroy_vm ()
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/thread.cpp:3801
#6  0x00007fd30a5c7c13 in jni_DestroyJavaVM (vm=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jni.cpp:5236
#7  0x00000031398029a6 in JavaMain (_args=<optimized out>) at ../../../src/share/bin/java.c:449
#8  0x0000003191e07d14 in start_thread (arg=0x7fd30a07d700) at pthread_create.c:309
#9  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 20 (Thread 0x7fd30ad46740 (LWP 9808)):
#0  0x0000003191e08e60 in pthread_join (threadid=140544383112960, thread_return=thread_return@entry=0x7fffa63e8548)
    at pthread_join.c:93
#1  0x000000313980934d in ContinueInNewThread0 (continuation=continuation@entry=0x3139802710 <JavaMain>, 
---Type <return> to continue, or q <return> to quit---
    stack_size=1048576, args=args@entry=0x7fffa63e85e0) at ../../../src/solaris/bin/java_md_solinux.c:997
#2  0x00000031398042d5 in ContinueInNewThread (ifn=ifn@entry=0x7fffa63e86e0, threadStackSize=<optimized out>, 
    argc=<optimized out>, argv=0x64c108, mode=<optimized out>, what=<optimized out>, ret=0)
    at ../../../src/share/bin/java.c:1859
#3  0x000000313980941d in JVMInit (ifn=ifn@entry=0x7fffa63e86e0, threadStackSize=<optimized out>, 
    argc=<optimized out>, argv=<optimized out>, mode=mode@entry=1, 
    what=what@entry=0x7fffa63ee333 "org.gudy.azureus2.ui.swt.Main", ret=ret@entry=0)
    at ../../../src/solaris/bin/java_md_solinux.c:1044
#4  0x0000003139804d15 in JLI_Launch (argc=0, argv=0x64c108, jargc=jargc@entry=1, jargv=jargv@entry=0x0, 
    appclassc=appclassc@entry=1, appclassv=appclassv@entry=0x0, 
    fullversion=fullversion@entry=0x4007e0 "1.7.0_03-icedtea-mockbuild_2012_06_13_15_59-b00", 
    dotversion=dotversion@entry=0x4007d5 "1.7", pname=pname@entry=0x4007d0 "java", lname=lname@entry=0x4007d0 "java", 
    javaargs=javaargs@entry=0 '\000', cpwildcard=cpwildcard@entry=1 '\001', javaw=javaw@entry=0 '\000', 
    ergo=ergo@entry=0) at ../../../src/share/bin/java.c:297
#5  0x0000000000400615 in main (argc=<optimized out>, argv=<optimized out>) at ../../../../src/share/bin/main.c:106

Thread 19 (Thread 0x7fd2dcb20700 (LWP 9856)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x000000319e6238d0 in PR_WaitCondVar () from /lib64/libnspr4.so
#2  0x00007fd2bf316277 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#3  0x00007fd2bf30ba67 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#4  0x00007fd2bf2e1df8 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#5  0x00007fd2bf30bce9 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#6  0x000000319e628c33 in ?? () from /lib64/libnspr4.so
#7  0x0000003191e07d14 in start_thread (arg=0x7fd2dcb20700) at pthread_create.c:309
#8  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 18 (Thread 0x7fd2dd6f0700 (LWP 9855)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:39
#1  0x00007fd2bf325dc4 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#2  0x00007fd2bf325993 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#3  0x00007fd2bf324460 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#4  0x00007fd2bf3304a2 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#5  0x00007fd2bf329eeb in ?? () from /usr/lib64/xulrunner-2/libxul.so
#6  0x00007fd2bf32d38c in ?? () from /usr/lib64/xulrunner-2/libxul.so
#7  0x00007fd2bf3308d5 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#8  0x0000003191e07d14 in start_thread (arg=0x7fd2dd6f0700) at pthread_create.c:309
#9  0x0000003191af199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 17 (Thread 0x7fd2f98b6700 (LWP 9853)):
---Type <return> to continue, or q <return> to quit---
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd2cc4d6a00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2f001e0a0, millis=0, interruptible=true, 
    __the_thread__=0x7fd2cc4ae800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd2cc4ae800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00007fd2d8101ed0 in ?? ()
#7  0x00007fd2f98b58c0 in ?? ()
#8  0x00007fd2f98b57e0 in ?? ()
#9  0x00007fd30a6a9735 in set_common (__the_thread__=0x0, vtable_index=<optimized out>, selected_method=..., 
    resolved_method=..., selected_klass=..., resolved_klass=..., this=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:117
#10 set_virtual (__the_thread__=0x0, vtable_index=<optimized out>, selected_method=..., resolved_method=..., 
    selected_klass=..., resolved_klass=..., this=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:98
#11 LinkResolver::runtime_resolve_virtual_method (result=..., resolved_method=..., resolved_klass=..., recv=..., 
    recv_klass=..., check_null_and_abstract=176, __the_thread__=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:865
#12 0x00007fd301006158 in ?? ()
#13 0x0000000000000000 in ?? ()

Thread 16 (Thread 0x7fd2fa391700 (LWP 9838)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fa390810, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=this@entry=0x7fd2f002ef00, millis=millis@entry=500)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a77f1c8 in park (millis=500, this=0x7fd2f002ef00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5096
#4  os::sleep (thread=0x7fd2f002e800, millis=500, interruptible=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:3337
#5  0x00007fd30a5ea842 in JVM_Sleep (env=<optimized out>, threadClass=<optimized out>, millis=500)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:2876
#6  0x00007fd301011f70 in ?? ()
#7  0x0000000000000000 in ?? ()
---Type <return> to continue, or q <return> to quit---

Thread 15 (Thread 0x7fd2fa492700 (LWP 9837)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd2cc41de00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2e8013750, millis=0, interruptible=true, 
    __the_thread__=0x7fd2cc41d800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd2cc41d800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00000000edfde760 in ?? ()
#7  0x0000000000000000 in ?? ()

Thread 14 (Thread 0x7fd2fa593700 (LWP 9836)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fa592660, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd2cc3c6800, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2f001b7f0, millis=5000, interruptible=true, 
    __the_thread__=0x7fd2cc3c6000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=5000, __the_thread__=0x7fd2cc3c6000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=5000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#6  0x00007fd301011f70 in ?? ()
#7  0x00000000eda39530 in ?? ()
#8  0x0000000000000000 in ?? ()

Thread 13 (Thread 0x7fd2fa694700 (LWP 9835)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fa693660, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd2cc3cad00, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2e80122f8, millis=10000, interruptible=true, 
---Type <return> to continue, or q <return> to quit---
    __the_thread__=0x7fd2cc3c5000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=10000, __the_thread__=0x7fd2cc3c5000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=10000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#6  0x00007fd301011f70 in ?? ()
#7  0x00000000eda39530 in ?? ()
#8  0x0000000000000000 in ?? ()

Thread 12 (Thread 0x7fd2faec4700 (LWP 9834)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd2cc240400)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2e800f8f8, millis=0, interruptible=true, 
    __the_thread__=0x7fd2cc3b6800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd2cc3b6800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00000000edfde760 in ?? ()
#7  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7fd2fafc5700 (LWP 9832)):
#0  0x0000003191ae8eef in __GI___poll (fds=fds@entry=0x7fd2fafc4640, nfds=nfds@entry=1, timeout=timeout@entry=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fd2fbdf5c7b in NET_Timeout (s=s@entry=8, timeout=timeout@entry=-1)
    at ../../../src/solaris/native/java/net/linux_close.c:363
#2  0x00007fd2fbdf6c37 in Java_java_net_PlainSocketImpl_socketAccept (env=0x7fd2cc20d1d8, this=0x7fd2fafc47c8, 
    socket=0x7fd2fafc47c0) at ../../../src/solaris/native/java/net/PlainSocketImpl.c:707
#3  0x00007fd301011f70 in ?? ()
#4  0x00007fd301005410 in ?? ()
#5  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fd2fb0c6700 (LWP 9831)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fb0c5660, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
---Type <return> to continue, or q <return> to quit---
#2  os::PlatformEvent::park (this=0x7fd2cc237e00, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2b8006540, millis=10000, interruptible=true, 
    __the_thread__=0x7fd2cc237800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=10000, __the_thread__=0x7fd2cc237800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=10000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#6  0x00007fd301011f70 in ?? ()
#7  0x00007fd2fb0c58a0 in ?? ()
#8  0x00007fd30101cc23 in ?? ()
#9  0x00007fd301005410 in ?? ()
#10 0x00007fd200000000 in ?? ()
#11 0x00007fd2fb0c5840 in ?? ()
#12 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fd2fb1c7700 (LWP 9830)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x00007fd30a78121b in os::PlatformEvent::park (this=0x7fd2cc222400)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5070
#2  0x00007fd30a76e8a5 in ObjectMonitor::wait (this=0x7fd2b8006498, millis=0, interruptible=true, 
    __the_thread__=0x7fd2cc21b800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1507
#3  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=0, __the_thread__=0x7fd2cc21b800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#4  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#5  0x00007fd301011f70 in ?? ()
#6  0x00007fd2fb1c6820 in ?? ()
#7  0x00007fd30a6a9735 in set_common (__the_thread__=0x0, vtable_index=<optimized out>, selected_method=..., 
    resolved_method=..., selected_klass=..., resolved_klass=..., this=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:117
#8  set_virtual (__the_thread__=0x0, vtable_index=<optimized out>, selected_method=..., resolved_method=..., 
    selected_klass=..., resolved_klass=..., this=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:98
#9  LinkResolver::runtime_resolve_virtual_method (result=..., resolved_method=..., resolved_klass=..., recv=..., 
    recv_klass=..., check_null_and_abstract=248, __the_thread__=0x0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/interpreter/linkResolver.cpp:865
#10 0x00007fd301006158 in ?? ()
---Type <return> to continue, or q <return> to quit---
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fd2fb2c8700 (LWP 9829)):
#0  0x0000003191af1f83 in epoll_wait () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd2fbbe1909 in iepoll (timeout=<optimized out>, numfds=4096, events=0x7fd2cc1c0000, epfd=23)
    at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:61
#2  Java_sun_nio_ch_EPollArrayWrapper_epollWait (env=0x7fd2cc1f99d8, this=<optimized out>, address=140543344246784, 
    numfds=4096, timeout=<optimized out>, epfd=23) at ../../../src/solaris/native/sun/nio/ch/EPollArrayWrapper.c:162
#3  0x00007fd301011f70 in ?? ()
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fd2fb4ca700 (LWP 9827)):
#0  0x0000003191e0e32d in accept () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fd2fbbe12c3 in Java_sun_nio_ch_ServerSocketChannelImpl_accept0 (env=0x7fd2cc1ef9d8, this=<optimized out>, 
    ssfdo=<optimized out>, newfdo=0x7fd2fb4c98e8, isaa=0x7fd2fb4c98e0)
    at ../../../src/solaris/native/sun/nio/ch/ServerSocketChannelImpl.c:90
#2  0x00007fd301011f70 in ?? ()
#3  0x00007fd2fb4c98e0 in ?? ()
#4  0x00007fd30101ce83 in ?? ()
#5  0x00007fd301005410 in ?? ()
#6  0x00007fd200000000 in ?? ()
#7  0x00007fd2fb4c9880 in ?? ()
#8  0x00000000ee11f4c0 in ?? ()
#9  0x00007fd2fb4c98f8 in ?? ()
#10 0x00000000ee11fd38 in ?? ()
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fd2fb5cb700 (LWP 9826)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fb5ca620, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd2cc193d00, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2b8003b40, millis=50, interruptible=true, 
    __the_thread__=0x7fd2cc193000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=50, __the_thread__=0x7fd2cc193000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=50)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
---Type <return> to continue, or q <return> to quit---
#6  0x00007fd301011f70 in ?? ()
#7  0x00000000ff7ad9d0 in ?? ()
#8  0x00007fd2cc193000 in ?? ()
#9  0x00007fd2fb5ca820 in ?? ()
#10 0x00007fd2cc193000 in ?? ()
#11 0x00007fd2fb5ca800 in ?? ()
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fd2fb6cc700 (LWP 9825)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fb6cb670, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd2cc184500, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2b80026e8, millis=50, interruptible=true, 
    __the_thread__=0x7fd2cc183800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=50, __the_thread__=0x7fd2cc183800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=50)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#6  0x00007fd301011f70 in ?? ()
#7  0x00007fd2fb6cb860 in ?? ()
#8  0x00007fd2cc183800 in ?? ()
#9  0x00007fd2cc185500 in ?? ()
#10 0x00007fd2fb6cb848 in ?? ()
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fd2fb9d5700 (LWP 9824)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fb9d46c0, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=this@entry=0x7fd2cc17ee00, millis=millis@entry=10000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a77f1c8 in park (millis=10000, this=0x7fd2cc17ee00)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5096
#4  os::sleep (thread=0x7fd2cc17e000, millis=10000, interruptible=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:3337
#5  0x00007fd30a5ea842 in JVM_Sleep (env=<optimized out>, threadClass=<optimized out>, millis=10000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:2876
---Type <return> to continue, or q <return> to quit---
#6  0x00007fd301011f70 in ?? ()
#7  0x00007fd301005410 in ?? ()
#8  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fd2fbad6700 (LWP 9823)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd2fbad5720, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=0x7fd2c4002500, millis=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a76e85a in ObjectMonitor::wait (this=0x7fd2f0004bc8, millis=1000, interruptible=true, 
    __the_thread__=0x7fd2c4008800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/objectMonitor.cpp:1509
#4  0x00007fd30a85c33c in ObjectSynchronizer::wait (obj=..., millis=1000, __the_thread__=0x7fd2c4008800)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/runtime/synchronizer.cpp:388
#5  0x00007fd30a5e328e in JVM_MonitorWait (env=<optimized out>, handle=<optimized out>, ms=1000)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:525
#6  0x00007fd301011f70 in ?? ()
#7  0x00000000edff0f30 in ?? ()
#8  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fd3001c8700 (LWP 9821)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:218
#1  0x00007fd30a77910f in safe_cond_timedwait (_abstime=0x7fd3001c7800, _mutex=<optimized out>, _cond=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:4442
#2  os::PlatformEvent::park (this=this@entry=0x7fd2cc05b600, millis=millis@entry=25)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5125
#3  0x00007fd30a77f1c8 in park (millis=25, this=0x7fd2cc05b600)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5096
#4  os::sleep (thread=0x7fd2cc05e000, millis=25, interruptible=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:3337
#5  0x00007fd30a5ea842 in JVM_Sleep (env=<optimized out>, threadClass=<optimized out>, millis=25)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/prims/jvm.cpp:2876
#6  0x00007fd301011f70 in ?? ()
#7  0x00000000ff7cad90 in ?? ()
#8  0x000000000000099d in ?? ()
#9  0x00007fd3001c7960 in ?? ()
#10 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fd3002fa700 (LWP 9820)):
---Type <return> to continue, or q <return> to quit---
#0  0x0000003191a35965 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x0000003191a37118 in __GI_abort () at abort.c:91
#2  0x00007fd30a77b749 in os::abort (dump_core=true)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1588
#3  0x00007fd30a8d689f in VMError::report_and_die (this=0x7fd3002f7720)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1012
#4  0x00007fd30a782c0f in JVM_handle_linux_signal (sig=11, info=0x7fd3002f7970, ucVoid=0x7fd3002f7840, 
    abort_if_unrecognized=1)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:528
#5  <signal handler called>
#6  0x0000000000000000 in ?? ()
#7  0x00007fd2bf2e2833 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#8  0x00007fd2bf306eda in ?? () from /usr/lib64/xulrunner-2/libxul.so
#9  0x00007fd2bf30721f in ?? () from /usr/lib64/xulrunner-2/libxul.so
#10 0x00007fd2bf3081b8 in ?? () from /usr/lib64/xulrunner-2/libxul.so
#11 0x00007fd2bf308c4d in ?? () from /usr/lib64/xulrunner-2/libxul.so
#12 0x00007fd2bf2e5c69 in NS_InitXPCOM2_P () from /usr/lib64/xulrunner-2/libxul.so
#13 0x00007fd2f8e19a3e in Java_org_eclipse_swt_internal_mozilla_XPCOM__1NS_1InitXPCOM2 ()
   from /home/mihkel/.swt/lib/linux/x86_64/libswt-mozilla-gtk-3802.so
#14 0x00007fd301011f70 in ?? ()
#15 0x00007fd3fffffffe in ?? ()
#16 0x00007fd30415de98 in ?? ()
#17 0x00007fd3002f7f80 in ?? ()
#18 0x00007fd30101d003 in ?? ()
#19 0x00007fd301005410 in ?? ()
#20 0x00007fd300000000 in ?? ()
#21 0x00007fd3002f7f20 in ?? ()
#22 0x00000000eea60f48 in ?? ()
#23 0x00007fd3002f7fa8 in ?? ()
#24 0x00000000eea81fc0 in ?? ()
#25 0x0000000000000000 in ?? ()
(gdb)
Comment 10 Deepak Bhole 2012-06-22 16:37:29 EDT
Yes, thank you! Okay, so it seems that the error is in SWT code -- unfortunately there is nothing that the JVM can do about it.

I am going to assign this to the SWT owners, however one question for you (that I am sure they will ask): Do you know where /home/mihkel/.swt/lib/linux/x86_64/libswt-mozilla-gtk-3802.so comes from? If it is not from the system, I think the only place to open this bug then would be with whoever supplies that .so file.
Comment 11 Mihkel Vain 2012-06-23 02:50:37 EDT
$ ls -lh|grep libswt-mozilla-gtk-3802.so
-rwxr-xr-x. 1 mihkel mihkel  97K 11. juuni 08:47 libswt-mozilla-gtk-3802.so
$ 

libswt-mozilla-gtk-3802.so is dated as 11 june this year. I don't know for sure where it came from, but at 11 june I downloaded vuze and reported this bug. So should I report this bug against vuze? Here on bugzilla or upstream?
Comment 12 Alexander Kurtakov 2012-06-25 01:04:12 EDT
There is vuze build specifically for Fedora (yum install azureus). Is the problem the same with it? libswt-mozilla does not work on fedora because of upstream not working with xulrunner >= 10.0. If you insist on working with xulrunner/mozilla and/or upstream vuze please read how to tell it to use older xulrunner or webkit at http://www.eclipse.org/swt/faq.php#browserlinux .
Comment 13 Mihkel Vain 2012-06-25 02:41:20 EDT
I did not try "yun install azureus", because I thought that since vuze is a java program, it should work just like that :)
Anyway http://www.eclipse.org/swt/faq.php#browserlinux seems a bit confusing for me, so I decided to go with prepackaged azereus.
Comment 14 Alexander Kurtakov 2012-07-06 09:21:07 EDT
would you please close the bug if the packaged azureus work for you?
Comment 15 Mihkel Vain 2012-07-06 11:01:46 EDT
Ok

Note You need to log in before you can comment on or make changes to this bug.