Bug 830668 - Should remove checking ~/.ssh/config as well while creating app
Should remove checking ~/.ssh/config as well while creating app
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 03:35 EDT by Xiaoli Tian
Modified: 2012-06-11 15:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 15:21:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-06-11 03:35:15 EDT
Description of problem:
While creating app, we still check the permissions or contents in ~/.ssh/config like below:
[xiaoli@localhost 611]$ rhc app create -a scalejboss -t jbossas-7 -s -l xtian+t101@redhat.com -p1
Creating application: scalejboss in domup001
Now your new domain name is being propagated worldwide (this might take a minute)...
Bad owner or permissions on /home/xiaoli/.ssh/config
fatal: The remote end hung up unexpectedly
Error in git clone
Cleaning up application

or

[xiaoli@localhost 611]$ rhc app create -a jbossapp1 -t jbossas-7 -l xtian+t101@redhat.com -p 12
Creating application: jbossapp1 in domup001
Now your new domain name is being propagated worldwide (this might take a minute)...
    retry # 5 - Waiting for DNS: jbossapp1-domup001.dev.rhcloud.com
/home/xiaoli/.ssh/config: line 18: Bad configuration option: ~
/home/xiaoli/.ssh/config: terminating, 1 bad configuration options
fatal: The remote end hung up unexpectedly
Error in git clone

As bug 829858 said, we do not need to check ~/.ssh/config any more, then we should remove the checking while creating app as well

Version-Release number of selected component (if applicable):
rhc-0.94.3-1.el6_2.noarch

How reproducible:
Always

Steps to Reproduce:
1.Change ~/.ssh/config permission to 666 
2.Try to create app

  
Actual results:
It will fail to create app and clone repo

Expected results:
It should create app and clone repo successfully

Additional info:
Comment 1 Clayton Coleman 2012-06-11 15:21:38 EDT
The permissions actually have to be correct for .ssh/config to work - the issue is only that we shouldn't fail the rhc domains status test if .ssh/config doesn't exist.  

If .ssh/config is not correctly permissioned, or if .ssh/config has errors, the user will not be able to use GIT or SSH to connect to their remote machine.  The checks in rhc domain status are intended to verify that those items are correct, so we still need the checks.  However, we should move the functionality in rhc domain status into rhc setup, since the purpose of rhc setup is to ensure your machine is correctly configured.

I created a new story to cover moving the remaining 'rhc domain status' functionality into 'rhc setup'.  https://rally1.rallydev.com/#/4670513817d/detail/userstory/6694331230

Note You need to log in before you can comment on or make changes to this bug.