Bug 830691 - RHEV-H TUI: Network settings get lost when configuring nic
RHEV-H TUI: Network settings get lost when configuring nic
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: beta
: 6.3
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 04:31 EDT by Guohua Ouyang
Modified: 2016-04-26 11:28 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Previously, existing nameservers were overwritten when a new network interface card was added and configured with DHCP. This update adds the "PEERDNS=no" parameter when nameservers are provided, to prevent overwriting existing nameservers.
Story Points: ---
Clone Of: 781707
Environment:
Last Closed: 2013-02-28 11:36:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 RHEL Product and Program Management 2012-07-10 02:33:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 21:51:00 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 Fabian Deutsch 2012-09-13 09:37:13 EDT
Upstream patch (could also reproduce it upstream)

http://gerrit.ovirt.org/#/c/7981/

Tested as follows:
1. Clean Node install
2. go to Network page
3. Enter a dns server (192.168.1.1)
4. Configure one NIC, "the "Unsaved changes detected" dialog appears
5. press "OK"
6. Configure the nic with dhcp

The DNS server does not change and stays at 192.168.1.1

7. Reboot and login

DNS is the same.
Comment 13 errata-xmlrpc 2013-02-28 11:36:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.