Bug 830774 - rhev-h: install fails for version 3.1 on compatibility version
rhev-h: install fails for version 3.1 on compatibility version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Dan Kenigsberg
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 07:47 EDT by Dafna Ron
Modified: 2016-04-26 12:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 14:20:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-06-11 07:47:57 EDT
Description of problem:

installing the host on 3.1 will fail because of vdsm compitability version. 

please make sure that /usr/share/vdsm/dsaversion.pyc has:
    'clusterLevels': ['3.0', '3.1'],

Version-Release number of selected component (if applicable):
 
Red Hat Enterprise Virtualization Hypervisor release 6.3 (20120606.3)

How reproducible:

100%

Steps to Reproduce:
1. install rhev-h on rhev-m 3.1
2. 
3.
  
Actual results:

install will fail with compitability version error

Expected results:

/usr/share/vdsm/dsaversion.pyc should have:
    'clusterLevels': ['3.0', '3.1'],

Additional info:
Comment 1 Perry Myers 2012-06-11 08:42:45 EDT
This functionality is controlled by vdsm (RHEV-M registration) so moving to that component
Comment 2 Haim 2012-06-12 02:09:51 EDT
(In reply to comment #1)
> This functionality is controlled by vdsm (RHEV-M registration) so moving to
> that component

not sure if its a vdsm or engine issue, we have a similar issue with RHEL hosts with latest vdsm after dsaverion.py was changed.
Comment 3 Itamar Heim 2012-06-21 08:36:08 EDT
igor - this is fixed by now, right?
Comment 4 Dan Kenigsberg 2012-06-27 14:20:17 EDT
Fixed by http://gerrit.usersys.redhat.com/1308 which is included
at v4.9.6-14, and tested by many. no need to keep around.

Note You need to log in before you can comment on or make changes to this bug.