Bug 830786 - maven-ant-tasks has missing runtime dependency on maven-error-diagnostics
Summary: maven-ant-tasks has missing runtime dependency on maven-error-diagnostics
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: maven-ant-tasks
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-11 12:24 UTC by Michel Alexandre Salim
Modified: 2013-03-19 12:56 UTC (History)
3 users (show)

Fixed In Version: maven-ant-tasks-2.1.3-4.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-19 12:56:24 UTC
Type: Bug


Attachments (Terms of Use)

Description Michel Alexandre Salim 2012-06-11 12:24:58 UTC
Description of problem:
Attempting to build software that depends on maven-ant-tasks using mvn-rpmbuild fails unless I add an explicit BR on maven-error-diagnostics; this is listed in maven-ant-tasks' POM file as a dependency but the RPM does not depend on it.

Version-Release number of selected component (if applicable):
maven-ant-tasks-2.1.1-9.fc17

How reproducible:
Always

Steps to Reproduce:
1. Download Leiningen SRPM (bug #830784) and its dependencies still being reviewed
2. Edit spec, disable BR on maven-error-diagnostics
3. Attempt to rebuild
  
Actual results:
Build fails - maven-ant-tasks requires in maven-error-diagnostics but its RPM does not depend on it

Expected results:
Build succeeds

Additional info:

Comment 1 Orion Poplawski 2012-06-11 16:03:44 UTC
Hmm, looks like maven-ant-tasks depends on maven 2, so this package may need to be dropped.

Comment 2 Mat Booth 2013-03-19 12:56:24 UTC
This should be fixed in F19 and rawhide.


Note You need to log in before you can comment on or make changes to this bug.