Bug 830949 - system registration server selection dialog is missing at-spi locators
system registration server selection dialog is missing at-spi locators
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-11 14:38 EDT by J.C. Molet
Modified: 2013-01-07 22:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
registration locators (92.49 KB, image/png)
2012-06-11 14:39 EDT, J.C. Molet
no flags Details
missing locators v2 (36.43 KB, image/png)
2012-06-19 12:54 EDT, J.C. Molet
no flags Details
New subscription manager window (22.50 KB, image/png)
2012-07-02 11:20 EDT, Sharath Dwaral
no flags Details
Verifying tags for new subscription manager window (93.36 KB, image/png)
2012-07-02 11:26 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description J.C. Molet 2012-06-11 14:38:55 EDT
Description of problem:
The server selection page is missing key at-spi locators making it unusable in a accessibility situation and in automation.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.3-1.git.30.db0f648.el5

How reproducible:
always

Steps to Reproduce:
1.  Start a fresh version of subscription-manager-gui
2.  Click the register button
3.  Try to access/view any of the clickable content in the window via locators
  
Actual results:
The radial buttons and the text entry field do not have locator values set for them and cannot be seen.

Expected results:
These elements would have some sort of clear/descriptive at-spi locator assigned to them.

Additional info:
I'm only marking this high because it significantly blocks all register tests (with all other automated tests depend on).
Comment 1 J.C. Molet 2012-06-11 14:39:46 EDT
Created attachment 590995 [details]
registration locators

screenshot of the items with missing locators
Comment 2 RHEL Product and Program Management 2012-06-11 14:48:16 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Alex Wood 2012-06-18 11:12:22 EDT
commit 830e9ccb6247e25c39f7883f411e2c2ef281b103
Refs: subscription-manager-1.0.3-1-50-g830e9cc
Author:     Adrian Likins <alikins@redhat.com>
AuthorDate: Wed Jun 13 12:24:30 2012 -0400
Commit:     Adrian Likins <alikins@redhat.com>
CommitDate: Wed Jun 13 12:24:30 2012 -0400

    830949: add accessibility locators for registration widgets

    Also, clean up some of the widget names to be a little
    more consistent. Update registergui.py for some of the
    widget name changes.
Comment 4 J.C. Molet 2012-06-19 12:54:07 EDT
Created attachment 593006 [details]
missing locators v2

Tested with: subscription-manager-gui-1.0.4-1.git.3.1768f90.el5


The organization of the at-spi locators are clear and descriptive.   There were two things missed though:

1) The text entry box for the custom server box still has no name
2) The offline radio button has no name

Tossing this back for a fix.
Comment 5 Adrian Likins 2012-06-26 15:40:55 EDT
'offline_radio' had the wrong property set, but so far, I can't
figure out why 'local_entry' isn't found. It seems to be setup
correctly.
Comment 6 Adrian Likins 2012-06-28 14:24:11 EDT
b7bc4c2a80e54072fa0d50cd61ff66b399cba233 should have the 
offline_radio fixed. I didn't change anything for local_entry
(no idea why that wouldn't work at the moment, may need
help to repro that...)
Comment 7 Sharath Dwaral 2012-07-02 11:20:00 EDT
Created attachment 595759 [details]
New subscription manager window

Subscription-manager register window has changed and the above bug does no hold good.
Comment 8 Sharath Dwaral 2012-07-02 11:26:05 EDT
Created attachment 595762 [details]
Verifying tags for new subscription manager window

Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-firstboot-1.0.7-1.git.10.4c364f3.el5
subscription-manager-gui-1.0.7-1.git.10.4c364f3.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.0.583d26c.el5
subscription-manager-migration-1.0.7-1.git.10.4c364f3.el5
subscription-manager-1.0.7-1.git.10.4c364f3.el5


The organization of the at-spi locators are clear and descriptive

Bug Verified
Comment 10 errata-xmlrpc 2013-01-07 22:54:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.