Bug 831006 - QE Feedback - Admin & Config Guide - Formatting
QE Feedback - Admin & Config Guide - Formatting
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 19:35 EDT by Misha H. Ali
Modified: 2012-08-15 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 23:07:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2012-06-11 19:35:26 EDT
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/chap-Cache_Modes.html

2.1.2.3. Configure Local Cache Mode - bad formatting of the configuration snippet

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Asynchronous_Communications.html

-> formatting can be a little better


* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Replication_Queue_Usage.html

-> formatting

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Write_Behind_Caching_Configuration.html

-> I guess the formatting could be a little better

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/WriteThrough_Caching_Configuration.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Unscheduled_WriteBehind_Strategy_Configuration.html

-> formatting (enclosing </infinispan> in a wrong place)

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Remote_Cache_Store_Configuration_Remote_ClientServer_Mode.html

-> formatting

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Remote_Cache_Store_Configuration_Library_Mode.html

-> formatting, the properties could be at the same level

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Define_the_Outbound_Socket_for_the_Remote_Cache_Store.html

-> formatting

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Remote_JdbcBinaryCacheStore_Configuration.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/JdbcBinaryCacheStore_Remote_Configuration_with_Passivation_Disabled.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Remote_JdbcStringBasedCacheStore_Configuration.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/JdbcStringBasedCacheStore_Remote_Configuration_with_Passivation_Enabled.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/JdbcStringBasedCacheStore_Remote_Configuration_with_Passivation_Disabled.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Remote_JdbcMixedCacheStore_Configuration.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/JdbcMixedCacheStore_Remote_Configuration_with_Passivation_Disabled.html

-> formatting, those lines would not have to overflow in this ugly way

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Custom_Cache_Store_Configuration_Library_Mode.html

-> formatting

* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Adding_Custom_Interceptors_Programatically.html
* http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Use_the_Transaction_Manager.html

-> formatting
Comment 1 Misha H. Ali 2012-06-11 22:24:25 EDT
(In reply to comment #0)
> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/chap-Cache_Modes.html
> 
> 2.1.2.3. Configure Local Cache Mode - bad formatting of the configuration
> snippet

Fixed.

> 
> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/Asynchronous_Communications.html
> 
> -> formatting can be a little better
> 
Fixed. 
> 
> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/Replication_Queue_Usage.html
> 
> -> formatting
> 

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/Write_Behind_Caching_Configuration.
> html
> 
> -> I guess the formatting could be a little better
> 

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/WriteThrough_Caching_Configuration.
> html

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Unscheduled_WriteBehind_Strategy_Configuration.html
> 
> -> formatting (enclosing </infinispan> in a wrong place)
> 

Fixed and removed comments saying that the one line is the specific config for unscheduled write behind strategy and added a separate line to indicate this at the end of the topic instead.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Remote_Cache_Store_Configuration_Remote_ClientServer_Mode.html
> 
> -> formatting
> 

Fixed. Should this have a </remote-store> at the end? 

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Remote_Cache_Store_Configuration_Library_Mode.html
> 
> -> formatting, the properties could be at the same level
> 

Fixed.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Define_the_Outbound_Socket_for_the_Remote_Cache_Store.html
> 
> -> formatting
> 

Fixed.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/sect-
> Remote_JdbcBinaryCacheStore_Configuration.html

Fixed.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> JdbcBinaryCacheStore_Remote_Configuration_with_Passivation_Disabled.html

Fixed.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/sect-
> Remote_JdbcStringBasedCacheStore_Configuration.html

Fixed. One line may be out of alignment, cannot fix.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> JdbcStringBasedCacheStore_Remote_Configuration_with_Passivation_Enabled.html

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> JdbcStringBasedCacheStore_Remote_Configuration_with_Passivation_Disabled.html

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/sect-
> Remote_JdbcMixedCacheStore_Configuration.html

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> JdbcMixedCacheStore_Remote_Configuration_with_Passivation_Disabled.html
> 
> -> formatting, those lines would not have to overflow in this ugly way
>

Fixed.

> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Custom_Cache_Store_Configuration_Library_Mode.html
> 
> -> formatting
> 

Fixed

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/
> Adding_Custom_Interceptors_Programatically.html

Fixed.

> *
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/sect-Use_the_Transaction_Manager.html
> 
> -> formatting

Fixed.
Comment 2 Misha H. Ali 2012-06-11 23:13:37 EDT
All fixes are now available on stage. Apologies for broken links in c#1, I assumed reply would retain the links. 

Please use the links in the original comment to verify. 

The only exception is the following where despite best efforts one line remains inexplicably out of alignment so I cannot fix this. Will file a bug against it.


> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/sect-Remote_JdbcStringBasedCacheStore_Configuration.html
Comment 3 Martin Gencur 2012-06-12 06:12:50 EDT
I can't open many of the links above, it redirects me to the main doc page. E.g. this one: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Remote_Cache_Store_Configuration_Library_Mode.html
Are those links supposed to work later or is it a problem?
Comment 4 Misha H. Ali 2012-06-12 10:55:26 EDT
Sorry, martin, that link changed due to moving Cache Loaders into the Cache Store Chapter (and thus Cache Stores chapter itself because one section of the larger chapter). This one should work:

http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/chap-Cache_Stores_and_Cache_Loaders.html#Remote_Cache_Store_Configuration_Library_Mode

Please let me know if there are any others which do not work.
Comment 5 Martin Gencur 2012-06-12 11:16:49 EDT
I have only one comment, related to 8.1.5.2. Remote Cache Store Configuration (Remote Client-Server Mode) at http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/chap-Cache_Stores_and_Cache_Loaders.html#Remote_Cache_Store_Configuration_Library_Mode

...really, the </remote-store> tag should be there IMO.

And maybe one more: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/Administration_and_Configuration_Guide/Asynchronous_Communications.html

...formatting of the code snippet looks odd, better start with the attributes right on the first line or move the whole group of attributes to the left.

Otherwise all issues were fixed.
Comment 6 Misha H. Ali 2012-06-12 12:44:30 EDT
(In reply to comment #5)
> I have only one comment, related to 8.1.5.2. Remote Cache Store
> Configuration (Remote Client-Server Mode) at
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/chap-Cache_Stores_and_Cache_Loaders.
> html#Remote_Cache_Store_Configuration_Library_Mode
> 
> ...really, the </remote-store> tag should be there IMO.

Should be available here: http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html-single/Administration_and_Configuration_Guide/index.html#Remote_Cache_Store_Configuration_Remote_ClientServer_Mode

(I assumed you meant the remote config, not the library ones linked in the quoted text, please correct if wrong).

> 
> And maybe one more:
> http://documentation-stage.bne.redhat.com/docs/en-US/JBoss_Data_Grid/6/html/
> Administration_and_Configuration_Guide/Asynchronous_Communications.html
> 
> ...formatting of the code snippet looks odd, better start with the
> attributes right on the first line or move the whole group of attributes to
> the left.
> 

Fixed.

> Otherwise all issues were fixed.
Comment 8 Martin Gencur 2012-06-12 12:49:22 EDT
I meant remote config, indeed. All issues are now fixed.

Note You need to log in before you can comment on or make changes to this bug.