Bug 831039 - [rhevm-log-collector] - Installer - LC is still using /etc/rhevm as the config folder
[rhevm-log-collector] - Installer - LC is still using /etc/rhevm as the confi...
Status: CLOSED DUPLICATE of bug 788079
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kiril Nesenko
yeylon@redhat.com
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 00:54 EDT by David Botzer
Modified: 2016-04-18 02:44 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-16 08:51:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Botzer 2012-06-12 00:54:06 EDT
Description of problem:
LC in rhevm 3.1 should use /etc/ovirt-engine/

Version-Release number of selected component (if applicable):
rhevm 3.1, si4

How reproducible:
always

Steps to Reproduce:
1.install rhevm 3.1
  
Actual results:
LC uses /etc/rhevm

Expected results:
should use /etc/ovirt-engine/ and not /etc/rhevm

Additional info:
Comment 1 Andrew Cathrow 2012-06-13 08:23:24 EDT
Since we symlink is this really an issue?
Comment 2 David Botzer 2012-06-13 08:26:02 EDT
The answer I got from Kroberts:
problem is that in the installer, it doesn't seem to be appending the user and password to that conf file. You can see that the LC RPM contains the conf file...
Comment 3 Itamar Heim 2012-06-17 03:04:12 EDT
keith - can you please elaborate?
if changing this, need to require rhev > 3.1 since 3.0 doesn't have this folder, or have backward compatible protective code.
as long as we symlink, i'd just close this for now.
Comment 4 Keith Robertson 2012-06-18 10:18:27 EDT
Symlink isn't really even necessary for any of the 3 tools I maintain.  They've all been updated to use /etc/ovirt-engine/.

This BZ came out of a debug session with David.  I looked in /etc/ and didn't see a /etc/ovirt-engine/.  The fact that this directory didn't exist and didn't contain the .conf files for the LC, ISO uploader, and image uploader, caused him to get prompted for user IDs.

I'm not sure what happened but I see the directories now on his system and they do contain the requisite conf files.

David, the only thing that you might want to check is if the installer correctly appends the following 2 lines to each config file.  In particular, you need to check that...
/etc/ovirt-engine/<logcollector.conf | isouploader.conf | imageuploader.conf> 
all get updated.  If they are not updated, the tools will prompt you in certain scenarios.

[root@dbotzer-installation ~]# tail -3 /etc/ovirt-engine/logcollector.conf 
#pg-ssh-user=root
rhevm=<hostname given to installer during install>:<port given to installer>
user=admin@internal <-- User ID given to installer.
Comment 5 Itamar Heim 2012-06-18 10:21:17 EDT
keith - do the new tools require rhevm > 3.1?
else they won't find any /etc/ovirt-engine, etc.
Comment 6 David Botzer 2012-06-18 10:25:45 EDT
Hi Keith,
I tested it now on 3.1/si6
the three files are logcollector/imageuploader/isouploader
Please advise,

[Correct]
tail -3 logcollector.conf 
#pg-ssh-user=root
rhevm=xxxx-vm-jrs7.qa.lab.tlv.redhat.com:443
user=admin@internal
----------------------------------------
[ERROR]
[root@xxxx-JRS7 ovirt-engine]# tail -3 imageuploader.conf 
## supply this option if you want to rename the template name (i.e. Name) of the image
#template-name=TEMPLATE_NAME
----------------------------------------
[Correct]
tail -3 isouploader.conf 

rhevm=xxxx-jrs7.qa.lab.tlv.redhat.com:443
user=admin@internal
Comment 7 Keith Robertson 2012-06-18 10:31:41 EDT
(In reply to comment #6)
> Hi Keith,
<snip>
> ----------------------------------------
> [ERROR]
> [root@xxxx-JRS7 ovirt-engine]# tail -3 imageuploader.conf 
> ## supply this option if you want to rename the template name (i.e. Name) of
> the image
> #template-name=TEMPLATE_NAME
> ----------------------------------------
So this is a bug.  Installer needs to append this information to the end of the .conf file.  

In reponse to comment 5, I didn't pin the new tools to '> 3.1' but it is a logical safety check.  Also, this only needs to be corrected downstream.  Upstream tools have always looked in /etc/ovirt-engine; hence, no need to change spec file there.
Comment 8 Keith Robertson 2012-06-26 18:06:02 EDT
There really isn't a LC, ISO uploader or Image Uploader bug here.  The only bug that I see is the fact that the installer isn't appending the hostname, port, and user information to the end of imageuploader.conf during install.  

I'm going to move this to the installer component as this issue needs to be fixed there.
Comment 9 Kiril Nesenko 2012-08-16 08:51:22 EDT
This issue was solved in bz788079.

*** This bug has been marked as a duplicate of bug 788079 ***

Note You need to log in before you can comment on or make changes to this bug.