Bug 831060 - Can't connect to wireless-n 5GHz (Intel iwlwifi 6200)
Can't connect to wireless-n 5GHz (Intel iwlwifi 6200)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 02:19 EDT by Gerard Fernandes
Modified: 2012-06-14 16:53 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 09:14:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2012-06-12 02:19:25 EDT
Description of problem: Can't connect to Wireless-N on 5GHz


Version-Release number of selected component (if applicable): (output from dmesg)
[    6.735324] iwlwifi 0000:08:00.0: Detected Intel(R) Centrino(R) Advanced-N 6200 AGN, REV=0x74
[    6.735468] iwlwifi 0000:08:00.0: L1 Enabled; Disabling L0S
[    6.753049] iwlwifi 0000:08:00.0: device EEPROM VER=0x436, CALIB=0x6
[    6.753054] iwlwifi 0000:08:00.0: Device SKU: 0x1F0
[    6.753056] iwlwifi 0000:08:00.0: Valid Tx ant: 0x6, Valid Rx ant: 0x6
[    6.753078] iwlwifi 0000:08:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels



How reproducible: Always


Steps to Reproduce:
1. Attempt to connect to Wireless-N 5GHz network

  
Actual results: Fails - comes back to password dialogue.


Expected results: Should connect - used to work in F-16.


Additional info:
Comment 1 Gerard Fernandes 2012-06-12 05:11:35 EDT
Router is a Netgear WNDR3500 dual radio (2.4GHz G, 5GHz N). I can connect to 2.4GHz G, but connection _always_ fails to 5GHz N.
Comment 2 Gerard Fernandes 2012-06-12 05:12:47 EDT
WNDR-3700 I mean.
Comment 3 John W. Linville 2012-06-12 10:44:11 EDT
What kernel version are you using?

What sort of encryption are you using on your network?
Comment 4 Gerard Fernandes 2012-06-12 15:01:55 EDT
Kernel version: kernel-3.4.0-1.fc17.x86_64
Network is setup to use WPA-2 (AES) encryption.
Comment 5 John W. Linville 2012-06-13 07:42:02 EDT
Please attach the contents of /var/log/wpa_supplicant.log and /var/log/messages from immediately after an unsuccessful connection attempt.
Comment 6 Gerard Fernandes 2012-06-13 15:36:50 EDT
Thanks for pointing me at the logs. I've found the problem.

My WPA-2 password is a 64-char long auto-generated random string. The last character was a "\".

This was being saved incorrectly in the key-ring as a "'" character. This caused password authentication to fail.

I tried manually editing it a few times in NetworkManager without success.

I swapped the last 2 chars around and now I can connect.

This is quite strange - I've never experienced this problem in the past (had the exact same password on Fedora-16 and it was saved correctly in the key-ring).

Don't know exactly what the cause of this problem is. But as the connection works now, this issue can be closed.
Comment 7 Gerard Fernandes 2012-06-14 05:24:47 EDT
>>I swapped the last 2 chars around and now I can connect.

(This also meant making the exact same change to the password on the router of course...)
Comment 8 John W. Linville 2012-06-14 09:14:57 EDT
Closing as NOTABUG, based on documented info in comment 6 and comment 7.

FWIW, I would guess that some other form of quoting/escaping would allow for the last character to be '\', but I think you current solution is as good as any. :-)
Comment 9 Gerard Fernandes 2012-06-14 16:53:00 EDT
:)
Thankyou for your help.

Note You need to log in before you can comment on or make changes to this bug.