Bug 831097 - The status of DIY application when using CLI is not correct and does not match the status on website.
The status of DIY application when using CLI is not correct and does not matc...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Master (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 03:49 EDT by Yujie Zhang
Modified: 2015-05-14 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2012-06-12 03:49:06 EDT
Description of problem:

I created a DIY application and check the status of this application using "rhc-ctl-app -c status -a $appname", the status is always "Application 'diy2' is either stopped or inaccessible", even when I change the status. However, the status of DIY application can be displayed correctly on website on application details page.

Version-Release number of selected component (if applicable):

int.openshift.redhat.com

How reproducible:always


Steps to Reproduce:
1.Create a DIY application and change the status of the application 
2.Check the status of the DIY application using "rhc-ctl-app -c status -a $appname"
3.Check the status of the DIY application on website
  
Actual results:

The status of DIY application when using CLI is not correct and does not match the status on website.

Expected results:

The status of DIY application should be correct and consistent with the status on website.

Additional info:
Comment 1 Clayton Coleman 2012-06-15 14:50:10 EDT
Not sure but this looks like a mismatch between old broker API call and new broker api call to gear status.
Comment 2 Lili Nader 2012-06-18 21:09:57 EDT
These are 2 very different calls....

The website uses the call /broker/rest/domains/<domain-name>/applications/<app-name>/gear_groups.json to get the state of each gear.

The CLI on the otherhand uses the old API which calls "app_ctl.sh status" on the gear itself.  For DIY apps it gives the following error:

usr/libexec/stickshift/cartridges/diy-0.1/info/bin/app_ctl.sh: line 46: print_running_processes: command not found

I did a grep and could not find anywhere the command print_running_processes was defined.
Comment 3 John Poelstra 2012-06-19 13:25:43 EDT
Expect fix today
Comment 4 Yujie Zhang 2012-06-20 03:13:23 EDT
(In reply to comment #3)
Tested this issue on int.openshift.redhat.com , the status of diy application is correct both on CLI and website, thanks.

Note You need to log in before you can comment on or make changes to this bug.