Bug 831101 - [RHEVH] upgade from 6.2 to 6.3 cannot migrate VLAN network configuration on dell server due to bios devname changes
[RHEVH] upgade from 6.2 to 6.3 cannot migrate VLAN network configuration on d...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
x86_64 Linux
urgent Severity urgent
: rc
: 6.3
Assigned To: Joey Boggs
Virtualization Bugs
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 03:57 EDT by Martin Pavlik
Modified: 2016-04-26 12:45 EDT (History)
25 users (show)

See Also:
Fixed In Version: ovirt-node-2.3.0-12.el6
Doc Type: Bug Fix
Doc Text:
Previously when upgrading, biosdevname assigned new device names on some machines, breaking the Hypervisor installation. To prevent this from occurring biosdevname is now only enabled on new Hypervisor installations, not upgrades.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 10:13:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and ifcfg files (1.24 MB, application/x-gzip)
2012-06-12 03:57 EDT, Martin Pavlik
no flags Details
screenshot 1 (207.16 KB, image/png)
2012-06-12 03:58 EDT, Martin Pavlik
no flags Details
screenshot 2 (207.47 KB, image/png)
2012-06-12 03:58 EDT, Martin Pavlik
no flags Details
ifcfg-* (163.71 KB, image/png)
2012-06-14 06:21 EDT, Guohua Ouyang
no flags Details
sys_class_net (105.48 KB, image/png)
2012-06-14 22:08 EDT, Guohua Ouyang
no flags Details
/proc/cmdline (213.23 KB, image/png)
2012-06-14 22:12 EDT, Guohua Ouyang
no flags Details

  None (edit)
Description Martin Pavlik 2012-06-12 03:57:32 EDT
Created attachment 591122 [details]
logs and ifcfg files

Description of problem:
When upgrading RHEVH host from 6.2 (20120605.0) to 6.3 (20120606.3) VLAN configuration file/files is not migrated properly as NIC names change from ethX (see screenshot 1) to emX and p1pX (see screenshot 2). 

In RHEVH 6.2 VLAN 173 attached NIC eth3 has following 3 config files: ifcfg-eth3, ifcfg-eth3.173 and ifcfg-VLAN_173

during upgrade to RHEVH 6.3 following changes take place:

new ifcfg-em2 file is created
   
   DEVICE=em2
   ONBOOT=yes
   BOOTPROTO=none
   HWADDR=D0:67:E5:F0:7F:30

file ifcfg-em2.173 is not created

DEVICE is rewritten in ifcfg-eth3 (from eth3 to em2)

   ifcfg-eth3 before migration:

   DEVICE=eth3
   ONBOOT=yes
   BOOTPROTO=none
   HWADDR=D0:67:E5:F0:7F:30

   ifcg-eth3 after migration:
   DEVICE=em2
   ONBOOT=yes
   BOOTPROTO=none
   HWADDR=D0:67:E5:F0:7F:30




Version-Release number of selected component (if applicable):
RHEVH host from 6.2 (20120605.0) to 6.3 (20120606.3)

How reproducible:
100%

Steps to Reproduce:
1. Attach VLAN network to RHEVH 6.2 host NIC
2. WPF -> hosts -> your host (mainanace) -> Upgrade RHEVH host to 6.3 -> General -> click on action item for upgrade
3. perform upgrade to RHEVH 6.3
  
Actual results:
VLAN configuration file/s is NOT migrated, old configuration files remain in system

Expected results:
VLAN configuration file/s is migrated, old configuration is removed from system


Additional info:
used server is dell-r210II (dmidecode attached)
rpm -qa for rhel 6.3 attached
vdsm.log+rhevm.log attached
ifcfg files befor and after upgrade attached
and some more logs
Comment 1 Martin Pavlik 2012-06-12 03:58:04 EDT
Created attachment 591123 [details]
screenshot 1
Comment 2 Martin Pavlik 2012-06-12 03:58:26 EDT
Created attachment 591124 [details]
screenshot 2
Comment 3 Mike Burns 2012-06-12 05:58:31 EDT
this is an issue in rhev-h.  when upgrading, we don't handle vlans correctly
Comment 4 Mike Burns 2012-06-12 06:02:09 EDT
Additional comments:

This affects only systems that meet the following criteria:
dmidecode Vendor entry reports "*dell*" (case insensitive check)
smbios version is >= 2.6
vlans are being used


Even given the above limitations, this still needs to be fixed ASAP.
Comment 7 Guohua Ouyang 2012-06-13 06:57:11 EDT
QE can reproduce this bug on Dell machine + SMBIOS = 2.6. when upgrade from 6.2-20111117.0 to 6.3-20120606.3.
Comment 10 Mike Burns 2012-06-13 12:55:44 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, in some upgrade cases, the network would become unreachable due to a migration to using biosdevname.  Now, biosdevname will only be active when doing a fresh install.
Comment 12 Stephen Gordon 2012-06-13 15:32:37 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Previously, in some upgrade cases, the network would become unreachable due to a migration to using biosdevname.  Now, biosdevname will only be active when doing a fresh install.+Previously when upgrading, biosdevname assigned new device names on some machines, breaking the Hypervisor installation. To prevent this from occurring biosdevname is now only enabled on new Hypervisor installations, not upgrades.
Comment 13 Guohua Ouyang 2012-06-14 06:21:52 EDT
Created attachment 591801 [details]
ifcfg-*

tested on rhevh-6.3-20120613.2 today, upgrade from 6.2-20111117.0 to this build, network still failed to up. 

same as upgrade from 6.2-20111117.0 to 6.3-20120606.3.
Comment 16 Guohua Ouyang 2012-06-14 22:08:51 EDT
Created attachment 591960 [details]
sys_class_net

test the jenkis build,
http://jenkins.virt.bos.redhat.com/jenkins/job/rhev-hypervisor-6/

upgrade would not create ifcfg-* for emX/pXpX now, but the network is still failed to up, this is because ethx isn't existing,  
#ls /sys/class/net/   only see em1, p3p1, rhevm,  not ethx, but rhevm is bridged over ethX.
Comment 17 Guohua Ouyang 2012-06-14 22:12:00 EDT
Created attachment 591962 [details]
/proc/cmdline

checked the grub during boot grub menu or in /proc/cmdline,
no biosdevname=0
Comment 18 Guohua Ouyang 2012-06-14 22:39:26 EDT
manually add biosdevname=0 in grub boot entry, the network can up.
Comment 21 Guohua Ouyang 2012-06-18 06:20:03 EDT
verified on 6.3-20120615.1 build, upgrade from 6.2-2011117.1 to 6.3-20120615.1, the network is up via rhevm.
Comment 23 errata-xmlrpc 2012-07-19 10:13:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0741.html

Note You need to log in before you can comment on or make changes to this bug.