Bug 831109 - [abrt] evolution-3.4.2-1.fc17: gtk_tree_model_get_valist: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.4.2-1.fc17: gtk_tree_model_get_valist: Process /usr/bin/ev...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:f99aff1ff0aa5f60393f268882d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 04:20 EDT by Douglas Furlong
Modified: 2012-06-13 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 05:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.03 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details
File: smolt_data (9.19 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details
File: xsession_errors (43.22 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details
File: maps (136.80 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details
File: dso_list (22.71 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details
File: build_ids (10.89 KB, text/plain)
2012-06-12 04:21 EDT, Douglas Furlong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 677597 None None None 2012-06-13 05:09:43 EDT

  None (edit)
Description Douglas Furlong 2012-06-12 04:20:57 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        evolution
crash_function: gtk_tree_model_get_valist
executable:     /usr/bin/evolution
kernel:         3.4.0-1.fc17.x86_64
pid:            10858
pwd:            /home/douglas.furlong
time:           Tue 12 Jun 2012 09:12:51 BST
uid:            1000
username:       douglas.furlong

backtrace:      Text file, 64539 bytes
build_ids:      Text file, 11152 bytes
dso_list:       Text file, 23250 bytes
maps:           Text file, 140087 bytes
smolt_data:     Text file, 9415 bytes
xsession_errors: Text file, 44253 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/douglas.furlong/2

comment:
:I was deleting a "Specific Folder" for a search folder, this was the only one present in the list.
:
:On hitting "remove" evolution would crash.

core_backtrace:
:710b0d8cc36603d66327090defd37c99daa38f28 0x266348 gtk_tree_model_get_valist libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x26665c gtk_tree_model_get libgtk-3.so.0 -
:7995d18ec075cabcac825d875163d3d83d5dcdc8 0x88e41 - libevolution-mail.so -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x206d8 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x287143 - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x28a138 - libgtk-3.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x206d8 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x176acd gtk_list_store_remove libgtk-3.so.0 -
:7995d18ec075cabcac825d875163d3d83d5dcdc8 0x88be2 - libevolution-mail.so -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf943 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x27d88 g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0xbba38 - libgtk-3.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf664 g_closure_invoke libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x20003 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x2866d g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0xb9d53 - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x17adcf - libgtk-3.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0xf943 - libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x27d88 g_signal_emit_valist libgobject-2.0.so.0 -
:31243d0d107bba586a96433c76c87a26db1e826c 0x287c2 g_signal_emit libgobject-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x2a2d0e - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x178d96 - libgtk-3.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x17a9a3 gtk_main_do_event libgtk-3.so.0 -
:8b33feb27b2125997520fdd21c90c42a65e438f1 0x48e62 - libgdk-3.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47e12 g_main_loop_run libglib-2.0.so.0 -
:710b0d8cc36603d66327090defd37c99daa38f28 0x179d65 gtk_main libgtk-3.so.0 -
:17f014bbe23d507f5dea851f72da7ea83d0fe000 0x22da main [exe] -

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=1766
:XDG_SESSION_ID=2
:HOSTNAME=z600.lme.co.uk
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=d270dfbb9c2432017d794b9a00000009-1339401820.964523-1642505994
:GNOME_KEYRING_CONTROL=/run/user/douglas.furlong/keyring-sLO1Um
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=douglas.furlong
:SSH_AUTH_SOCK=/run/user/douglas.furlong/keyring-sLO1Um/ssh
:USERNAME=xxxxxxxxx
:MAIL=/var/spool/mail/douglas.furlong
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/douglas.furlong/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/douglas.furlong
:XMODIFIERS=@im=none
:EDITOR=vim
:GNOME_KEYRING_PID=1599
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:GDMSESSION=gnome
:SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/douglas.furlong
:SHLVL=1
:LOGNAME=douglas.furlong
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-UxDKESunNr,guid=a9dbec68999ce242325279a900000022
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/douglas.furlong
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-douglas.furlong-le8OMc/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1603,unix/unix:/tmp/.ICE-unix/1603
:GPG_AGENT_INFO=/run/user/douglas.furlong/keyring-sLO1Um/gpg:0:1
:LC_TIME=en_GB.utf8
:LC_NUMERIC=en_GB.utf8
:LC_MONETARY=en_GB.utf8
:LC_MEASUREMENT=en_GB.utf8
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/evolution.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=10858
:DESKTOP_STARTUP_ID=gnome-panel-1844-z600.lme.co.uk-evolution-1_TIME4257818

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63566                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63566                63566                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/douglas.furlong/.xsession-errors
:2:/home/douglas.furlong/.xsession-errors
:3:socket:[2766679]
:4:anon_inode:[eventfd]
:5:socket:[2772137]
:6:anon_inode:[eventfd]
:7:socket:[2769305]
:8:anon_inode:[eventfd]
:9:socket:[2771156]
:10:anon_inode:[eventfd]
:11:socket:[2769306]
:12:/home/douglas.furlong/.pki/nssdb/cert9.db
:13:/var/tmp/etilqs_RP86wKZAe8W0zSL (deleted)
:14:socket:[2765380]
:15:/var/tmp/etilqs_O36MdsyKz7jYjwZ (deleted)
:16:/var/tmp/etilqs_f0LHy576ka5zpAH (deleted)
:17:/home/douglas.furlong/.pki/nssdb/key4.db
:18:/var/tmp/etilqs_WsHlffbqn8bRE3S (deleted)
:19:/var/tmp/etilqs_XW82Ky2m5n1YUpD (deleted)
:20:/var/tmp/etilqs_T70OtFx7cGehzyI (deleted)
:21:/etc/pki/nssdb/cert9.db
:22:/var/tmp/etilqs_nDJVfTyHPXc0nEs (deleted)
:23:/var/tmp/etilqs_H3dYGXqCsH6jnnr (deleted)
:24:/etc/pki/nssdb/key4.db
:25:/var/tmp/etilqs_PLxK6zc8eUy9Usl (deleted)
:26:/var/tmp/etilqs_BFrUADEDHhggffg (deleted)
:27:/home/douglas.furlong/.local/share/evolution/mail/local/folders.db
:28:/home/douglas.furlong/.local/share/evolution/mail/vfolder/folders.db
:29:anon_inode:[eventfd]
:30:anon_inode:[eventfd]
:31:/home/douglas.furlong/.cache/evolution/mail/1317716879.3989.7@z600.local/folders.db
:32:/home/douglas.furlong/.local/share/evolution/mail/local_mbox/folders.db
:33:/home/douglas.furlong/.cache/evolution/mail/1338391531.3643.4@z600.lme.co.uk/folders.db
:34:anon_inode:inotify
:35:anon_inode:[eventfd]
:36:/dev/urandom
:37:/home/douglas.furlong/.local/share/gvfs-metadata/home (deleted)
:38:/home/douglas.furlong/.local/share/gvfs-metadata/home-c22406f8.log (deleted)
:39:socket:[2767656]
:40:socket:[2772448]
:41:/var/tmp/etilqs_8ik3p3986fiPf2i (deleted)
:42:socket:[9425401]
:43:/var/tmp/etilqs_tpZMbu6P93SgCtg (deleted)
:44:/var/tmp/etilqs_yjah05Mp44Rh9gT (deleted)
:45:socket:[6862700]

var_log_messages:
:Jun 11 08:48:46 z600 yum[20903]: Updated: evolution-data-server-3.4.2-1.fc17.x86_64
:Jun 11 08:52:16 z600 yum[20903]: Updated: evolution-3.4.2-1.fc17.x86_64
:Jun 11 08:53:31 z600 yum[20903]: Updated: evolution-mapi-3.4.2-1.fc17.x86_64
:Jun 11 08:53:32 z600 yum[20903]: Updated: evolution-ews-3.4.2-2.fc17.x86_64
:Jun 11 08:53:33 z600 yum[20903]: Updated: evolution-NetworkManager-3.4.2-1.fc17.x86_64
:Jun 11 08:53:40 z600 yum[20903]: Updated: evolution-help-3.4.2-1.fc17.noarch
:Jun 11 09:05:43 z600 abrt[3058]: Saved core dump of pid 2006 (/usr/libexec/evolution-calendar-factory) to /var/spool/abrt/ccpp-2012-06-11-09:05:43-2006 (63700992 bytes)
:Jun 12 09:12:51 z600 kernel: [86805.639013] evolution[10858]: segfault at 30 ip 0000003363666348 sp 00007fff7cbe2490 error 4 in libgtk-3.so.0.400.3.#prelink#.UXexAl (deleted)[3363400000+472000]
:Jun 12 09:12:51 z600 abrt[19155]: File '/usr/bin/evolution' seems to be deleted
:Jun 12 09:12:54 z600 abrt[19155]: Saved core dump of pid 10858 (/usr/bin/evolution) to /var/spool/abrt/ccpp-2012-06-12-09:12:51-10858 (343011328 bytes)
Comment 1 Douglas Furlong 2012-06-12 04:21:01 EDT
Created attachment 591132 [details]
File: backtrace
Comment 2 Douglas Furlong 2012-06-12 04:21:03 EDT
Created attachment 591133 [details]
File: smolt_data
Comment 3 Douglas Furlong 2012-06-12 04:21:06 EDT
Created attachment 591134 [details]
File: xsession_errors
Comment 4 Douglas Furlong 2012-06-12 04:21:10 EDT
Created attachment 591135 [details]
File: maps
Comment 5 Douglas Furlong 2012-06-12 04:21:12 EDT
Created attachment 591136 [details]
File: dso_list
Comment 6 Douglas Furlong 2012-06-12 04:21:18 EDT
Created attachment 591137 [details]
File: build_ids
Comment 7 Milan Crha 2012-06-13 05:09:43 EDT
Thanks for a bug report. There is filled a similar upstream bug [1], thus I'm moving this there. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

By the way, I see from the xsession_errors that there are issues with your local folders (like On This Computer/Templates,Inbox,Sent,Drafts,Outbox), did you update from older Fedora or anything like that? Does these folders work at all? If not, I suggest to open a new bug report and take care of it, because there should not be any issue with these folders.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=677597

Note You need to log in before you can comment on or make changes to this bug.