Bug 831142 - incomplete documentation of retransmits
incomplete documentation of retransmits
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.3
All Linux
medium Severity low
: rc
: ---
Assigned To: Josef Ridky
Rachel Sibley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 05:51 EDT by Karel Volný
Modified: 2017-09-25 04:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-25 04:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-06-12 05:51:50 EDT
Description of problem:
There are two new options in ipmitool: -R and -N.
The manpage does not describe the behaviour sufficiently.

Version-Release number of selected component (if applicable):
ipmitool-1.8.11-13.el6.1.x86_64

1. There is a typo in "-N" description - the default delay for lanplus is 1 second, not "4 seconds" (note that the commandline help lists correct value).

2. For lanplus interface, the delay is increased between tries. I'd suggest to add a sentence like:

"For the lanplus interface, the delay grows by 1 second after each retransmission in a series."

- also, it may be noted explicitly that the delay is constant for lan interface.

3. The number of retransmissions is a bit more difficult, see bug 828678#c9
I wouldn't go into such detail, however, it may be noted that on lanplus, IPMI 2.0 is tried at first, then it is retried with 1.5

As for sending the initial request twice, I'd rather see this as a bug/something to be documented within release notes.
Comment 1 RHEL Product and Program Management 2012-09-07 01:19:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2013-10-13 20:36:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Josef Ridky 2017-09-25 04:29:50 EDT
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the
Production 3 Phase, Critical impact Security Advisories (RHSAs) and
selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as
they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase
and will be marked as CLOSED/WONTFIX. If this remains a critical
requirement, please contact Red Hat Customer Support to request
a re-evaluation of the issue, citing a clear business justification. Note
that a strong business justification will be required for re-evaluation.
Red Hat Customer Support can be contacted via the Red Hat Customer Portal
at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.