Bug 831170 - Seam-gen configuration misses knowledge-api.jar for packaging of jars in WAR application
Seam-gen configuration misses knowledge-api.jar for packaging of jars in WAR ...
Status: CLOSED DEFERRED
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.ER8
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Marek Novotny
Marek Schmidt
Seam2.3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 07:55 EDT by Marek Novotny
Modified: 2012-06-19 04:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 04:18:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Novotny 2012-06-12 07:55:50 EDT
Description of problem:
There is a warning in EAP 6 server log while deploying seam-gen generated WAR application: 

10:56:26,539 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.drools.WorkingMemoryEntryPoint in Module "deployment.seamproj.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/drools/WorkingMemoryEntryPoint (Module "deployment.seamproj.war:main" from Service Module Loader)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:396)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.seam.init.DependencyManager.checkClassDependencies(DependencyManager.java:138) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.checkAllDependencies(DependencyManager.java:98) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:93) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:69) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.computeInstallSet(DependencyManager.java:49) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.installedSet(DependencyManager.java:30) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.installComponents(Initialization.java:1111) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.init(Initialization.java:737) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:36) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_31]
Caused by: java.lang.NoClassDefFoundError: org/drools/runtime/rule/WorkingMemoryEntryPoint
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	... 41 more
Caused by: java.lang.ClassNotFoundException: org.drools.runtime.rule.WorkingMemoryEntryPoint from [Module "deployment.seamproj.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	... 47 more

10:56:26,543 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.drools.WorkingMemory in Module "deployment.seamproj.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/drools/WorkingMemory (Module "deployment.seamproj.war:main" from Service Module Loader)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:396)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.seam.init.DependencyManager.checkClassDependencies(DependencyManager.java:138) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.checkAllDependencies(DependencyManager.java:98) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:93) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:69) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.computeInstallSet(DependencyManager.java:49) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.installedSet(DependencyManager.java:30) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.installComponents(Initialization.java:1111) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.init(Initialization.java:737) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:36) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_31]
Caused by: java.lang.NoClassDefFoundError: org/drools/WorkingMemoryEntryPoint
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	... 25 more
Caused by: java.lang.ClassNotFoundException: org.drools.WorkingMemoryEntryPoint from [Module "deployment.seamproj.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	... 31 more



Additional info:

http://anonsvn.jboss.org/repos/seam/branches/enterprise/WFK-2_0/jboss-seam-gen/dist/build-scripts/deployed-jars-war.list misses knowledge-api.jar in the list and therefore it is not packaged into war application.
Comment 1 Marek Novotny 2012-06-12 07:57:35 EDT
knowledge-api.jar is correct name ;-)
Comment 2 Martin Malina 2012-06-12 08:07:57 EDT
I can confirm that this doesn't happen with EAP project.
Comment 3 Marek Novotny 2012-06-12 08:39:59 EDT
Martin,
 you wanted to say EAR not EAP project, right?
Comment 4 Martin Malina 2012-06-12 09:06:51 EDT
Correct, I mean EAR. I type eap too often nowadays :)

Note You need to log in before you can comment on or make changes to this bug.