Bug 831177 - rhev-h: the first parameter of storage_vol don't be effective any more
rhev-h: the first parameter of storage_vol don't be effective any more
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 08:08 EDT by yuanquan chen
Modified: 2016-04-26 11:46 EDT (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Virtualization Hypervisor 6.3 no longer uses a separate boot partition. This deprecates the boot partition setting in the storage_vol parameters for the Red Hat Enterprise Virtualization Hypervisor during automated installs. To maintain backwards compatibility, the format for the storage_vol command has remained the same, but the options provided for the BOOT partition will be silently ignored.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:36:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0556 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2013-02-28 16:29:06 EST

  None (edit)
Description yuanquan chen 2012-06-12 08:08:50 EDT
Description of problem:
There original parameter storage_vol consists of six parts, "storage_init=boot:swap:root:config:logging:data", replacing each partition with size value in MB to specify each partition size.

Since boot partition of rhev-h doesn't exist in rhev-h 6.3, the first part of the storage_init doesn't take effect with root partition any more. Though there's a EFI partition, it also can't take effect with the EFI partition size.


Version-Release number of selected component (if applicable):
rhevh-6.3-20120606.3.el6


How reproducible:
100%

Steps to Reproduce:
1. try auto install the rhev-h with storage_vol parameter as "storage_init=600:2000:700:30:4000:5000" 
2. boot the installed rhev-h, and check each partition

  
Actual results:
Other than the first parameter of storage_init, the other five parameter are effective to specify the partition size.


Expected results:
Since the first parameter doesn't work, it should be removed, the storage_init parameter should change to five parts


Additional info:
Comment 2 RHEL Product and Program Management 2012-07-10 03:18:55 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:08 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Mike Burns 2012-07-11 09:37:40 EDT
I'm assuming that you're referring to storage_vol and not storage_init.
Comment 5 Mike Burns 2012-08-21 16:24:45 EDT
just as a note, we won't be changing storage_vol to use just 5 parameters.  We may make the initial parameter something that is used for the EFI/grub_bios partition or just make it completely unused and document it.  

Changing it to be 5 parameters would cause issues with people that have pre-existing PXE setups with this defined.
Comment 8 cshao 2012-08-26 20:52:27 EDT
(In reply to comment #4)
> I'm assuming that you're referring to storage_vol and not storage_init.

yuanquan chen said that is storage_vol not storage_init. 
Clear needinfo flag. Thanks!
Comment 13 errata-xmlrpc 2013-02-28 11:36:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.