Bug 831188 - Add path to server SSL certificate to rhui-tools.conf so that we don't have to prompt for it during client config rpm creation
Add path to server SSL certificate to rhui-tools.conf so that we don't have t...
Status: CLOSED ERRATA
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-12 08:42 EDT by James Slagle
Modified: 2012-08-24 07:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Users are promted for the path to server SSL certificate during client config rpm creation. The path is now added to rhui-tools.conf so that users are no longer prompted for this path during client config rpm creation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 07:54:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Verifying screen log (23.58 KB, text/plain)
2012-07-26 08:03 EDT, mkovacik
no flags Details

  None (edit)
Description James Slagle 2012-06-12 08:42:41 EDT
Add path to server SSL certificate to rhui-tools.conf so that we don't have to prompt for it during client config rpm creation.
Comment 1 James Slagle 2012-06-12 08:47:42 EDT
committed to cloude master: 461fd760281f102a535948d6efd867ef6d35ca69
Comment 2 James Slagle 2012-06-12 08:49:24 EDT
QA:
The path to the CA that has signed the RHUA and CDS's server SSL certificates is now set in /etc/rhui/rhui-tools.conf as the rhua.ssl_ca_cert setting.
You're no longer prompted for this path during client config rpm creation.  Verify that the right cert has been used and that clients connect successfully to each CDS to download/update packages.
Comment 3 mkovacik 2012-07-26 08:03:24 EDT
Created attachment 600494 [details]
Verifying screen log

Verified in RHEL-6.3-RHUI-2.1-20120719.0-Server-x86_64-DVD1.iso. See the attachment...
Comment 4 sachua 2012-08-14 23:14:59 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Users are promted for the path to server SSL certificate during client config rpm creation. The path is now added to rhui-tools.conf so that users are no longer prompted for this path during client config rpm creation.
Comment 6 errata-xmlrpc 2012-08-24 07:54:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1205.html

Note You need to log in before you can comment on or make changes to this bug.